rodolfo

  • Posts

    204
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Applications

Everything posted by rodolfo

  1. @igor The MAC still seems to be newly created on each restart and udev-rules force a change in interface name ( wlan1 instead of wlan0 ) Quick and dirty workaround : sudo rm /etc/udev/rules.d/70-persistent-net.rules sudo echo # >/etc/udev/rules.d/75-persistent-net-generator.rules
  2. AP is solved for OPI ONE/LITE with USB dongles (this tutorial) and for OPI LITE internal wifi http://forum.armbian.com/index.php/topic/1241-opi-lite-wireless-device-not-working/ Enjoy
  3. @tkaiser, @igor, @jernej AP (master) mode and monitor mode both work Working tested AP mode sudo nano /etc/default/hostapd -------------------------------- DAEMON_CONF="/etc/hostapd.conf" -------------------------------- sudo nano /etc/hostapd.conf ------------------------------------------------------- ssid=xx_opilite1_xx interface=wlan0 hw_mode=g channel=5 driver=nl80211 logger_syslog=0 logger_syslog_level=0 wmm_enabled=1 ieee80211n=1 wpa=3 preamble=1 #wpa_psk=66eb31d2b48d19ba216f2e50c6831ee11be98e2fa3a8075e30b866f4a5ccda27 wpa_passphrase='12345678' wpa_key_mgmt=WPA-PSK wpa_pairwise=TKIP rsn_pairwise=CCMP auth_algs=1 macaddr_acl=0 noscan=1 #ht_capab=[HT40-][sHORT-GI-40][sHORT-GI-40][DSSS_CCK-40] country_code=CH #ieee80211d=1 -------------------------------- sudo nano /etc/network/interfaces -------------------------------- allow-hotplug wlan0 iface wlan0 inet static address 192.168.4.171 netmask 255.255.255.0 network 192.168.4.0 -------------------------------- Testing monitor mode A new virtual interface needs to be created for monitor mode sudo iw phy phy0 interface add wlan1 type monitor sudo ifconfig wlan1 192.168.5.171 sudo iwlist wlan1 scan ( ---> list of scanned SSIDs, just to show interface is up ) enjoy
  4. @Jernej and @Igor Thank you, the solution works for OPI LITE. @Igor - Please disable gmac in orangepilite.fex as it creates non-existing eth0 interface [gmac0] gmac_used = 0 gmac_power1 = - enable 8189fs in /etc/modules-load.d/modules.conf #-------------- working internal wifi 8189fs WIFI is stable, Iperf shows similar performance to USB-dongles on OPI LITE/ONE ( 75 mbps ) in noisy environment.
  5. OPI LITE with RTL8153 ( 35 MB/s ) on USB-OTG and two cheap USB 3.0 Flash Drives ( 17MB/s seq.write each ) are a nicely performing ultra-low-power (5V/1A) no-noise combination even with the current legacy kernel.
  6. In order to still use the OPI LITE boards before internal wifi is solved, OPI ONE settings can be used with disabled eth0 ( " gmac_used = 0 " in fex-file ). OPI LITE can then be used with USB-LAN and USB-WLAN per instructions given in http://forum.armbian.com/index.php/topic/1237-tutorial-opi-one-wireless-success/
  7. @tkaiser Wifi is not recognized with fex from post #10. Testing output as requested : armhwinfo.log.txt lshw.txt sdio.txt
  8. I've just received OPI LITE and start testing based on Armbian_5.10 I've adapted/customized for my use cases on OPI ONE. By using the (dvfs-corrected) OPI ONE fex-file for OPI LITE, disabling gmac (eth0) and not enabling internal wifi of the OPI LITE, the OPI LITE works just like the OPI ONE ( minus LAN ). Connections via external USB-LAN connector ( 278mbps ) and cheap wifi-dongle ( 50mbps with noise) are successfully tested. No valid testing output for internal wifi yet, will post as soon as tested.
  9. @p117 Welcome on board. USB-dongles are usually auto-mounted on a newly created mount point in /media. This is how you force it to be mounted at a predefined mount point. 1. Create a new mount point for your USB-dongle sudo mkdir /mnt/mydrive 2. Plug in your USB-drive and check the partition name ( e.g. /dev/sda1 ) Your drive is most likely formatted as vfat. sudo blkid /dev/mmcblk0p1: UUID="56a9eae3-fd35-47d4-a01c-00251c2d6a8d" TYPE="ext4" PARTUUID="00003286-01" /dev/mmcblk0: PTUUID="00003286" PTTYPE="dos" /dev/sda1: UUID="4732-9959" TYPE="vfat" 3. Use the unique identifier (UUID) of the filesystem on your USB-drive and add an entry to your /etc/fstab sudo nano /etc/fstab #----sample fstab-entry to mount specific USB-drive # the unique identifier UUID can be queried with # blkid # UUID="4732-9959" /mnt/mydrive vfat defaults,noatime 0 2 4. When you reboot, the USB-drive will be automatically mounted at /mnt/mydrive. Adjust permissions if needed. 5. Enjoy
  10. @xwalter I do understand your wish to use the OPI boards for something useful. I'll test OPI LITE's onboard wifi as soon as I get the boards, but having found a satisfactory solution with USB dongles I actually do not really care whether onboard wifi works right out of the box. Good luck with your project.
  11. @xwalter The manual is very specific about the USB dongles and drivers. Anything else is speculation.
  12. See earlier reply to your post. Remote desktop solutions are not geared at playing videos remotely. The reason you can comfortably view videos locally is GPU acceleration. Available bandwidth and necessary encoding/decoding for remote viewing make it very unlikely to arrive at at satisfactory solution. Stream your data and view it directly. Your sources of information would be mpv-forums. Good luck.
  13. With terminal servers (x2go/xrdp) installed and OPI ONE configured as wireless AP you are set up for some major fun. AP configuration see : http://forum.armbian.com/index.php/topic/1237-tutorial-opi-one-wireless-success/
  14. @xwalter X-mas is early with a special gift for you : http://forum.armbian.com/index.php/topic/1237-tutorial-opi-one-wireless-success/
  15. Relax : http://forum.armbian.com/index.php/topic/1237-tutorial-opi-one-wireless-success/
  16. Relax : http://forum.armbian.com/index.php/topic/1237-tutorial-opi-one-wireless-success/
  17. Relax - Wireless is solved for OPI ONE There seems to be a lot of confusion and missing information on how to access the dirt cheap OPI ONE wirelessly and the steps necessary to successfully use cheap Realtek USB dongles ( 8188cus, 8188eu ) with Armbian_5.10. This is a short summary of the needed materials and steps to turn your OPI ONE into a wireless client or wireless AP. There are NO custom kernels, custom modules or anything else needed, we are using stock Armbian_5.10 with stock kernel, stock modules and stock software to configure wireless access for select tested and working Realtek wifi dongles. Follow the steps without variation. Once you get wifi working you may adapt setup/configuration to your specific needs Prerequisites - OPI ONE with quality power supply 5V/2A - MicroSD ( 4G or higher ) with stock Armbian_5.10 installed per official instructions - Supported wifi USB dongle - LAN connection to host computer ( preferrably notebook running Linux ) for needed setup/configuration - WLAN-router accessible from host computer to test wireless connections. General procedure to set up wireless on OPI ONE - Set up your OPI ONE with basic Armbian_5.10 and configure a static IP LAN-address - Access OPI ONE via ssh from your host computer - Plug in wireless dongle and load correct driver module - check capabilities of wifi dongle (iw list) - configure wpa_supplicant for client mode - configure hostapd for AP mode >>> all configurations will be minimal without added automagic complexities ( bridges, DHCP etc...) OPI ONE wireless client Module 8192cu works with Realtek 8188CUS dongles and provides a wireless interface wlan0 ready to be configured in managed mode with wpa_supplicant. nano /etc/modules-load.d/modules.conf ===================================== #8189es 8192cu nano /etc/network/interfaces (adapt to your network setup) ========================================================== auto lo iface lo inet loopback #----- lan interface ( standard maintenance connection via ssh ) allow-hotplug eth0 iface eth0 inet static address 192.168.3.164 netmask 255.255.255.0 network 192.168.3.0 #----- Realtek 8192cu wlan interface client ( access defined in /etc/wpa_supplicant/wpa_supplicant.conf ) allow-hotplug wlan0 iface wlan0 inet static address 192.168.2.164 netmask 255.255.255.0 network 192.168.2.0 broadcast 192.168.2.255 gateway 192.168.2.77 dns-nameservers 192.168.1.1 dns-nameservers 8.8.8.8 wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf nano /etc/wpa_supplicant/wpa_supplicant.conf ============================================ ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 network={ ssid="<your_ssid>" psk="<your_password>" key_mgmt=WPA-PSK priority=99 } After restarting OPI ONE it should be connected to your configured wireless router and accessible under the static IP. Wireless connection is working now and the rest is up to your hopefully wild imagination and creativity. Tested working dongles RTL8188CUS cheap no-name dongle from Aliexpress ( < $2 ) Bus 002 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter RTL8188CUS Edimax EW-7811Un high quality dongle ( $10 ) Bus 001 Device 008: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS] Wifi performance is not stellar, but definitely adequate. Under ideal conditions ( same room as router, little interference ) speeds of 80mbps ( measured with iperf ) can be expected. Crossing two walls at 20m distance from router the signal was still usable yielding 20mbps. OPI ONE access point + wireless client Surprise : You were asking for AP mode and now you are getting AP deluxe with an extra client interface for free. Module 8188eu works with Realtek 8188EU dongle and provides TWO wireless interfaces : wlan0 is ready to be configured in AP mode with hostapd and wlan1 in managed mode with wpa_supplicant. When the dongle is plugged in and the driver correctly loaded, iw list will enumerate the drivers parameters for the two new interfaces. iwconfig will show wlan0 and wlan1. nano /etc/modules-load.d/modules.conf ===================================== #8189es 8188eu nano /etc/default/hostapd ========================= DAEMON_CONF="/etc/hostapd.conf" nano /etc/network/interfaces ============================ auto lo iface lo inet loopback #----- lan interface ( standard maintenance connection via ssh ) allow-hotplug eth0 iface eth0 inet static address 192.168.3.164 netmask 255.255.255.0 network 192.168.3.0 #----- Realtek 8188eu wlan interface AP ( access defined in /etc/hostapd.conf ) allow-hotplug wlan0 iface wlan0 inet static address 192.168.4.164 netmask 255.255.255.0 network 192.168.4.0 #----- Realtek 8188eu wlan interface client ( access defined in /etc/wpa_supplicant/wpa_supplicant.conf ) allow-hotplug wlan1 iface wlan1 inet static address 192.168.2.164 netmask 255.255.255.0 network 192.168.2.0 broadcast 192.168.2.255 gateway 192.168.2.77 dns-nameservers 192.168.1.1 dns-nameservers 8.8.8.8 wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf nano /etc/hostapd.conf ====================== ssid=<your-OPI-ONE-ssid> interface=wlan0 hw_mode=g channel=5 driver=nl80211 logger_syslog=0 logger_syslog_level=0 wmm_enabled=1 ieee80211n=1 wpa=3 preamble=1 #wpa_psk=66eb31d2b48d19ba216f2e50c6831ee11be98e2fa3a8075e30b866f4a5ccda27 wpa_passphrase='12345678' wpa_key_mgmt=WPA-PSK wpa_pairwise=TKIP rsn_pairwise=CCMP auth_algs=1 macaddr_acl=0 noscan=1 #ht_capab=[HT40-][sHORT-GI-40][sHORT-GI-40][DSSS_CCK-40] country_code=<your country code> #ieee80211d=1 nano /etc/wpa_supplicant/wpa_supplicant.conf ============================================ ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 network={ ssid="<your-router-ssid>" psk="<your-router-password>" key_mgmt=WPA-PSK priority=99 } After restarting OPI ONE it should be connected to your configured wireless router and accessible under the static IP. On your notebook the newly created OPI ONE access point should be visible when scanning. Specify a static IP for the link and connect using the chosen password ( e.g. '12345678' ) . Feel like a hero, empty a sixpack and order more pizza.... Wireless connection is working now and the rest is up to your hopefully wild imagination and creativity. Tested working dongle for AP mode : RTL8188EU cheap no-name dongle from Aliexpress ( $2.20 ) Bus 001 Device 009: ID 0bda:0179 Realtek Semiconductor Corp. ( noname identified as 8188EU ) Wifi performance with both interfaces active is surprisingly good. Under ideal conditions ( same room as router, little interference ) speeds of 60 (client) / 30 (AP) mbps can be expected. Crossing two walls at 20m distance from router signals were still usable yielding 20 (client) / 5 (AP) mbps. Troubleshooting Most of the problems encountered while setting up WIFI are caused by inadequate or overly complicated testing setups, procedures and rampant wild guesses. Keep it simple and solve one problem at a time. As a stable datum you should realize that the procedures outlined above DO WORK and have been adequately TESTED and RETESTED.. Solution No. 1 : Follow the steps outlined Solution No. 2 : Find out where you did not follow the steps outlined Solution No. 3 : Find out what you added to the steps outlined Solution No. 4 : Reiterate Good luck with your wireless OPI ONE, enjoy and flood the forum with working solutions.
  18. @technik007_cz See http://forum.armbian.com/index.php/topic/749-orange-pi-pc-wireless-module-8192cu/
  19. Adding few more cpufreq operating points sounds great. Governor "ondemand" used more frequencies than "interactive" when tested, leading to cooler running and less current draw.
  20. @tkaiser Thanks for detailling the rationale for H3 optimizations. IMHO the OPI ONE/LITE merit simple foolproof settings appropriate to running the boards within safe limits. A well-performing cheap little powerhouse without overclocking, overvolting, throttling, fans... running on stable Armbian. OPI ONE / (and probably LITE from the specs) run well with 2 dvfs operating points. Switching between 1.1V and 1,3V at 816 MHz ( lower than tested 1008 MHz ) should embrace any board quality. As I've mentioned before, using governor "ondemand" instead of "interactive" seems appropriate for OPI ONE when testing with typical and even more when testing with higher loads. Boards with a more sophisticated voltage/frequency control definitely merit appropriate testing/monitoring/optimization tools. For OPI ONE/LITE it is probably an overkill. By keeping it simple and using the simple boards well within their limits, the true power of these tiny jewels is unleashed : pleasing performance at a ridiculous price.
  21. OPI ONE is running stably and relatively cool with new settings : http://forum.armbian.com/index.php/topic/1122-arisc-errors-have-returned/
  22. Thermal : http://forum.armbian.com/index.php/topic/1122-arisc-errors-have-returned/
  23. I've retested different settings for [dvfs_table] and actually noticed no different behaviour for 2 or 5 levels. There are only two voltages anyway, so the min, max and voltage change frequencies are all that matter. I've put some more load on the running system and tested the impact of the governor. By default. the governor is set to "interactive", a supposedly optimized "ondemand" governor adjusting frequency levels to loads. The "interactive" governor running on the OPI ONE behaved more like "performance", hardly ever switching from max.frequency and producing rather high cpu-temperatures ( no drama at all, I was just joking about the towering inferno boards , mea culpa, mea maxima culpa .....). A very noticeable change happened when switching to "ondemand" governor. Suddenly, the whole frequency range was being used, temperature dropped by 9°C and current draw was reduced by 50mA. With previously mentioned ( or soon to be released in Armbian ) fex-settings and a small heatsink on the OPI ONE the board behaves very nicely under the testing load ( x2go-server, flash dongle file-server with 2 parallel 4G scp network file-copies wireless and wired , modest browsing in iceweasel ) temperatures 39 (idle) , 59 (typical load) and 79 ( lots of stress ) when running governor "interactive" temperatures 39 (idle) , 50 (typical load) and 77 ( lots of stress ) when running governor "ondemand" To test governor "ondemand" : sudo echo ondemand>/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor To revert to governor "interactive" : sudo echo interactive>/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor To configure default governor "ondemand" : sudo nano /etc/default/cpufrequtils ------------------------ ENABLE=true MIN_SPEED=480000 MAX_SPEED=1200000 GOVERNOR=ondemand ------------------------ To check board temperature and current frequency : sudo watch cat /sys/class/thermal/thermal_zone0/temp sudo watch -n .1 cpufreq-info -w