Jump to content

Search the Community

Showing results for tags 'orangepilite'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community
    • Announcements
    • Feature Requests
  • Using Armbian
    • Beginners
    • Software, Applications, Userspace
    • Advanced users - Development
  • Upcoming Hardware (WIP)
    • News
    • Odroid M1
    • ROCK 5B
  • Maintained Hardware
    • Board does not start
    • Amlogic meson
    • Allwinner sunxi
    • Marvell mvebu
    • Rockchip
    • Other families
  • Unmaintained (CSC/EOL/TVB) / Other
    • TV boxes
    • Off-topic
    • Amlogic meson
    • Allwinner sunxi
    • Marvell mvebu
    • Rockchip
    • Other families

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Matrix


Mastodon


IRC


Website URL


XMPP/Jabber


Skype


Github


Discord


Location


Interests

  1. Hi. After 2 years uptime it disconnected from wifi and was unable to reconnect even after reboot. I suspect my AC adapter has degraded. Can this SBC measure the voltage? Upd: saw this post: https://raspberrypi.stackexchange.com/questions/112122/wifi-not-connecting-depending-on-power-supply I use NetworkManager and when it starts it usually cannot connect to wifi saying that the pre-shared key is wrong, marking the connection as failed and not re-trying. In particular, the log contained a failed "asking for new key" message. Re-starting the service or manually activating the connection worked. As a workaround I created a *.conf file in /etc/NetworkManager/conf.d/ : [main] autoconnect-retries-default=0 Not sure if it helped though. One boot had a different error and a re-try. The other boot suddenly connected with the 1st attempt.
  2. I have an orange pi lite, I want to use the lcd ili9341 TFT 320X240 2.8 Inch touch screen, and by header 34 pin and how the installation connections I don't know I need your help. I be very grateful. The OS is "Armbian_22.08.2_Orangepilite_jammy_current_5.15.69_xfce_desktop" And I'm looking for 2.8 inch LCD setup codes on Armbian for Orange Pi Lite!
  3. Hello everyone, I need to run below code so I can convert speech to text on my OPi Lite. ////////////// import speech_recognition as sr rec = sr.Recognizer() with sr.Microphone() as source: audio = rec.record(source, duration=15) print("Converting...") output_text = rec.recognize_google(audio) print(output_text) ////////////// speech recognition is installed, but everytime I try to run below code, I am getting these odd errors. I tried several different ways, wonder if someone have had same issue and had fixed it. ///Error//// ALSA lib pcm.c:2664snd_pcm_open_noupdate) Unknown PCM cards.pcm.front ALSA lib pcm.c:2664snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear ALSA lib pcm.c:2664snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe ALSA lib pcm.c:2664snd_pcm_open_noupdate) Unknown PCM cards.pcm.side ALSA lib pcm.c:2664snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21 ALSA lib pcm.c:2664snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround21 ALSA lib pcm.c:2664snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround40 ALSA lib pcm.c:2664snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround41 ALSA lib pcm.c:2664snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround50 ALSA lib pcm.c:2664snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround51 ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.surround71 ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958 ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958 ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.iec958 ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline ALSA lib pcm.c:2664:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline Cannot connect to server socket err = No such file or directory Cannot connect to server request channel jack server is not running or cannot be started JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock Cannot connect to server socket err = No such file or directory Cannot connect to server request channel jack server is not running or cannot be started JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock ALSA lib pcm_oss.c:397:(_snd_pcm_oss_open) Cannot open device /dev/dsp ALSA lib pcm_oss.c:397:(_snd_pcm_oss_open) Cannot open device /dev/dsp ALSA lib pulse.c:242:(pulse_connect) PulseAudio: Unable to connect: Connection refused ALSA lib pulse.c:242:(pulse_connect) PulseAudio: Unable to connect: Connection refused ALSA lib confmisc.c:160:(snd_config_get_card) Invalid field card ALSA lib pcm_usb_stream.c:482:(_snd_pcm_usb_stream_open) Invalid card 'card' ALSA lib confmisc.c:160:(snd_config_get_card) Invalid field card ALSA lib pcm_usb_stream.c:482:(_snd_pcm_usb_stream_open) Invalid card 'card' Cannot connect to server socket err = No such file or directory Cannot connect to server request channel jack server is not running or cannot be started JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
  4. Hi there, I need to install below libraries on my orange pi lite, on a virtual environment tensorflow 2 keras numpy pandas OrangePi.GPIO does anyone have a armbian image including all these libraries pre-installed. because everytime I try to do it, I face lots of odd errors, mostly for installing tensorflow 2, and installing anyone of libraries on virtual environment.
  5. I try to communicate nextion display with Orange pi lite, I can receive data from the display, but can’t send it using WiringSerial library. if I use common file write(), and try to catch an error by errno.h, it gives me: value of errno 14 error printed by errno: bad address.
  6. Hi, I followed the following link to create encrypted root. However, every time I boot, i don't see any prompt for password. My armbianEnv.txt is following", but nothing display at "Console" (HDMI) or "Serial" (debug 3 pins next to USB port). ~ Has anyone had any success? I did this for OrangePi Lite 2 (64-bit) H6 and no issue. Thanks
  7. Hi, I am unable to build any images for orangepi SOCs specifically orangepilite, orangepilite2 and one plus. Always returned error halfeway. Following is a sample of log when I compile image for orange pi lite. Please me some guidance on how to resolve this. My steps: run sudo compile.sh -- "Do no tchnage the kernel..." --> "orangepilite"--> either current or legacy --> either "buster" -->"Image with console inter..." -->"Standard image with ..."compilation.log
  8. Hi, I have been running Armbian on OrangePi Lite for more than a year just fine. Then I decided to upgrade and flashed the latest version. Now with the latest version the device looses wifi every few days no matter which wifi device I use. In order to investigate I have plugged additional USB wifi. Some time both wifi work. Then built-in may disconnect and stop working, but USB keeps working. Or vice versa, USB stops working, but the built in keeps working. I have been able to send syslog to an external machine and here what it showed Connection works fine: The next day one of the connections stops working and complains that the WPA key may be wrong: Obviously, nothing has changed, the hotspot is still the same and WPA key has not been changed. Both wifi connections are using the same key, and one works fine. Rebooting resolves the issue, but after few days it is back again. Anyone have seen this behavior? Before downgrading to a version prior 2020 I'd like to check as much as possible if this is some bug Thanks
  9. hi i try to load bootlog from /boot/mmc on orange pi lite when add bootlogo=true to armbianEnv only armbian logo show. i check u-boot and it send an erro "Unknown command 'bmp' - try 'help'" i check u-boot env and u-boot dont have bmp command. ow can I fix this.
  10. Hi, root@orangepilite:~# armbianmonitor -u System diagnosis information will now be uploaded to Please post the URL in the forum where you've been asked for. I'm trying to connect my PI board to my smartphone's phone hotspot. I tried with different phones (ASUS Zenfon, Huawei P10, iPhone 11) - "nmcli dev wifi" does not display my hotspots, however nearby computers and the phones themselves do see the hotspots. The PI finds many wifi networks around and use one of them w/o issues: root@orangepilite:~# nmcli dev wifi IN-USE SSID MODE CHAN RATE SIGNAL BARS SECURITY * fbk.info Infra 6 270 Mbit/s 70 ▂▄▆_ WPA2 TP-Link_4339 Infra 4 270 Mbit/s 57 ▂▄▆_ WPA2 dlink-25C4 Infra 2 270 Mbit/s 49 ▂▄__ WPA1 WPA2 Pavel Infra 13 270 Mbit/s 47 ▂▄__ WPA2 ... Any ideas what's going on? Thanks in advance!
  11. Hi, I have connected Orange Pi Lite over serial UART, but looks like the default settings are to not output the boot log to serial. You can only see U-Boot messages, then "Uncompressing Linux kernel" and after some time the login prompt comes. What exactly do I need to change/configure to get the classic kernel boot log to serial console? Thanks
  12. Hello, I installed Armbian (image from here https://www.armbian.com/orange-pi-lite/ [Buster / mainline based kernel 5.4.y]). After booting on OPi Lite everithing works fine. I have updated and upgraded OS. Reboot, shutdown and again turn on the board works just fine. I decided to download desktop for this image. Desktop was downloaded and installed successfully (with armbian-config). Everything works fine. After reboot, shutdown, turn off by unplugging the cable, Armbian on my OPi Lite does not wake up anymore. When I will load this image again, everything works fine by the time I will download and install desktop and turn off the board. I have tried other distribiutions like Ubuntu and Debian from Orange Pi website. There is no issiues with those OS's. Only with Armbian after installing desktop I can not boot OS on OPi Lite anymore. I have changed SD cards, powersupplies and measured voltage while booting, (working properly, after and while cannot boot) for them, everything correct. Without desktop everything works as expected. I use recommended Etcher to upload images to SD card. I tried to connect USB to TTl converter to UART to check if board outputs something in this weird state. Nothing appears in Putty, (Rx to Tx and vice versa, 3.3V, common ground, correct port and baud rate 115200). When my board is in this weird state, green LED is ligthing all the time like when it is working normally before desktop. My display changes state to Power Saving Mode every second what is unexpected. After unplugging power supply it stops. When UART connected, green LED sometimes blinks randomly. I have unplugged antenne, plugged antene, keyboard and mouse is via wireless donge, tired with plugged unplugged, display is connected via HDMI and HDMI to DVI converter, tried with plugged and unplugged, on unplugged no response on URAT too. I have no more ideas of mine and from this and other forums, maybe I missed something.
  13. Hi, i use orangepi lite with armbian buster and kernel 5.4.35 my journal flooding with messages: May 02 09:50:11 orali kernel: RTL871X: CurIGValue=31, EntryMinUndecoratedSmoothedPWDB = 30 May 02 09:50:13 orali kernel: RTL871X: CurIGValue=31, EntryMinUndecoratedSmoothedPWDB = 31 May 02 09:50:15 orali kernel: RTL871X: CurIGValue=31, EntryMinUndecoratedSmoothedPWDB = 32 May 02 09:50:17 orali kernel: RTL871X: adaptive_early_32k(): bcn_cnt = 101 May 02 09:50:17 orali kernel: RTL871X: CurIGValue=31, EntryMinUndecoratedSmoothedPWDB = 31 May 02 09:50:19 orali kernel: RTL871X: CurIGValue=31, EntryMinUndecoratedSmoothedPWDB = 32 May 02 09:50:21 orali kernel: RTL871X: CurIGValue=31, EntryMinUndecoratedSmoothedPWDB = 32 How can i stop this? Thank you! Al
  14. I want to create an image file with yocto. There is no orangepilite in the link "https://github.com/linux-sunxi/meta-sunxi" . I created an image file for orangepione. kernel did not stand up. then I downloaded the metalayer in the link https://github.com/abradianu/meta-orangepi/. I made the following changes. ../conf/local.conf/ MACHINE ??= "orangepi-lite" ../conf/bblayers.conf /home/e2das//Desktop/yocto/poky/meta-orangepi \ then I ran the bitbake core-image-base ERROR: /home/e2das/Desktop/yocto/poky/meta/recipes-sato/images/core-image-sato.bb: Deprecated variable(s) found: "IMAGE_DEPENDS_sunxi-sdimg". Use do_image_<type>[depends] += "<recipe>:<task>" instead--:-- ERROR: /home/e2das/Desktop/yocto/poky/meta/recipes-sato/images/core-image-sato-sdk.bb: Deprecated variable(s) found: "IMAGE_DEPENDS_sunxi-sdimg". Use do_image_<type>[depends] += "<recipe>:<task>" instead ERROR: /home/e2das/Desktop/yocto/poky/meta/recipes-sato/images/core-image-sato-sdk-ptest.bb: Deprecated variable(s) found: "IMAGE_DEPENDS_sunxi-sdimg". Use do_image_<type>[depends] += "<recipe>:<task>" instead ERROR: /home/e2das/Desktop/yocto/poky/meta/recipes-rt/images/core-image-rt.bb: Deprecated variable(s) found: "IMAGE_DEPENDS_sunxi-sdimg". Use do_image_<type>[depends] += "<recipe>:<task>" instead ERROR: /home/e2das/Desktop/yocto/poky/meta/recipes-rt/images/core-image-rt-sdk.bb: Deprecated variable(s) found: "IMAGE_DEPENDS_sunxi-sdimg". Use do_image_<type>[depends] += "<recipe>:<task>" instead ERROR: /home/e2das/Desktop/yocto/poky/meta/recipes-sato/images/core-image-sato-dev.bb: Deprecated variable(s) found: "IMAGE_DEPENDS_sunxi-sdimg". Use do_image_<type>[depends] += "<recipe>:<task>" instead ERROR: Failed to parse recipe: /home/e2das/Desktop/yocto/poky/meta/recipes-sato/images/core-image-sato-sdk.bb what should I do.
  15. hi good night i have an orange pi lite, i want to use the (lcd ili9341 3.2 model MSP3218) touch screen and how the installation connections i don't know are correct in these connections in gpios and why my pc broke and qr use orange as desktop i need your help. I will be grateful. I want to connect to the retrorange pi 4.2 system how do I install lcd 3.2 on orange lite? https://mobile4dev.blogspot.com/2017/09/orange-pi-pc-tft-ili9341.html?fbclid=IwAR2h4HLkaBtLA7W5cfXobFbvFkZory0Wznvnju6fMrYzOcDVe1k7oBTwwRw
  16. Hi, I'm running the following kernel on my Orange Pi Lite: Linux lights 5.3.9-sunxi #19.11.3 SMP Mon Nov 18 18:49:43 CET 2019 armv7l GNU/Linux I'm getting the following crash in the WiFi driver (copy-pasted from dmesg) after some time (about 10 hours if I read the output correctly?). [36792.103947] ------------[ cut here ]------------ [36792.104326] WARNING: CPU: 3 PID: 1108 at drivers/net/wireless/realtek/rtl8189fs/core/rtw_mlme.c:2622 rtw_stadel_event_callback+0x41/0x1fa [8189fs] [36792.104331] Modules linked in: snd_soc_hdmi_codec snd_soc_simple_card snd_soc_simple_card_utils sun8i_codec_analog sun4i_i2s sunxi_cir sun8i_adda_pr_regmap snd_soc_core lima sun4i_gpadc_iio snd_pcm_dmaengine dw_hdmi_cec dw_hdmi_i2s_audio gpu_sched snd_pcm cdc_acm industrialio snd_timer input_leds snd sun8i_thermal soundcore zram evdev uio_pdrv_genirq uio cpufreq_dt g_serial libcomposite 8189fs cfg80211 rfkill ip_tables x_tables hid_lenovo gpio_keys [36792.104402] CPU: 3 PID: 1108 Comm: RTW_CMD_THREAD Not tainted 5.3.9-sunxi #19.11.3 [36792.104406] Hardware name: Allwinner sun8i Family [36792.104431] [<c010d6d9>] (unwind_backtrace) from [<c010a14d>] (show_stack+0x11/0x14) [36792.104444] [<c010a14d>] (show_stack) from [<c091a425>] (dump_stack+0x69/0x78) [36792.104458] [<c091a425>] (dump_stack) from [<c011b54b>] (__warn.part.3+0x83/0x9a) [36792.104468] [<c011b54b>] (__warn.part.3) from [<c011b665>] (warn_slowpath_null+0x33/0x36) [36792.104648] [<c011b665>] (warn_slowpath_null) from [<bf899749>] (rtw_stadel_event_callback+0x41/0x1fa [8189fs]) [36792.104920] [<bf899749>] (rtw_stadel_event_callback [8189fs]) from [<bf8a305d>] (mlme_evt_hdl+0x57/0x64 [8189fs]) [36792.105172] [<bf8a305d>] (mlme_evt_hdl [8189fs]) from [<bf88b6e3>] (rtw_cmd_thread+0x14b/0x218 [8189fs]) [36792.105309] [<bf88b6e3>] (rtw_cmd_thread [8189fs]) from [<c013339d>] (kthread+0xfd/0x104) [36792.105321] [<c013339d>] (kthread) from [<c01010f9>] (ret_from_fork+0x11/0x38) [36792.105325] Exception stack(0xcfd67fb0 to 0xcfd67ff8) [36792.105332] 7fa0: 00000000 00000000 00000000 00000000 [36792.105339] 7fc0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 [36792.105344] 7fe0: 00000000 00000000 00000000 00000000 00000013 00000000 [36792.105350] ---[ end trace 4f359df1c8c4b9f9 ]--- [41403.988509] ------------[ cut here ]------------ [41403.988704] WARNING: CPU: 3 PID: 8374 at net/wireless/sme.c:756 __cfg80211_connect_result+0x313/0x380 [cfg80211] [41403.988717] Modules linked in: snd_soc_hdmi_codec snd_soc_simple_card snd_soc_simple_card_utils sun8i_codec_analog sun4i_i2s sunxi_cir sun8i_adda_pr_regmap snd_soc_core lima sun4i_gpadc_iio snd_pcm_dmaengine dw_hdmi_cec dw_hdmi_i2s_audio gpu_sched snd_pcm cdc_acm industrialio snd_timer input_leds snd sun8i_thermal soundcore zram evdev uio_pdrv_genirq uio cpufreq_dt g_serial libcomposite 8189fs cfg80211 rfkill ip_tables x_tables hid_lenovo gpio_keys [41403.988811] CPU: 3 PID: 8374 Comm: kworker/u8:2 Tainted: G W 5.3.9-sunxi #19.11.3 [41403.988814] Hardware name: Allwinner sun8i Family [41403.988879] Workqueue: cfg80211 cfg80211_event_work [cfg80211] [41403.988903] [<c010d6d9>] (unwind_backtrace) from [<c010a14d>] (show_stack+0x11/0x14) [41403.988917] [<c010a14d>] (show_stack) from [<c091a425>] (dump_stack+0x69/0x78) [41403.988931] [<c091a425>] (dump_stack) from [<c011b54b>] (__warn.part.3+0x83/0x9a) [41403.988941] [<c011b54b>] (__warn.part.3) from [<c011b665>] (warn_slowpath_null+0x33/0x36) [41403.989004] [<c011b665>] (warn_slowpath_null) from [<bf849eaf>] (__cfg80211_connect_result+0x313/0x380 [cfg80211]) [41403.989123] [<bf849eaf>] (__cfg80211_connect_result [cfg80211]) from [<bf827bff>] (cfg80211_process_wdev_events+0xaf/0xec [cfg80211]) [41403.989233] [<bf827bff>] (cfg80211_process_wdev_events [cfg80211]) from [<bf827c65>] (cfg80211_process_rdev_events+0x29/0x68 [cfg80211]) [41403.989341] [<bf827c65>] (cfg80211_process_rdev_events [cfg80211]) from [<bf8231e3>] (cfg80211_event_work+0x17/0x1c [cfg80211]) [41403.989404] [<bf8231e3>] (cfg80211_event_work [cfg80211]) from [<c012ebf3>] (process_one_work+0x167/0x37c) [41403.989415] [<c012ebf3>] (process_one_work) from [<c012fb03>] (worker_thread+0xfb/0x3f4) [41403.989426] [<c012fb03>] (worker_thread) from [<c013339d>] (kthread+0xfd/0x104) [41403.989435] [<c013339d>] (kthread) from [<c01010f9>] (ret_from_fork+0x11/0x38) [41403.989439] Exception stack(0xc8b55fb0 to 0xc8b55ff8) [41403.989445] 5fa0: 00000000 00000000 00000000 00000000 [41403.989452] 5fc0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 [41403.989458] 5fe0: 00000000 00000000 00000000 00000000 00000013 00000000 [41403.989519] ---[ end trace 4f359df1c8c4b9fa ]--- I don't know enough to track this down further - does anybody know where to report this next to hopefully help somebody fix it? Thanks! Leon
  17. I want my armbian (running on OrangePi lite) to output 2560x1440p60 resolution. the h3disp tool has an option for 2048x1536 (3:4) but not for 1440p. How can I get 1440p output?
  18. Hi ! I am using Armbian_5.65_Orangepilite_Debian_stretch_next_4.14.78armbian deb stretch image on orange pi lite. Its working great for the most part, but it misses the starting portion of the audio. I have installed snips voice assistant on it and for some reason the speaker does not produce the confirmation sound output on hotword detection. But plays rest of the sound outputs after that for another 5 seconds or so. Missing the confirmation sound from a smart speaker is really annoying. Is that a bug? Is there a possible workaround? Is any way this can be solved properly? Please point me in the right direction
  19. Here is uploaded image showing problem with text overlapping. I googled without success, so if anyone could suggest how to try fixing it. Chromium version is 76.0.3809.100 (Official Build) Built on Ubuntu, running on Ubuntu 16.04 (32-bit) on Orange Pi Lite. It is not big deal, but if there is easy fix why not to try.
  20. I‘m using an OrangePi Lite with the intent to display a 4kp30 video to a 4k TV over hdmi. from reading through the forums I saw that mainline kernel does not support video acceleration - is this information current? after installing the Xenial Image with 3.4 kernel I manage to play 1440p video smoothly two ways with mpv: - windowed if display resolution is set to 4k -fullscreen if display resolution is set to 1080p if I try to run the 1440p video at 4k display resolution in fullscreen, the app crashes with messages about ‚not enough resources to create surface‘ and the framebuffer stays corrupted after that and I have to reboot. The same happens if I try to play the 4k30p video (independently of whether I run it fullscreen or windowed, 4k or 1080p display res. I also tried both h264 and h265). I Played around with extraargs=cma=... sunxi_ve_mem_reserve=... in ArmbianEnv.txt but it didn‘t seem to have effect. The docs state that in the 3.4 kernel the video memory is hardcoded to 80MB (not sure if I understood that correctly though) which probably would prevent 4k playback with that kernel. on https://linux-sunxi.org/Cedrus/libvdpau-sunxi it's stated that: This can be set by the following kernel argument. sunxi_ve_mem_reserve=128 NOTE: This kernel parameter is ignored in recent linux-sunxi 3.4 kernels, if CMA is enabled in kernel configuration. If CONFIG_CMA=y, ve_size is hardcoded to 80MB in sunxi_cedar kernel module. For A33 or H3, if you use the kernel from official SDK, you should modify the memory reservation configuration of ion memory allocator. 32 MB seems to be enough for 720p H.264 decoding, and 64MB is enough for 1080p H.264 decoding. But I don't know what it means to modify the memory reservation configuration of ion memory allocator and how to do that? Is there any kernel available which can playback hardware accelerated 4k30p video on Orange Pi Lite (H3) and if so, how do I need to go about to setup my Xenial installation to make use of it?
  21. Hi, as it is quite hot now in Europe, one of my boards is experiencing overheat and shuts down automatically: Jun 25 16:52:27 localhost kernel: [74505.568246] thermal thermal_zone0: critical temperature reached (90 C), shutting down Who is initiating this shutdown? Is it possible to: 1. Change the temperature value that triggers the shutdown 2. Hook a script instead of direct shutdown so I can handle the overheat Thanks
  22. Hi , I'm using orange pi lite (H3) and armbian xenial desktop. When I plug in my adata 8GB flash drive armbian couldn't find it. What should I do?
  23. Hey,I'm using Lg 19M38A 18.5 inch monitor .when I plug in my orange pi , only monitor shows the booting process and then the black screen up .how can I fix this problem?
  24. Hi, I try to connect Orangepi lite to SIM800l module. I don't have any response on AT commands. I checked the module with Arduino and it works. So I connected Arduino and Orangepi and I can send messages from Arduino to Orangepi, but I can't get any message from Orangepi to Arduino. 1, On Orangepi I allowed UART3 via editing /boot/script.bin [uart3] uart_used = 1 uart_port = 3 uart_type = 4 uart_tx = port:PA13<3><1><default><default> uart_rx = port:PA14<3><1><default><default> uart_rts = port:PA15<3><1><default><default> uart_cts = port:PA16<3><1><default><default> 2, I didn't do anything with GPIO definitions, because I didn't find any such pin definitions in the /boot/script.bin. 3, The physical connection of pins (rx->tx, tx->rx) should be fine. I tried to swith them either. 4, For reading the port I use this simple script.. import serial serport = serial.Serial("/dev/ttyS3", 9600, timeout=1) while True: while serport.inWaiting() > 0: c = serport.read() print(c) As I've already mentioned, it can read messages from Arduino serial monitor. 5, For writing to the port I use this one... import serial serport = serial.Serial("/dev/ttyS3", 9600, timeout=1) while True: txt = raw_input("Type something: ") serport.write(txt) No message gets to Arduino monitor.... Any clue? Thank you, Mapek
  25. Hello, I recently installed Armbian 5.85 legacy on my new Orange Pi Lite in order to try out my new Orange Pi camera, but it's not being recognized at all, even after following the instructions in this topic: I already tried doing the following (as root) unsuccessfully (no errors returned, but still can't detect camera): sunxi-pio -m "PG11<1><0><1><1>" #DOVDD sunxi-pio -m "PE15<1><0><1><0>" #Power_Down sunxi-pio -m "PE14<1><0><1><1>" #reset modprobe gc2035 modprobe vfe_v4l2 Here's the output of lsusb: Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Unfortunately, Armbian 5.20 is no longer available, so I can't try that unless I can compile it from source.
×
×
  • Create New...