Setting up Static IP address not working


Recommended Posts

Hello everybody,

 

im running a Helios64 with most current Debian Buster5.10.16 image.

 

I was freshly setting up the device and i am now failing to assign a static ip address to it.

 

I installed Pi-hole, Home assistant and openmediavault over softy.

 

During the pihole installation i can setup a static ip address, but after a reboot i still get the old DHCP addess.


I assigned it over the OMV interface but its not applied after a reboot, the armbian-config tool doesnt open when i want to change to static and i also tried netplan.

 

DHCP is also turned off on my router and switch. i rebooted all of the devices multiple times.

 

OMV

1186219897_UnbenanntesBild.thumb.png.5d25bb6e789820c2178ea786e9a556c9.png

 

netplan

 

network:

  ethernets:

    eth0:

      match:

        macaddress: 64:62:66:d0:0a:e0

      addresses:

      - 192.168.2.64/24

      gateway4: 192.168.2.1

      dhcp4: false

      dhcp6: false

      link-local: []

      nameservers:

        addresses:

        - 127.0.0.1

 

 

/etc/network/interfaces

# This file is auto-generated by openmediavault (https://www.openmediavault.org)

# WARNING: Do not edit this file, your changes will get lost.

 

# interfaces(5) file used by ifup(8) and ifdown(8)

# Better use netplan.io or systemd-networkd to configure additional interface stanzas.

 

# Include files from /etc/network/interfaces.d:

source-directory /etc/network/interfaces.d

Link to post
Share on other sites

Donate and support the project!

Hello tparys,

 

thank you for you reply

 

service network status
Unit network.service could not be found.

 

/etc/network/interfaces.d

its empty

 

armbianmonitor -u

http://ix.io/2POV

 

tried

 

nmcli con mod "Wired connection 1"  ipv4.addresses "192.168.2.64/24"  ipv4.gateway "192.168.2.1"  ipv4.dns "127.0.0.1,192.168.2.1"  ipv4.dns-search "lan" ipv4.method "manual"

 

didnt do the trick

 

EDIT2: I just tried a fresh install and apparently the OMV installation breaks something regarding networking.

I setup a static ip via armbian-config and i worked, but when i installed OMV over softy, the CPU run on 100% on one core and the system crashed.

After the automated reboot its back to its DHCP IP 192.168.2.101 instead of 192.168.2.64

 

grafik.thumb.png.ab87fd869578fcd63acb0713d4f539ad.png

Link to post
Share on other sites

So I'm not super familiar with OMV, so take al this with a grain of salt.

 

However, I find it easiest to set static IP's via ifupdown. Based on the "source-directory" line you might just put the below in "/etc/network/interfaces.d/eth0", and enable via "systemctl enable networking", and see if that works for you.

 

iface eth0 inet static
            address 192.168.2.64/24
            gateway 192.168.2.1

 

Another option for NetworkManager is to use the "nm-connection-editor" application. There's a lot of options for specifying network configurations. I'd check that your IPv4 settings are set up correctly, and you tick the "Connect Automatically" and "All users may connect" tick boxes.

 

I'm not at all familiar with netplan. But it might be as simple as checking to see if "io.netplan.Netplan.service" is enabled/started?

 

Failing that, it might just be easier to set a static IP on your home router?

Link to post
Share on other sites

> nmcli con mod "Wired connection 1"  ipv4.addresses "192.168.2.64/24"  ipv4.gateway "192.168.2.1"  ipv4.dns "127.0.0.1,192.168.2.1"  ipv4.dns-search "lan" ipv4.method "manual"

 

This tells me you're still using NetworkManager - one option as tparys suggested is to configure that properly - but I'm thinking you probably don't need it anyway?

 

Just do `systemctl disable NetworkManager.service` and it should get out of your way.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

0