Jump to content

Restore X88 PRO 10


mathgaming
 Share

Recommended Posts

I was trying to flash the eMMC of my X88 PRO 10, which bricked it. I need some help to unbrick it.

So far, I have managed to put it into maskrom mode by conneting the two contact pads in the red circles and pluging in a USB A to A cable in the USB 2.0 port of the tv box and my computer.
I took a backup of the firmware with the multitool from here: https://forum.armbian.com/topic/17597-csc-armbian-for-rk3318rk3328-tv-box-boards/page/1 but I could not find a way to restore it.
I tried Android tool reports, which says "Found One MASKROM Device", but threw an error when I tried to load my backup.
So I searched for the origional firmware, but could not find a source that was working.
Can someone help me unbricking my TV box?

20220924_154014.thumb.jpg.8a4430afdb3b64ab6dd2f1c66001ca94.jpg

Link to comment
Share on other sites

Check forum guidelines to use maximum potential!

Interesting you found a way to put the device in maskrom mode, the testing points are not always obvious.

I will link this thread in the rk3318 first post for future reference.

 

However once in maskrom mode the board will boot from sdcard. As far as I remember, yours has the sdcard allocated to a "secondary" controller and for this reason probably is unable to boot multitool from sdcard when in maskrom mode.

You could use rkdeveloptool to erase or program the internal flash manually when in maskrom mode with linux, or use the AndroidTool with Windows

Link to comment
Share on other sites

@Elbie Kittens AFAIR the X88 has the sdcard connected to sdmmc_ext bus, that's the reason why it won't boot from sdcard when firmware is erased. You should have install the armbian image right after erasing the emmc.

 

Now you are probably in maskrom mode, the board should show when connected to PC via USB male-to-male cable, but you have to use the board USB OTG port. Then you can use rkdeveloptool to upload an armbian image.

 

Read the paragraph The Multitool does not boot / How to burn image directly on eMMC on the support page

 

Link to comment
Share on other sites

Thank you, 

I have done a bit more investigation.

 

If it's in maskrom mode it should appear as a device when a usb a to a cable is used. However under windows and Linux no device is shown. 

 

I can also use a usb to serial device and have connected to the three pins marked gnd, Tx and Rx. 

No matter what baud rate I use, nothing appears. 

 

It's like it has no sign of life.

 

I can make out what I think are three test points on the back of the PCB near the emmc on the front that could be the clk, however I am unsure.

 

Pushing in the button inside the 3.5mm jack doesn't do anything. Holding it for 3, 5 or 30 seconds doesn't make a difference. 

 

Nothing I do makes this device show up. All was fine until I used multitool to erase...

 

Now, I do have a backup of the emmc made with multitool, however burning it to SD doesn't do anything, same as burning any img to SD using etcher. 

 

Do I have a dead board somehow? 

 

Thank you 

 

Link to comment
Share on other sites

@Elbie Kittens If you erased the emmc, it must be in maskrom mode, there is no further need to short the eMMC clock pins.

f it is in maskrom mode, the serial will be totally silent. Beware that there are other possible serial pins on the front side of the board, nearby the IR receiver. I don't remember which ones where in use for debug.

 

Beware that you MUST connect the USB cable in the OTG port only, other ports won't work at all. Your board should have one USB2 and one USB3 port, the OTG should be the USB2 port.

Also you should also try with and without the power plug connected, but try to power the box only via USB cable: when the USB cable is inserted in the USB OTG port, the box should be automatically powered on.

 

Last but not least: when you plug the cable, you should use lsusb tool to see if there is a rockchip device in maskrom mode, and not wait for something to automatically show up like a storage device.

Link to comment
Share on other sites

@jock

 

I shall try again tomorrow. Thank you for the info.

 

I did try lsusb, however nothing was detected. 

 

I only have a usb3 a to a male to male. That wouldn't cause any issues would it? 

As the cable should be electrically backwards compatible.

 

I'll remember it's the usb2.0 that's the otg. 

 

Thank you once again. 

Link to comment
Share on other sites

I believe my device is dead. 

 

Nothing shows under lsusb sudo or otherwise. 

 

Nothing shows on HDMI output, can't load the sdcard due to it being the ext type. 

 

So I think I'm at a loss. 

 

I can upload some high detail pics and where I believe the clk point is asap. 

 

Thank you once again for all your support.

Link to comment
Share on other sites

@Elbie KittensAFAIR I don't remember a rockchip device that was unable to be restored using the maskrom mode + male-to-male cable.

 

You can go with emmc clock pin shorting, probably one of the pads behind the eMMC is the right one, nonetheless in you erased the eMMC it should already go in maskrom mode.

 

Link to comment
Share on other sites

@jock

 

I have ordered a usb 2.0 male to male, arrives tomorrow. Hopefully this rules out the usb 3.0 male to male I'm currently using. 

 

In the mean time I shall take some high resolution images of the board and what I believe are the various points. 

 

Hopefully this little endeavour can help others.

 

I have noticed just how much help you give to various forum posts @jock I for one am very grateful for the help and knowledge you have passed along. Thank you 

Hope you had a fab new years. 

Edited by Elbie Kittens
Spelling correction
Link to comment
Share on other sites

So, here we have some fun findings. 

 

Using the usb 2.0 male to male... No change. 

Nothing is in rockusb mode or maskrom mode...

 

So, screw it, short the emmc pins, or which ones I have a belief in being... success!! 

Maskrom mode!

 

So, can I flash anything, yes, one img file, an android x88 pro 10 build. 

Anything else, nope. 

 

None of the tools accept any armbian img as valid. 

(Windows that is, Linux wasnt happy today)

 

So, I can instal the image fine, it's android 10 by the looks of it, no WiFi however. 

 

Multitool will now work...no matter the img flashed using the tool, none boot and I'm left having to maskrom and start again. 

 

So so odd 😅

 

Picture is the pins on the back for maskrom 

 

Right hand side has one pin. 

Left has two, it's the right one of those two that you short to the right side pin. 

 

I've marked the pins in yellow and blue for ease.

 

https://ibb.co/Y2fWyRY

 

Edited by Elbie Kittens
Link to comment
Share on other sites

@Elbie Kittens Thanks a lot! I'm sorry I told you that you already should have been in maskrom mode, but it really had to work that way if you erased the eMMC. I really don't what was wrong in first instance. Surely the serial log would have been helpful.

 

About the tools, I don't know what tools are you using, but the armbian images are provided as xzipped raw images, not the proprietary format expected by AndroidTool for Windows, for example. Multitool is capable of burning them decompressing them on the fly, otherwise rkdeveloptool is able too but you have to decompress them first.

 

Anyway yes, it is very odd what you describe. X88 Pro has been tested in the past and should work without issues with armbian.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...