Jump to content

ttyname failed inappropriate ioctl for device?


Recommended Posts

hi @all! i find this site by accidentally looking a youtube video named "install ubuntu on a 40$ amlogic tv-box"...

ubuntu on the android box, you are great!!! this is what i need and what i like to have for my box too!

so i start to try run armbian on my XBII, gangbangdoo TV-box 2017, amlogic s905, yesterday, in the evening.

i downloaded the latest version ubuntu mate, install it, and all works fine - until i set the new root pwd. then i get the following message :(


error found when loading /root/.profile:

ttyname failed inappropriate ioctl for device

as a result the session will not be configured correctly.

you should fix the problem as soon as feasible.


after this, when i click on ok buttom, kodi starts direktly, and nothing other is possible to do - when i close kodi, the device will restart.

this was a long night, i tried many tips from the internet and at least many from the older releases from armbian and linux, too.

but only this release works anyway, all the tips bring more other errors, without solve the 1. problem, and now i still sit here at the pc without sleeping :wacko:

so i hope somebody here can help me with this problem...?!

many thanks for your support!!! ...and also a big sorry for my bad english :unsure: i live in germany, and i dont have to speek english for a long time.:unsure:

Link to comment
Share on other sites

Help us fund some #badass gear for our continuous integration build framework

5 hours ago, newbarmbee said:

i downloaded the latest version ubuntu mate

Could help a lot if you could give a link to what exactly you installed.


5 hours ago, newbarmbee said:

error found when loading /root/.profile:

ttyname failed inappropriate ioctl for device

I found this bug report: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1584488 - So the message seems harmless and should go away when you update.


5 hours ago, newbarmbee said:

kodi starts direktly, and nothing other is possible to do - when i close kodi, the device will restart.

Sounds like there's no display server whatsoever but kodi doing everything directly. Try pressing Ctrl + Alt + F2 when kodi is running to get to a terminal. Log in as root there and see what's running with

systemctl status


Link to comment
Share on other sites

i have downloaded from this site (yadl.sk), at first this file - Armbian_5.34_S9xxx_Ubuntu_xenial_3.14.29_mate_20171027.img.xz, later Armbian_5.34_S9xxx_Debian_jessie_3.14.29_xfce_20171027.img.xz, but debian will be froozen while entering login.

to be sure, its not from a broken download or sdcard-error, i downloaded both files again and install them on other sdcards, but with the same effects.


on ubuntu i can login with root, the changed pwd after 1234 is permanently saved. but i am not able to create a new user...

after login with enter the root pwd, the device create the error message and starts kodi, with no access to system settings or anything else.

i have read from the bug at ligthdm, and i tried to change the settings with the editor offline, with switching the sdcard to my laptop.

the tv-box have no access to any network, and it was not available to get remote access from pc.

but i have not hear about this key combination before, thank you very much! and i would never thought to test it while running kodi.


i check this later, at the moment i have started a new way...i have installed the server file (ubuntu, not damian).

the login was exhausting and taked a long time, but it worked correct and asked then to create the new user.

but this is unfortunately all about success at this time. i have no network, can not find how or where to setup this - and what i type on the keyboard is unable to be seen on the display until pressed enter. and with a totally unknown keyboard layout, i do not know what i write almost the time :wacko:

and now, more than 3h later, i still have only access to the shell.


so i think it is better to stop this test now, reboot with the desktop version again and try your tip.

thank you for support! i will report the effects right after that...

Link to comment
Share on other sites

ok, when kodi is running, no combinations are working (no system reboot from keyboard, too).

but when i exit kodi, i will get back to login screen - and there it works.

unfortunately i can not make a screenshot, and after set the command to display system status, i see a big three and the message, 2 units failed.

a bigger part of this, on top, is named system.slice....following from a user.slice an at least a user-0.slice. most of the informations listed in this 3 sections i have to learn to understand first, because of using xubuntu only a short time until now.

i will try to get a picture using the smartphone, maybee you can give me another tip where to look and what is to do, to solve the problems.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...