Jump to content

Vagrant issue


Nick
 Share

Recommended Posts

Hi,

I've been trying to follow the instructions here https://docs.armbian.com/Developer-Guide_Using-Vagrant/ rather than using my current virtualbox setup however I fall over at the following spot:

 

nick@Nick-desktop:~$ vagrant plugin install vagrant-disksize
Installing the 'vagrant-disksize' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:
conflicting dependencies nokogiri (= 1.5.10) and nokogiri (= 1.8.1)
  Activated nokogiri-1.8.1
  which does not match conflicting dependency (= 1.5.10)
  Conflicting dependency chains:
    nokogiri (= 1.8.1), 1.8.1 activated
  versus:
    vagrant-libvirt (> 0), 0.0.9 activated, depends on
    nokogiri (= 1.5.10)

It looks as though it's a vagrant error rather than an Armbian issue in particular but wondered if anyone had solved it? This is the second issue that I've run into, I had a similar issue with another dependancy last night (I can't remember which one now) but managed to google my way past that.

 

Here is uname for my machine 

Linux Nick-desktop 4.13.0-1-amd64 #1 SMP Debian 4.13.4-2 (2017-10-15) x86_64 GNU/Linux

 

Link to comment
Share on other sites

Search Before Posting!

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...