0
N4IRS

Unable to build for NanoPi NEO2

Recommended Posts

I am attempting to build the following:

Full OS image for flashing

Do not change the kernel configuration

nanopineo2

next or dev kernel same error

stretch or xenial same error

 

[ o.k. ] Downloading sources
[ o.k. ] Checking git sources [ u-boot v2017.11 ]
[ .... ] Up to date
[ o.k. ] Checking git sources [ linux-mainline linux-4.14.y ]
[ .... ] Up to date
[ o.k. ] Checking git sources [ arm-trusted-firmware-sunxi-mainline allwinner-stable ]
[ .... ] Fetching updates
fatal: Couldn't find remote ref allwinner-stable
[ .... ] Checking out
error: pathspec 'FETCH_HEAD' did not match any file(s) known to git.
[ o.k. ] Checking git sources [ sunxi-tools master ]
[ .... ] Up to date
[ o.k. ] Checking git sources [ rkbin-tools master ]
[ .... ] Up to date
[ o.k. ] Checking git sources [ marvell-tools A3700_utils-armada-17.10 ]
[ .... ] Up to date
[ o.k. ] Checking git sources [ odroidc2-blobs master ]
[ .... ] Up to date
[ o.k. ] Cleaning output/debs for [ nanopineo2 next ]
[ o.k. ] Cleaning [ arm-trusted-firmware-sunxi-mainline/allwinner-stable ]
[ o.k. ] Compiling ATF
[ o.k. ] Compiler version [ aarch64-linux-gnu-gcc 6.4.1 ]
[ o.k. ] Started patching process for [ atf sunxi64-nanopineo2-next ]
[ o.k. ] Looking for user patches in [ userpatches/atf/atf-sunxi64 ]
[ warn ] * [l][c] add-SRAM-mapping-for-SCPI.patch [ failed ]
[ warn ] * [l][c] enable-a53-errata-workaround.patch [ failed ]
[ warn ] * [l][c] enable-additional-regulators.patch [ failed ]
[ warn ] * [l][c] set-rsb-to-nonsec.patch [ failed ]
make: *** No rule to make target 'bl31'.  Stop.
[ error ] ERROR in function compile_atf [ compilation.sh:59 ]
[ error ] ATF compilation failed
[ o.k. ] Process terminated
root@ImageBuilder:/srv/build#
 

Can someone point me in the proper direction? I have been using the builder for custom images for other boards without error. 

I will also say, I love this tool. Makes it very easy for me to build customized Armbian images with my applications pre-installed.

 

Thanks, Steve 

Share this post


Link to post
Share on other sites

Well that was fast. I retried the build and saw a change had been committed to the repository. It's building now.

 

Thanks SO much!

 

Steve

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0