0
dony71

hostapd no internet on BPI M2 Plus

Recommended Posts

I have armbian 5.65 ( kernel 4.14.78-sunxi) on BPI M2 Plus

I can enable hotspot using armbian-config but when connect to AP, no internet access

Is there any setting missing here??

 

/etc/network/interfaces

# Network is managed by Network manager
auto lo
iface lo inet loopback
pre-up ifconfig eth0 hw ether 22:33:44:55:66:77

 

 

/etc/network/interfaces.d/armbian.ap.nat

# armbian NAT hostapd
allow-hotplug wlan0
iface wlan0 inet static
        address 172.24.1.1
        netmask 255.255.255.0
        network 172.24.1.0
        broadcast 172.24.1.255

 

/etc/hostapd.conf

#
# armbian hostapd configuration example
#
# nl80211 mode
#

ssid=ARMBIAN
interface=wlan0
hw_mode=g
channel=5
#bridge=br0
driver=nl80211

logger_syslog=0
logger_syslog_level=0
wmm_enabled=1
wpa=2
preamble=1

wpa_psk=xxxxxxxxxxxxxx
wpa_passphrase=xxxxxxx
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
auth_algs=1
macaddr_acl=0

noscan=1

## IEEE 802.11n
ieee80211n=1
ht_capab=[DSSS_CK-40][HT20+]
country_code=US
ieee80211d=1
## IEEE 802.11n

### IEEE 802.11a
#hw_mode=a
### IEEE 802.11a

### IEEE 802.11ac
#ieee80211ac=1
#vht_capab=[MAX-MPDU-11454][SHORT-GI-80][TX-STBC-2BY1][RX-STBC-1][MAX-A-MPDU-LEN-EXP3]
#vht_oper_chwidth=1
#vht_oper_centr_freq_seg0_idx=42
### IEEE 802.11ac

# controlling enabled
ctrl_interface=/var/run/hostapd

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0