Valerij

Members
  • Posts

    2
  • Joined

  • Last visited

Valerij's Achievements

  1. Orange Pi Zero H2+ Armbian 21.08.1 Orangepizero Bullseye current 5.10.60 from armbian.com/downloads. I have attached external RTC module with DS3231 on TWI0 (/dev/i2c-0) and activated it with command echo ds3231 0x68 > /sys/bus/i2c/devices/i2c-0/new_device After that /sys/class/hwmon/hwmon0 links to temperature sensor on DS3231 instead of SOCTEMP. So armbianmonitor -m shows temperature from DS3231 now. syslog shows error: thermal thermal_zone0: binding zone cpu_thermal with cdev thermal-cpufreq-0 failed:-22 Solution #1: use command "echo ds1307 0x68 > /sys/bus/i2c/devices/i2c-0/new_device" Solution #2: attach RTC module on TWI1 pins (/dev/i2c-1) and use command "echo ds3231 0x68 > /sys/bus/i2c/devices/i2c-1/new_device"
  2. Hello! I have: 1) Orange Pi PC+ with ARMBIAN 5.38 stable Ubuntu 16.04.5 LTS 3.4.113-sun8i 2) Orange Pi Zero with ARMBIAN 5.60 stable Ubuntu 16.04.5 LTS 3.4.113-sun8i 3) Orange Pi PC with Debian 3.4.39 #1 SMP PREEMPT Wed Sep 16 13:39:07 CEST 2015 armv7l On both ARMBIANs I have noticed: every start of arecord sets level on "MIC1 boost AMP gain control" audio setting with constant value 5. I think it uses value of "cap_vol=5" from section [audio0] from script.bin. On Debian it does not. In my case I need very very very low value of "MIC1 boost AMP gain control". Value of "ADC input gain ctrl" is already 0. Any ideas what is responsible: alsa, driver or something else? And how to avoid that? The way to repeat: 1) with amixer see current value of "MIC1 boost AMP gain control" - in my case 5. 2) set any another value: amixer sset "MIC1 boost AMP gain control" 4 3) check new value 4 with amixer 4) start arecord to record anything 5) check value of "MIC1 boost AMP gain control" with amixer: it got 5 again