r4w

Members
  • Content Count

    7
  • Joined

  • Last visited

  1. The solution is to avoid that box or force it to run at 100Mbit instead of 1Gbit They have tried a lot of things in LibreElec, something seemed to work but not for all: https://forum.libreelec.tv/thread/13071-zte-zx2aa500-gb-ethernet-transceiver-problems-solved-big-news-for-inside/?pageNo=1
  2. Thanks, you have saved from to a very wrong purchase. Now I need to find a S912 were at least the gigabit network works ok!
  3. Do you mean that even the integrated network card (not wireless) wasn't working for you?
  4. Everything works with a 3.14.x kernel and module wlan, but I can't get it working with the latest kernel
  5. Thanks! According to the error, the filename is correct (Failed to find firmware-N.bin (N between 2 and 6) from ath10k/QCA9377/hw1.00). Looking at other forums, I saw similar errors but reporting the full path, for example: e.g. /lib/firmware.ath10k/QCA9377/hw1.00, that's why I'm wondering where it's expecting to find the firmwares.
  6. I have a strange issue and I digged it a bit on google but I can't see what's exactly wrong. In dmesg I see: [ 1005.422372] ath10k_sdio mmc2:0001:1: failed to write to address 0x828: -84 [ 1005.422392] ath10k_sdio mmc2:0001:1: unable to disable sdio interrupts: -84 [ 1147.797298] ath10k_sdio mmc2:0001:1: WARNING: ath10k SDIO support is incomplete, don't expect anything to work! [ 1147.823159] ath10k_sdio mmc2:0001:1: Failed to find firmware-N.bin (N between 2 and 6) from ath10k/QCA9377/hw1.0: -2 [ 1147.823166] ath10k_sdio mmc2:0001:1: could not fetch firmware files (-2) [ 1147.823192] ath10k_sdio mmc2:0001:1: could not probe fw (-2) I have checked the relative firmware folder and I have the firmwares: root@aml:/lib/firmware/ath10k/QCA9377/hw1.0# pwd /lib/firmware/ath10k/QCA9377/hw1.0 root@aml:/lib/firmware/ath10k/QCA9377/hw1.0# ls board-2.bin board.bin firmware-5.bin firmware-6.bin notice_ath10k_firmware-5.txt notice_ath10k_firmware-6.txt Is it possible that it's looking for the firmwares in another folder instead of the standard one? (CONFIG_EXTRA_FIRMWARE_DIR != /lib/firmware) Thanks!
  7. I'm looking for the headers too, thanks!