Jump to content

rvmn

  • Posts

    3
  • Joined

  • Last visited

  1. EDIT: After a few days the focal xfce gave me the blank display bug as well I have tried now extensively tested two other DE's: gnome and Cinnamon. Gnome: found that the bug is totally not existant on Gnome (3.36), have run it for a week or so without any burp. Only ting I dislike is that is a bit heavy feeling, not a ssmooth running as XFCE or Cinnamon Cinnamon: the bug does happen here sometimes, BUT it only takes a 1-2 second until it shows the screen again WITH the chosen resolution. Can live with that as it's a smooth experience and has lot of handy features. Budgie: I haven't tested it because it is not as feature rich as other DE's in my opinion BTW hirsute works fine, it's really the Panfrost driver that causes the issue and the DE that copes with it smartly or not BTW2 i recommend using the oibaf/graphics-drivers ppa for the newest drivers, they do have less bugginess BTW3 In case your system does bug to a lower resolution everytime if have found you can try setting the default resolution by setting it in /etc/X11/xorg.conf by copying a mode from cvt: cvt 1920 1080 60 # specify your width height of resolution and refresh rate (60Hz = usually ok) then copy the output, and paste it into the second last line in the following text blob inside a text editor, then copy all this into the bottom of /etc/X11/xorg.conf (open it in a text editor f.e. sudo gedit /etc/X11/xorg.conf ) Section "Monitor" Identifier "dummy_monitor" HorizSync 28.0-80.0 VertRefresh 48.0-75.0 Modeline XXX # replace this line here with cvt output EndSection
  2. I have found out it's not related directly to the Panfrost driver, but some other display problem. I have tried the latest Panfrost (22.0) on both hirsute and focal and on focal it works perfectly fine but on hirsute it keeps giving refreshes to a low resolution. I now use focal xfce, using a previous Armbian version (21.05) found in the archives: https://armbian.systemonachip.net/archive/khadas-vim3/archive/ I upgraded xfce to 4.16 (has fractional scaling) and everyrthing else using the following commands: sudo apt install ca-certificates sudo add-apt-repository ppa:xubuntu-dev/staging sudo apt upgrade sudo apt install xfce4-helpers xfce4-settings xfce4-panel The last command was needed because it didnt update the settings panel for some reason which is a bit sorry cause it shows the new scaling options only with the new version. Hope this might help others with problems
  3. Same problem here. The display driver seems to be the cause, it is solved by plugging the hdmi cable out and in so its definitely graphics related. Does someone know to go about reverting back the gpu driver, or would freezing the kernel be enough?
×
×
  • Create New...