JTI

  • Posts

    3
  • Joined

  • Last visited

Reputation Activity

  1. Like
    JTI got a reaction from Kalobok in Orange Pi Plus 2e - Where is 1,6Ghz and SD ?   
    I used this information for Booting with eMMC and with or without SD-Card insert
     
    http://forum.armbian.com/index.php/topic/1187-boot-from-emmc-with-blank-sd-in-slot-bpi-m3/?p=9292
     
    I tested this on Orange PC Plus and works fine
     
    - installation Armbian on sd card (first) / boot / update ...
    - then nand-sata-install (copy from SD-card to eMMC) and boot from eMMC without SDCARD
    - then cp /boot/script.bin /boot/script.bak (for safety)
    - then "bin2fex /boot/script.bin /tmp/script.fex" (or to another directory e.g. /root ...)
    - then Change sdc_detmode from 3 to 1 in the script.fex - then "fex2bin /tmp/script.fex /boot/script.bin" - then boot systen with e.g. reboot and now the system booting from eMMC with or without SD-Card.   I use this to greatly expand the home directory. (System on eMMC and Home (User) on SD-Card) and works fine.   jti
  2. Like
    JTI reacted to eternalWalker in Boot from eMMC with blank SD in slot (BPI-M3)   
    I got it!
    After boot from eMMC i plug SD and ... voila!   Effect as in "Android"
    
    
    
    
    
     
    root@BananaPiM3:~ # dmesg | tail
    [  155.365740] mmc1: new high speed SDHC card at address 59b4
    [  155.372439] mmcblk1: mmc1:59b4 USD00 29.5 GiB
    [  155.378893]  mmcblk1: p1 p2
    [  155.382764] *******************sd init ok*******************  
     
    root@BananaPiM3:~ # cat /proc/partitions
    major minor  #blocks  name
     179        0    7634944 mmcblk0
     179        1     262144 mmcblk0p1
     179        2    7270400 mmcblk0p2
     179       32       4096 mmcblk0boot1
     179       16       4096 mmcblk0boot0
     179       48   30981120 mmcblk1
     179       49      51200 mmcblk1p1
     179       50   30827520 mmcblk1p2
     
     
     
     
     
     
     // Clone BPI-M3-bsp //
    Edit the file sys_config.fex /BPI-M3-bsp/sunxi-pack/chips/sun8iw6p1/configs/BPI_M3_1080P/sys_config.fex   I use HDMI-1080P, for other Resolution or Video Output must chage the path /BPI_M3_1080P/
     
    Edit sys_config.fex:  aud look for [mmc0_para]
     
     
     
    . . . . . ... ;-------------------------------------------------------------------------------- ;   SDMMC PINS MAPPING                                                          | ; ------------------------------------------------------------------------------| ;   Config Guide                                                                | ;   sdc_used: 1-enable card, 0-disable card                                     | ;   sdc_detmode: card detect mode                                               | ;                1-detect card by gpio polling                                  | ;                2-detect card by gpio irq(must use IO with irq function)       | ;                3-no detect, always in for boot card                           | ;                4-manually insert and remove by /proc/driver/sunxi-mmc.x/insert| ;   sdc_buswidth: card bus width, 1-1bit, 4-4bit, 8-8bit                        | ;   sdc_use_wp: 1-with write protect IO, 0-no write protect IO                  | ;   sdc_isio: for sdio card                                                     | ;   sdc_regulator: power control.if card supports UHS-I/DDR and HS200 timing for| ;                  SD3.0 or eMMC4.5, regulator must be configured. the value is | ;                  the ldo name of AXP221, eg: sdc_regulator = "axp22_eldo2"    | ;   other: GPIO Mapping configuration                                           | ; ------------------------------------------------------------------------------| ;   Note:                                                                       | ;   1 if detmode=2, sdc_det's config=6                                          | ;     else if detmode=1, sdc_det's config=0                                     | ;     else sdc_det IO is not necessary                                          | ;   2 if the customer wants to support UHS-I and HS200 features, he must provide| ;     an independent power supply for the card. This is only used in platforms  | ;     that supports SD3.0 cards and eMMC4.4+ flashes                            | ;-------------------------------------------------------------------------------- [mmc0_para] sdc_used          = 1 sdc_detmode       = 3 sdc_buswidth      = 4 sdc_clk           = port:PF02<2><1><2><default> sdc_cmd           = port:PF03<2><1><2><default> sdc_d0            = port:PF01<2><1><2><default> sdc_d1            = port:PF00<2><1><2><default> sdc_d2            = port:PF05<2><1><2><default> sdc_d3            = port:PF04<2><1><2><Default> sdc_det           = port:PF06<0><1><2><default> sdc_use_wp        = 0 sdc_wp            = sdc_isio          = 0 sdc_regulator     = "none" sdc_power_supply  = "vcc-card" And the most important!   Change sdc_detmode from 3 to 1
     
     
    After compile (BPI-M3-bsp)  boot from SD Card, flash eMMC with the  5 files ,
     
    export card=/dev/mmcblk1
     
    dd if=boot0_sdcard.fex of=${card} bs=1k seek=8
    dd if=u-boot.fex of=${card} bs=1k seek=19096
    dd if=sunxi_mbr.fex of=${card} bs=1k seek=20480
    dd if=boot-resource.fex of=${card} bs=1k seek=36864
    dd if=env.fex of=${card} bs=1k seek=69632
    dd if=boot.fex of=${card} bs=1k seek=86016
     
    Shutdown -h now, SD card out, boot fom eMMC, plug the SD inside and.....   Problem solved!  
     
    Great
    eW