pas059

Members
  • Content Count

    3
  • Joined

  • Last visited

  1. pas059

    install Qt

    Hello, I wondered what was this 'nodm' that i saw while attempting to install some softwares (not only Qt) Thank you for the advices JMCC, this was indeed the problem. As the Os i used was a Bionic which i had configured with 'armbian-config' so that to have a desktop (but perhaps incorrectly), i follow your advice and i flashed Debian Strech. Indeed, this Os has a desktop environment by default, and for me everything works nicely (wifi, network); eveything i needed could be configured without using command lines. Then i installed Synaptic and i used it to install QtCreator, QtDesigner, Qt4.8.7, ... and also CodeBlocks; everything was installed without problem and works. I feel that i found the good Os, even if Bionic is perhaps a little nicer; perhaps i will retry with Bionic later, but from my little experience with linux on the Rock64, i can say that Armbian with Debian Strech is the more easy to install and setup. thanks again JMCC for your judicious advices. Regards
  2. pas059

    install Qt

    Hi, thanks for the links, but this not solve the problem. I'm afraid that there is no solution currently. Regards
  3. pas059

    install Qt

    Hello, I'm new to Armbian which i just installed on a Rock64 board (Armbian_5.65_Rock64_Ubuntu_bionic_default_4.4.162.7z). I have to say that my first impressions are that Armbian is a nice Os and that this is the one that causes me the less troubles on the Rock64 to install and to start. My goal is the write/port an application in C++ preferably by using Qt. Here, it is the problem. I tried to install it using command: sudo apt-get install qtcreator sudo apt-get install qt4-designer "Qt 4 Designer" seems installed correctly and seems working properly. Qt Creator was not installed completely, the IDE is installed but there is no kits installed (nor Qt4.8, nor Qt5.x). I was not surprised because during the execution of "sudo apt-get install qtcreator", some errors happened; below the text of the error: Setting up nodm (0.13-1.3) ... Job for nodm.service failed because the control process exited with error code. See "systemctl status nodm.service" and "journalctl -xe" for details. invoke-rc.d: initscript nodm, action "start" failed. ● nodm.service - Display manager for automatic session logins Loaded: loaded (/lib/systemd/system/nodm.service; static; vendor preset: enabled) Active: activating (auto-restart) (Result: exit-code) since Thu 2018-12-27 16:51:04 CET; 26ms ago Docs: man:nodm(8) Process: 18678 ExecStartPre=/bin/sh -c [ "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/nodm" ] (code=exited, status=1/FAILURE) dpkg: error processing package nodm (--configure): installed nodm package post-installation script subprocess returned error exit status 1 Errors were encountered while processing: nodm E: Sub-process /usr/bin/dpkg returned an error code (1) I also see such error implying "nodm.service" (?) during the install of other packages. Someone can help? Regards Pascal