pas059

Members
  • Content Count

    5
  • Joined

  • Last visited

  1. Hi, i also have low throughputs with wifi. I have a rock64 v2 with 4Gb and i use a 802.11n usb2/wifi adapter (the found on pine64 website). I made some test using iperf. With the Gigabit interface, i get ~800Mbits/sec with both ayfan bionic 4.4.132 on eMMc and with armbian bionic 4.4.174 on a SD card; the throughput seems a little speeder when booting on the eMMC but this is not significant. Always using iperf, the wifi throughput is at least 2 times slower when booting on a SD card . (~40 Mbits/sec on eMMC, and ~15 Mbits/sec on SD). Now concerning the internet throughput, it is always lower than 100 MBits/sec (using gigabit and booting on eMMc) although my internet connection allows 500 Mbits/sec (so 5 times lower), and at least 2 times lower when booting on SD. And the internet throughput using wifi is ~40 Mbits/sec on eMMC, and ~15 Mbits/sec on SD. To resume, the internet throughput is really slow (even with gigabit ethernet), my wifi adaptor is also slow, and booting on a SD reduces by at leasr 2 the throughputs except for gigabit ethernet tranfers. Any comments? regards Pascal
  2. pas059

    install Qt

    Hello, To complete the informations above, i also tried to install Qt on Bionic. I succeeded to install qtcreator&QtDesigner but the build process of an app does not work. By comparing the packages installed under armbian-stretch and bionic, i remarqued than a package is not available under bionic: qt-sdk, i fell that this is the reason for which QTCreator fails to build projects under Bionic. By curiosity, i also tried other IDEs: Codeblocks, Codelite and Anjuta; i gave them in order preference. All the 3 work, but none of them offers a complete solution (on armbian) for building applications with GUI; when there is a correct framework (for instance wxWidgets on codeblocks), there is no RAD tools (no wxFormBuilder for instance), or when there is s RAD tool there is not a sufficiently solid/complete couple IDE/framework (Anjuta). Of course this my opinion, but i really think that Qt (once installed) is the best solution for making applications on Armbian. regards
  3. pas059

    install Qt

    Hello, I wondered what was this 'nodm' that i saw while attempting to install some softwares (not only Qt) Thank you for the advices JMCC, this was indeed the problem. As the Os i used was a Bionic which i had configured with 'armbian-config' so that to have a desktop (but perhaps incorrectly), i follow your advice and i flashed Debian Strech. Indeed, this Os has a desktop environment by default, and for me everything works nicely (wifi, network); eveything i needed could be configured without using command lines. Then i installed Synaptic and i used it to install QtCreator, QtDesigner, Qt4.8.7, ... and also CodeBlocks; everything was installed without problem and works. I feel that i found the good Os, even if Bionic is perhaps a little nicer; perhaps i will retry with Bionic later, but from my little experience with linux on the Rock64, i can say that Armbian with Debian Strech is the more easy to install and setup. thanks again JMCC for your judicious advices. Regards
  4. pas059

    install Qt

    Hi, thanks for the links, but this not solve the problem. I'm afraid that there is no solution currently. Regards
  5. pas059

    install Qt

    Hello, I'm new to Armbian which i just installed on a Rock64 board (Armbian_5.65_Rock64_Ubuntu_bionic_default_4.4.162.7z). I have to say that my first impressions are that Armbian is a nice Os and that this is the one that causes me the less troubles on the Rock64 to install and to start. My goal is the write/port an application in C++ preferably by using Qt. Here, it is the problem. I tried to install it using command: sudo apt-get install qtcreator sudo apt-get install qt4-designer "Qt 4 Designer" seems installed correctly and seems working properly. Qt Creator was not installed completely, the IDE is installed but there is no kits installed (nor Qt4.8, nor Qt5.x). I was not surprised because during the execution of "sudo apt-get install qtcreator", some errors happened; below the text of the error: Setting up nodm (0.13-1.3) ... Job for nodm.service failed because the control process exited with error code. See "systemctl status nodm.service" and "journalctl -xe" for details. invoke-rc.d: initscript nodm, action "start" failed. ● nodm.service - Display manager for automatic session logins Loaded: loaded (/lib/systemd/system/nodm.service; static; vendor preset: enabled) Active: activating (auto-restart) (Result: exit-code) since Thu 2018-12-27 16:51:04 CET; 26ms ago Docs: man:nodm(8) Process: 18678 ExecStartPre=/bin/sh -c [ "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/nodm" ] (code=exited, status=1/FAILURE) dpkg: error processing package nodm (--configure): installed nodm package post-installation script subprocess returned error exit status 1 Errors were encountered while processing: nodm E: Sub-process /usr/bin/dpkg returned an error code (1) I also see such error implying "nodm.service" (?) during the install of other packages. Someone can help? Regards Pascal