Emil

Members
  • Content Count

    2
  • Joined

  • Last visited

  1. hello after updating from cat /proc/version Linux version 4.14.84-sunxi (root@armbian.com) (gcc version 7.2.1 20171011 (Linaro GCC 7.2-2017.11)) #3 SMP Sat Dec 1 07:18:41 CET 2018 to Linux version 4.19.13-sunxi (root@armbian.com) (gcc version 7.2.1 20171011 (Linaro GCC 7.2-2017.11)) #5.70 SMP Sat Jan 12 15:43:21 CET 2019 my one wire thermometer stopped working - is there some additional steps needed now? I didn't change my configuration overlays=w1-gpio param_w1_pin=PB10 param_w1_pin_int_pullup=0  and now I have dmesg [ 1174.451457] w1_master_driver w1_bus_master1: Attaching one wire slave 00.e80000000000 crc 2b [ 1174.456242] w1_master_driver w1_bus_master1: Family 0 for 00.e80000000000.2b is not registered. [ 1234.023523] w1_master_driver w1_bus_master1: Attaching one wire slave 00.180000000000 crc 5f [ 1234.029428] w1_master_driver w1_bus_master1: Family 0 for 00.180000000000.5f is not registered. ... ls /sys/bus/w1/devices 00-180000000000 00-580000000000 00-980000000000 w1_bus_master1 (00-... directories names and count changes after every minute) cat /sys/kernel/debug/gpio gpiochip0: GPIOs 0-287, parent: platform/1c20800.pinctrl, 1c20800.pinctrl: gpio-40 ( |ahci-5v ) out hi gpio-224 ( |cd ) in lo IRQ gpio-225 ( |cd ) in lo IRQ gpio-227 ( |usb2-vbus ) out hi gpio-228 ( |usb0_id_det ) in hi IRQ gpio-230 ( |usb1-vbus ) out hi gpio-244 ( |cubieboard2:green:us) out lo gpio-245 ( |cubieboard2:blue:usr) out lo gpio-271 ( |onewire@0 ) in lo gpiochip1: GPIOs 413-415, parent: platform/axp20x-gpio, axp20x-gpio, can sleep: there is no "gpio-42" line, old was cat /sys/kernel/debug/gpio gpiochip0: GPIOs 0-287, parent: platform/1c20800.pinctrl, 1c20800.pinctrl: gpio-40 ( |ahci-5v ) out hi gpio-42 ( |w1 ) in hi gpio-224 ( |cd ) in lo IRQ gpio-225 ( |cd ) in lo IRQ gpio-227 ( |usb2-vbus ) out hi gpio-228 ( |usb0_id_det ) in hi IRQ gpio-230 ( |usb1-vbus ) out hi gpio-244 ( |cubieboard2:green:us) out lo gpio-245 ( |cubieboard2:blue:usr) out lo gpiochip1: GPIOs 413-415, parent: platform/axp20x-gpio, axp20x-gpio, can sleep:
  2. Hello Maybe it will help someone. I lost a lot of time trying to connect 1-wire to Cubieboard2 via DVK 522 (it has DS18B20 connection on PB10 /gpio 66/ with external pullup). I've done steps in http://linux-sunxi.org/1-Wire with different combination and it doesn't work. In /sys/bus/w1/devices i had only sth like 00-80... 00-40... 00-c00.. without w1_slave file (i was 100% sure of hardware - it works on waveshare debian image) SOLUTION: In /boot/armbianEnv.txt lines needs to be without comments: and that's it ( overlays are created automatically by config so it will be sth like for example this: overlays=mmc2 nand uart2 uart3 uart4 uart5 uart6 uart7 w1-gpio ) other interesting behaviour cat /sys/kernel/debug/gpio gpio-42 ( |w1 ) in hi I don't know why pin 66 ( https://github.com/cubieplayer/Cubian/wiki/GPIO-Introduction ) has number 42 now I've tried to use PC02 http://linux-sunxi.org/A20/PIO#PC02_.2866.29 and also "(position of letter in alphabet - 1) * 32 + pin number" dmesg output [ 18.227575] sun4i-pinctrl 1c20800.pinctrl: unknown pin PB10 # desired pin finally helped INFO: Cubieboard2, DVK522 image: Armbian Stretch mainline kernel 4.14.y (legacy kernel doesn't boot) on SATA drive cat /proc/version Linux version 4.14.84-sunxi (root@armbian.com) (gcc version 7.2.1 20171011 (Linaro GCC 7.2-2017.11)) #3 SMP Sat Dec 1 07:18:41 CET 2018