• Content Count

  • Joined

  • Last visited

About markolonius

  • Rank

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I had this same problem with kworker processes using 20-50% of CPU at idle. Tried this method out with cpufreq-set -d 1.15G and immediately the kworker processes cpu utilization dropped. Question about making the changes permanent at each reboot. I created the file /etc/default/cpufrequtils like you mentioned. What do I put in there exactly? From googling some put: GOVERNOR="ondemand" MIN_SPEED="800MHz" MAX_SPEED="950MHz" Except I would change the MIN_SPEED and MAX_SPEED to the same MAX_SPEED of my cpu (which is 1.15G for pine64+). I've seen some put GOVERNOR=
  2. I was able to successfully build with the patch this time as well. Been running solid since! Can we get this patch submitted into official builds?
  3. Problem still persists with the upstream patches. Been running 5.2.5-sunxi64 and I still get this issue. Its somewhat more stable on this kernel however if you stop and disable systemd-timesyncd. Seems like systemd-timesyncd provokes it more. But I still have to reboot and use ntpdate to sync the time when it flips to year 2114 usually every few days. Very unreliable. Yes I have "CONFIG_SUN50I_ERRATUM_UNKNOWN1=y". @sundbry mentioned he applied this patch from the legacy 3.x kernel and has been stable for 1 month
  4. @sundbry I attempted to apply the patch but could never get it to work. So I actually tried out the 5.2.x kernel and kept systemd-timesyncd disabled, which seems to work and is stable for me for the past week or so. As soon as I enable systemd-timesyncd and start it, it switches the time to year 2114. Since I don't have much time at the moment keep trying to build a patched kernel I'll keep it this way. But if anyone has the same problem on the 5.2.x kernel w/ systemd-timesyncd and is working on trying to solve it I'll be more than happy to supply whatever logs requested to help.
  5. This sounds awesome. Haven't built a kernel for an arm board yet so this should be interesting. I'll give it a try, but might take me a while due to time. How would I download this patch? Any plans/hopes of this making it into a nightly or stable release?
  6. I have this problem very very often. Running Ubuntu Bionic with Armbian Linux 4.19.57-sunxi64 pretty stable otherwise when time is sync'd. I disabled systemd-timesyncd and seems to not have the time/date go to year 2114 as much, but still happens 3-4 times per week. I usually have to manually resync the time using sudo ntpdate Sometimes this gives invalid argument and requires me to reboot to run this command. I'd love to help in any way I can to debug this issue. Not sure how! I should add I didn't have this issue running arch linux with kernel
  7. Just downloaded tried out the new pine64 mainline bionic images and get some errors at boot: *** Warning: no boot file name; using 'C0A8917A.img' Using ethernet@1c30000 device TFTP from server; our IP is Filename 'C0A8917A.img'. Load address: 0x42000000 Loading: T T T T T T T T T T Retry count exceeded; starting again missing environment variable: pxeuuid missing environment variable: bootfile Retrieving file: pxelinux.cfg/01-02-ba-e5-6f-57-fd Using ethernet@1c30000 device TFTP from server; our IP is Filename 'C0A8917A.img'. Load a