radoxpi

  • Posts

    4
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

radoxpi's Achievements

  1. I briefly tried to compile it with the stock image. The main thing is it needs *linux kernel headers* in the image to compile the panfrost gpu drivers, which I cannot get with the legacy debian bullseye via `apt install`. After then, I have gained some more familiarity with the Armbian build system, and found out that we can get the linux kernel header via rebuilding the image from the git repository. This can be done by compiling it with the file argument `INSTALL_HEADERS="yes"`. So, it will be something like this `./compile.sh INSTALL_HEADERS="yes"`. I have successfully compiled an image with the headers, but not yet compiled the Panfrost gpu driver. Let me know how things go with the *gpu driver compilation* because I also have interest in the subject, and also please correct me if I said something not right.
  2. I tried your suggestion and it indeed works, with one condition. The disk's file system should not be NTFS, I think. I do not know the actual issue of using NTFS file system on Ubuntu Hirsute (kernel 5.11) to compile Armbian, but only when I start over with a clean workspace in my ext4 main drive, it works. It still has some issues such as toolchain not found, gpg verification failure. However, those are rather easy to mitigate.
  3. Good point. In short, this tag does not seem to matter much. I came across this parameter when browsing through the documentation. The default is master, but since I use legacy, I thought it will make sense to set it accordingly. Please correct me if I misunderstood in anyway. In the end, I did not see any difference from setting this parameter. The issue persists with or without the parameter. The issue is related to the building of the debs linux-image-*.deb . I have a feeling that this relates to the kernel linux-orangepi 4.9 repository. I wonder why it seems like I am the only one that has this problem 😂
  4. By the way, does anyone understand why I keep on getting `maintainer script 'preinst' has bad permissions 444 (must be >=0555 and <=0775)` when compiling the kernel from scratch? I have tried to run the compilation script with sudo, checked the folder permission, but I have currently no idea how to change the 444 permision of the 'preinst' script. I only checked on compilation on orange pi zero2 allwinner h616, this is my script : ./compile.sh USE_TORRENT=no BOARD=orangepizero2 BRANCH=legacy RELEASE=bullseye BUILD_MINIMAL=no KERNEL_ONLY=no KERNEL_CONFIGURE=no INSTALL_HEADERS=yes LIB_TAG=nightly I will be grateful is anyone has any idea on the topic