sakib_farhad

Members
  • Content Count

    1
  • Joined

  • Last visited

  1. I just downloaded Olimex Lime a64 Armbian Bionic image. when I try to boot it with my sd card, kernel panics. I am posting full log below. It didn't happen with testing release. Testing release worked perfectly for the same board. U-Boot SPL 2018.11-rc3-armbian (Feb 08 2019 - 10:25:08 +0100) DRAM: 1024 MiB Trying to boot from MMC1 NOTICE: BL3-1: Running on A64/H64 (1689) in SRAM A2 (@0x44000) NOTICE: Configuring SPC Controller NOTICE: BL3-1: v1.0(debug):c9f55c0 NOTICE: BL3-1: Built : 10:25:02, Feb 8 2019 NOTICE: DT: sun50i-a64-olinuxino INFO: Configuring AXP PMIC INFO: PMIC: DRAM voltage: 1.36V INFO: PMIC: setup successful NOTICE: SCPI: dummy stub handler, implementation level: 000000 INFO: BL3-1: Initializing runtime services INFO: BL3-1: Preparing for EL3 exit to normal world INFO: BL3-1: Next image address: 0x4a000000, SPSR: 0x3c9 U-Boot 2018.11-rc3-armbian (Feb 08 2019 - 10:25:08 +0100) Allwinner Technology CPU: Allwinner A64 (SUN50I) Model: Olimex A64-Olinuxino DRAM: 1 GiB MMC: SUNXI SD/MMC: 0, SUNXI SD/MMC: 1 Loading Environment from FAT... Card did not respond to voltage select! In: serial Out: serial Err: serial Net: phy interface7 eth0: ethernet@1c30000 230454 bytes read in 20 ms (11 MiB/s) starting USB... USB0: USB EHCI 1.00 USB1: USB OHCI 1.0 USB2: USB EHCI 1.00 USB3: USB OHCI 1.0 scanning bus 0 for devices... 1 USB Device(s) found scanning bus 2 for devices... 1 USB Device(s) found scanning usb for storage devices... 0 Storage Device(s) found Autoboot in 1 seconds, press <Space> to stop switch to partitions #0, OK mmc0 is current device Scanning mmc 0:1... Found U-Boot script /boot/boot.scr 3042 bytes read in 14 ms (211.9 KiB/s) ## Executing script at 4fc00000 U-boot loaded from SD Boot script loaded from mmc 104 bytes read in 11 ms (8.8 KiB/s) 34222 bytes read in 22 ms (1.5 MiB/s) 3795 bytes read in 21 ms (175.8 KiB/s) Applying kernel provided DT fixup script (sun50i-a64-fixup.scr) ## Executing script at 44000000 8808437 bytes read in 448 ms (18.8 MiB/s) 14243848 bytes read in 712 ms (19.1 MiB/s) ## Loading init Ramdisk from Legacy Image at 4fe00000 ... Image Name: uInitrd Image Type: AArch64 Linux RAMDisk Image (gzip compressed) Data Size: 8808373 Bytes = 8.4 MiB Load Address: 00000000 Entry Point: 00000000 Verifying Checksum ... OK ## Flattened Device Tree blob at 4fa00000 Booting using the fdt blob at 0x4fa00000 EHCI failed to shut down host controller. EHCI failed to shut down host controller. Loading Ramdisk to 49799000, end 49fff7b5 ... OK reserving fdt memory region: addr=4fa00000 size=6e000 Loading Device Tree to 0000000049728000, end 0000000049798fff ... OK Starting kernel ... � U-Boot SPL 2018.11-rc3-armbian (Feb 08 2019 - 10:25:08 +0100) DRAM: 1024 MiB Trying to boot from MMC1 NOTICE: BL3-1: Running on A64/H64 (1689) in SRAM A2 (@0x44000) NOTICE: Configuring SPC Controller NOTICE: BL3-1: v1.0(debug):c9f55c0 NOTICE: BL3-1: Built : 10:25:02, Feb 8 2019 NOTICE: DT: sun50i-a64-olinuxino INFO: Configuring AXP PMIC INFO: PMIC: DRAM voltage: 1.36V INFO: PMIC: setup successful NOTICE: SCPI: dummy stub handler, implementation level: 000000 INFO: BL3-1: Initializing runtime services INFO: BL3-1: Preparing for EL3 exit to normal world INFO: BL3-1: Next image address: 0x4a000000, SPSR: 0x3c9 U-Boot 2018.11-rc3-armbian (Feb 08 2019 - 10:25:08 +0100) Allwinner Technology CPU: Allwinner A64 (SUN50I) Model: Olimex A64-Olinuxino DRAM: 1 GiB MMC: SUNXI SD/MMC: 0, SUNXI SD/MMC: 1 Loading Environment from FAT... Card did not respond to voltage select! In: serial Out: serial Err: serial Net: phy interface7 eth0: ethernet@1c30000 230454 bytes read in 20 ms (11 MiB/s) starting USB... USB0: USB EHCI 1.00 USB1: USB OHCI 1.0 USB2: USB EHCI 1.00 USB3: USB OHCI 1.0 scanning bus 0 for devices... 1 USB Device(s) found scanning bus 2 for devices... 1 USB Device(s) found scanning usb for storage devices... 0 Storage Device(s) found Autoboot in 1 seconds, press <Space> to stop switch to partitions #0, OK mmc0 is current device Scanning mmc 0:1... Found U-Boot script /boot/boot.scr 3042 bytes read in 12 ms (247.1 KiB/s) ## Executing script at 4fc00000 U-boot loaded from SD Boot script loaded from mmc 104 bytes read in 12 ms (7.8 KiB/s) 34222 bytes read in 22 ms (1.5 MiB/s) 3795 bytes read in 18 ms (205.1 KiB/s) Applying kernel provided DT fixup script (sun50i-a64-fixup.scr) ## Executing script at 44000000 8808437 bytes read in 446 ms (18.8 MiB/s) 14243848 bytes read in 709 ms (19.2 MiB/s) ## Loading init Ramdisk from Legacy Image at 4fe00000 ... Image Name: uInitrd Image Type: AArch64 Linux RAMDisk Image (gzip compressed) Data Size: 8808373 Bytes = 8.4 MiB Load Address: 00000000 Entry Point: 00000000 Verifying Checksum ... OK ## Flattened Device Tree blob at 4fa00000 Booting using the fdt blob at 0x4fa00000 EHCI failed to shut down host controller. EHCI failed to shut down host controller. Loading Ramdisk to 49799000, end 49fff7b5 ... OK reserving fdt memory region: addr=4fa00000 size=6e000 Loading Device Tree to 0000000049728000, end 0000000049798fff ... OK Starting kernel ... [ 10.445290] kernel BUG at arch/arm64/kernel/traps.c:412! [ 10.450877] Internal error: Oops - BUG: 0 [#1] SMP [ 10.456045] Modules linked in: zram r8723bs(C) snd_soc_spdif_tx snd_soc_hdmi_codec sun50i_codec_analog cfg80211 snd_soc_simple_card sun8i_adda_pr_regmap sun8i_codec sun4i_i2s snd_soc_simple_card_utils rfkill snd_soc_core snd_pcm_dmaengine snd_pcm snd_timer snd axp20x_battery axp20x_ac_power axp20x_adc soundcore sun4i_gpadc_iio industrialio cpufreq_dt thermal_sys sch_fq_codel lima pinctrl_axp209 gpu_sched ttm dw_hdmi_cec dw_hdmi_i2s_audio micrel [ 10.495500] CPU: 1 PID: 0 Comm: swapper/1 Tainted: G C 4.19.20-sunxi64 #5.75 [ 10.503850] Hardware name: Olimex A64-Olinuxino (DT) [ 10.508818] pstate: 00000085 (nzcv daIf -PAN -UAO) [ 10.513625] pc : do_undefinstr+0xdc/0x2d8 [ 10.517638] lr : do_undefinstr+0xc8/0x2d8 [ 10.521649] sp : ffff00000800bc10 [ 10.524966] x29: ffff00000800bc10 x28: ffff80003aa51980 [ 10.530283] x27: ffff80003bf8cd40 x26: 0000000000000000 [ 10.535601] x25: 0000000000000080 x24: 0000000000000000 [ 10.540917] x23: 0000000000000085 x22: ffff0000080e3900 [ 10.546234] x21: ffff00000800bdb0 x20: ffff00000800bc70 [ 10.551551] x19: ffff000008d68000 x18: 0000000000000000 [ 10.556960] x17: 0000000000000000 x16: 0000000000000000 [ 10.562726] x15: 0000000000000400 x14: 0000000000000000 [ 10.568033] x13: 0000000000000000 x12: 0000000000000000 [ 10.573342] x11: 0000000000000000 x10: 0000000000000000 [ 10.578649] x9 : 0000000000000000 x8 : 0000000000000000 [ 10.583957] x7 : 0000000000000000 x6 : ffff800009940458 [ 10.589265] x5 : 0000000000000000 x4 : 0000000000000000 [ 10.594574] x3 : 0000800033237000 x2 : 0000000000000000 [ 10.599882] x1 : 1fb76a7ec3aad500 x0 : 0000000000000085 [ 10.605193] Process swapper/1 (pid: 0, stack limit = 0x(____ptrval____)) [ 10.611886] Call trace: [ 10.614332] do_undefinstr+0xdc/0x2d8 [ 10.617993] el1_undef+0x10/0x70 [ 10.621222] account_process_tick+0x30/0x118 [ 10.625491] update_process_times+0x20/0x58 [ 10.629674] tick_sched_handle.isra.5+0x30/0x48 [ 10.634201] tick_sched_timer+0x48/0x98 [ 10.638034] __hrtimer_run_queues+0xe4/0x1f8 [ 10.642301] hrtimer_interrupt+0xf4/0x2b0 [ 10.646311] arch_timer_handler_phys+0x28/0x40 [ 10.650752] handle_percpu_devid_irq+0x80/0x138 [ 10.655281] generic_handle_irq+0x24/0x38 [ 10.659288] __handle_domain_irq+0x5c/0xb0 [ 10.663381] gic_handle_irq+0x58/0xa8 [ 10.667040] el1_irq+0xb0/0x140 [ 10.670181] arch_cpu_idle+0x10/0x18 [ 10.673755] do_idle+0x1d4/0x298 [ 10.676980] cpu_startup_entry+0x20/0x28 [ 10.680901] secondary_start_kernel+0x18c/0x1c8 [ 10.685429] Code: f2400c1f 54fffae0 a9025bb5 f9001bb7 (d4210000) [ 10.691517] ---[ end trace c8e5f6cf237b08c3 ]--- [ 10.696131] Kernel panic - not syncing: Fatal exception in interrupt [ 10.702480] SMP: stopping secondary CPUs [ 10.706400] Kernel Offset: disabled [ 10.709887] CPU features: 0x0,24802004 [ 10.713630] Memory Limit: none [ 10.716685] Rebooting in 10 seconds.. I also tried changing the SD card and with 2 other same board. I was looking forward to this release. am I doing something wrong? I loaded the SD card using dcfldd