gen2thomas

  • Posts

    11
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

gen2thomas's Achievements

  1. Hello, I'm trying to use i2c (i2c1, i2c4) with fresh installed image "Armbian_21.05.1_Tinkerboard_focal_current_5.10.34.img.xz". The related overlays seems to be enabled by default: cat /boot/armbianEnv.txt verbosity=1 bootlogo=false overlay_prefix=rockchip overlays=i2c1 i2c4 spi2 spidev2 uart1 uart2 rootdev=UUID=68be20e3-93fc-4c59-95e1-0c534586d070 rootfstype=ext4 usbstoragequirks=0x2537:0x1066:u,0x2537:0x1068:u i2c is enabled by default: i2cdetect -l i2c-2 i2c rk3x-i2c I2C adapter i2c-0 i2c rk3x-i2c I2C adapter i2c-5 i2c rk3x-i2c I2C adapter What I have missed to setup? Thanks Thomas
  2. Please read this topic, eventually this could help you:
  3. Using the "/atc/asound.conf" for this to prevent modifications of the system file "/usr/share/alsa/cards/USB-Audio.conf" is pretty simple. * Open the files "/etc/asound.conf" and "/usr/share/alsa/cards/USB-Audio.conf" with your prefered editor. * Copy the last two sections of the "USB-Audio.conf" incl. "<confdir:pcm/iec958.conf>" to the "asound.conf" (at the end of the file). * Close the file "USB-Audio.conf". * Add "cards." before the section description e.g. "cards.USB-Audio.pcm.iec958.0 {...}". in "asound.conf" * Change the values "default 0" to "default 999" and "default 999" to "default 1". * alsactl init * "aplay -L|grep iec958" will gives only the right device iec958:CARD=OnBoard,DEV=1 The result should look something like this: Unfortunately some devices will disappear for alsa front, surround21, surround41, surround50, surround51, surround71 In case of active using such devices the copy procedure must repeated for each needed device. For simple tests with mpv generate your configuration file Add/open the file ".config/mpv/mpv.conf" with your editor. Add the next lines to it (actually HDMI is active):
  4. For now I have only an dirty hack to force alsa to get the correct device number. Manipulate file * Open "/usr/share/alsa/cards/USB-Audio.conf" and jump to the end of the file. * In section "USB-Audio.pcm.iec958.1" set the value of "default 999" to another value, e.g. "1". "999" means "deactivated". Restart alsa and check * alsactl init * "aplay -L|grep iec958" will gives a new device iec958:CARD=OnBoard,DEV=0 iec958:CARD=OnBoard,DEV=1 Remove the wrong device and check * Open "/usr/share/alsa/cards/USB-Audio.conf" and jump to the end of the file. * In section "USB-Audio.pcm.iec958.0" set the value of "default 0" to "999". * alsactl init * "aplay -L|grep iec958" will gives only the right device iec958:CARD=OnBoard,DEV=1 Test mpv: * open command line (so you can see the messages from mpv) * start "mpv MyMovie.mkv" --> the movie plays (eventually without audio when no fiber cable is connected to your sound system) * stop video and see there is no error anymore for audio * recognize the line "AO: [alsa] 48000Hz stereo 2ch spdif-ac3" --> seems to be the correct paththrough Next step is to prevent this dirty hack with "/etc/asound.conf" or another solution for normally use. Any idea? BTW: This also works great with KODI!
  5. Hi, I have made some progress for SPDIF paththrough. All tests are made with alsa and mpv, therefore pulsaudio was deactivated to simplify things. Remember was the problem is: aplay -L|grep iec958 iec958:CARD=OnBoard,DEV=0 Which is wrong for tinkerboard, it should be "DEV=1" Deactivate pulsaudio (use sudo if necessary) refer to KodiWiki: * open "/etc/pulse/client.conf", set autospawn from "yes" to "no" and remove comment sign ";" * reboot or just "pulseaudio --kill" Prepare mpv with configuration in users home directory: * open/create ~/.config/mpv/mpv.conf and add some content for play with: Test mpv: * make an ac3 (or another) video available for testing e.g. in users home directory * open command line (so you can see the messages from mpv) * start "mpv MyMovie.mkv" --> the movie plays without audio * stop video and see some errors from mpv marked with [ao] * modify mpv.conf for your preferred output and start the movie again --> this should work Fix the problem * see next post(s)
  6. After some playing around with "aplay -L" and "speaker-test -D" the device "iec958" seems to be not OK. iec958:CARD=OnBoard,DEV=0 USB Audio OnBoard, USB Audio IEC958 (S/PDIF) Digital Audio Output All devices with "DEV=1" in the name, except "dsnoop" switches the LED light on while playing with speaker-test. The iec958 device only works with "-r8000" like all other devices with "DEV=0" (possible BT-devices) and the LED light keeps off. see also "cat /proc/asound/card0/stream0" --> gives the rate 8000 The test code: "speaker-test -D iec958:CARD=OnBoard,DEV=0 -c2 -r8000" This only works with r8000: "speaker-test -D dmix:CARD=OnBoard,DEV=0 -c2 -r8000" This switched the LED on: "speaker-test -D dmix:CARD=OnBoard,DEV=1 -c2" This gives sound on head phone: "speaker-test -D dmix:CARD=OnBoard,DEV=2 -c2" Is this wrong mapping, a configuration failure or an kernel issue?
  7. I'm not able to configure armbian nor KODI with paththrough. Only stereo is available. Can I solve this (with configuration and/or rebuild of kernel and/or KODI) or is this an known limitation at the moment?
  8. Hi, this depends on your installation procedure. In case of "apt-get install kodi" (installs v17.x krypton) you can try this site. I cleaned up my old installation first by "apt-get purge *kodi*". After install "apt-get install kodi" I get the v18.1 leia (on my lubuntu x86_64 notebook). In case of using the media-script this is also interesting to me because start without running X on armbian device: @JMCC please can you give us some explanation how to build kodi like you.
  9. Toslink on armbian (using pulseaudio) works fine with my music center. I tried the media script and installed accelerated Kodi (it is not the latest release) from that. Now Kodi is smooth enough and SPDIF is available in audio configuration of Kodi. Next I will test it by playing an video and, when running good enough, configure it to start Kodi on system startup. This could be an alternative to LibreELEC in case of I can't get it to work with S/PDIF.
  10. Thank you very much! Such simple solution - the red LED now was switched on. Is there the same solution using LibreELEC? Background information: Armbian actually is very slow with Kodi installation, with LibreELEC it runs smoothly but without SPDIF at the moment. Alternatively I could activate hardware acceleration for GPU in armbian, but how to do?
  11. Hello, I want to enable sound using the S/PDIF on my tinker board. What I have to do? At the moment I have attached an optical transmitter jack (toslink) at the specified output (pin between USB and LAN connector, the outer one, pin4 - 5V & pin6 - GND). I have installed the "ARMBIAN 5.73 stable Ubuntu 18.04.2 LTS 4.19.20-rockchip". $ aplay -l **** List of PLAYBACK Hardware Devices **** card 0: OnBoard [USB Audio OnBoard], device 0: USB Audio [USB Audio] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: OnBoard [USB Audio OnBoard], device 1: USB Audio [USB Audio #1] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: OnBoard [USB Audio OnBoard], device 2: USB Audio [USB Audio #2] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: rockchiptinkerc [rockchip,tinker-codec], device 0: ff890000.i2s-i2s-hifi i2s-hifi-0 [] Subdevices: 1/1 Subdevice #0: subdevice #0