Rafal

Members
  • Content Count

    11
  • Joined

  • Last visited

About Rafal

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi I would like to ask you can I connect my NanoPi Neo Core 2 (Armbian) with LCD TFT 3.2 (320x240)px by GPIO and SPI. RPi driver module LCD-show is nor response and don,t work. Anybody has experience or know how to do that. Is it possible.
  2. Hi I have strange problem with my nano pi neo core 2. The device was working a few days then suddenly I lost my ssh connection. I used serial port to communication to see what happened and I get reply below. The last line it is a Error so I should reset my device. I did it several times and the result is the same. I'm not specialist but I supposed it is something wrong with eMMC memory because if I insert SD card with armbian it starts normally. Anyone have idea what was that, what happened. My nano pi shows week light of red LED. U-Boot SPL 2018.11-armbian (Feb 08 2019 - 11:05:25 +0100) DRAM: 1024 MiB Trying to boot from MMC2 NOTICE: BL31: v2.0(debug):30490b1 NOTICE: BL31: Built : 19:11:09, Feb 6 2019 NOTICE: BL31: Detected Allwinner H5 SoC (1718) NOTICE: BL31: Found U-Boot DTB at 0x40843b8, model: FriendlyARM NanoPi NEO Core 2 INFO: ARM GICv2 driver initialized INFO: Configuring SPC Controller NOTICE: BL31: PMIC: Defaulting to PortL GPIO acorrding to H5 reference design INFO: BL31: Platform setup done INFO: BL31: Initializing runtime services INFO: BL31: cortex_a53: CPU workaround for 855873 was applied INFO: BL31: Preparing for EL3 exit to normal world INFO: Entry point address = 0x4a000000 INFO: SPSR = 0x3c9 U-Boot 2018.11-armbian (Feb 08 2019 - 11:05:25 +0100) Allwinner Technology CPU: Allwinner H5(SUN50I) Model: FriendlyARM NanoPi NEO Core 2 DRAM: 1 GiB MMC: SUNXI SD/MMC: 0 ,SUNXI SD/MMC:1 Loading Enviroment from EXT4... MMC: no card present In: serial Out: serial Err: serial Net: No ethernet found. MMC: no card present MMC: no card present starting USB... USB0: USB EHCI 1.00 USB1: USB OHCI 1.0 scanning bus 0 for devices... 1 USB Device(s) found scanning us for storage devices... 0 Storage Device(s) found Autoboot in 1 second, press <Space> to stop swich to partitions #0, OK mmc1(part 0) is current device Scanning mmc 1:1... Found U-Boot script /boot/boot.src 3042 bytes read in 7 ms (423.8 KiB/s) ## Executing script at 4fc00000 U-boot loaded from eMMC or secondary SD Boot script loaded from mmc 5080090 bytes read in 28 ms (17.3 MiB/s) MMC: no card present 28982 bytes read in 15 ms (1.8 MiB/s) 374 bytes read in 14 ms (25.4 KiB/s) Applying kernel provided DT overlay sun50i-h5-i2c0.dtbo 374 bytes read in 14 ms (25.4 KiB/s) Applying kerenl provided DT overaly sun50i-h5-i2c1.dtbo 502 bytes read in 16 ms (30.3 KiB/s) Applying kernel provided DT overlay sun50i-h5-uart1.dtbo 777 bytes read in 19 ms (39.1 KiB/s) Applying kernel provided DT overlay sun50i-h5-w1-gpio.dtbo 4155 bytes read in 14 ms (289.1 KiB/s) Applying kernel provided DT fixup script (sun50i-h5-fixup.scr) ## Executing script at 44000000 tmp_bank=A tmp_pin=1 5328003 bytes read in 268 ms (19 MiB/s) 14243848 bytes read in 702 ms (19.4 MiB/s) ## Loading init Ramdisk from Legacy Image at 4fe00000 ... Image Name: uInitrd Image Type: AArch64 Linux RAMDisk Image (gzip compressed) Data Size: 5327939 Bytes = 5.1 MiB Load Address: 00000000 Entry Point: 00000000 Veryfying Checksum ... OK ## Flattend Device Tree blob at 4fa00000 Booting using the fdt blob at 0x4fa00000 EHCI failed to shut down host controller. Loading Ramdisk to 49aeb000, end 49fffc43 ... OK reserving fdt memory region: addr=4fa00000 size=6d000 Lading Device Tree to 0000000049a7b00, end 0000000049aeaff ... OK WARNING: could not set bootargs FDT_ERR_NOSPACE. ERROR: /chosen node create failed -must RESET the board to recover FDT creation failed! hanging...### ERROR ### Please RESET the board ###
  3. I solved this problem. Thank you for advices. I use pyserial and rpi.gpio library to my nanoPi and RS communication is working.
  4. Hi thank you for yours ideas. I work with module MAX485+ and work perfect with AVR micro-controller. I would like to have RS-485 protocol to my nanoPi. I saw we can easily connect raspberry pi to max485 module : https://www.google.com/search?client=ubuntu&channel=fs&tbm=isch&sa=1&ei=hJOPXLSpDaSurgTl6LfoCg&q=MAX485+rpi+&oq=MAX485+rpi+&gs_l=img.3...793957.793957..794407...0.0..0.82.82.1......1....1..gws-wiz-img.3g77RWZ6_Xc So we can connect Rpi to this module but nanoPi doesn't work?
  5. Hi I would like to ask you how to use MAX485 module to communicate 2 NanoPi Neo Core 2. I would like to use UART0 (it is GPIO4 and 5). I connection my module similar to this picture: https://www.google.com/search?q=max+485&client=ubuntu&hs=ern&channel=fs&tbm=isch&source=iu&ictx=1&fir=FN56jmGIPP4yJM%3A%2CBP52RgiAvdjG4M%2C_&vet=1&usg=AI4_-kQK1TQEVXzv7J4_kJ8nEnLbgH0X5w&sa=X&ved=2ahUKEwjxy57J2oHhAhVpsosKHZTnCnAQ9QEwBHoECAUQDA#imgrc=Jkfuqm9JL_mJXM:&vet=1 I wrote python3 code send.py : import RPi.GPIO as GPIO import time import serial import os EN_485 = 24 GPIO.setmode(GPIO.BOARD) GPIO.setup(EN_485,GPIO.OUT) print("Test1") send_str = input("Wiadomosc testowa 123123123") ser = serial.Serial(port='/dev/ttyS0',baudrate =115200,bytesize=8,stopbits=1,timeout=1) last_time = time.time() print("Test2") now_time = time.time() GPIO.output(EN_485,True) time.sleep(0.01) n = 80 try: while n>0: ser.write(send_str) n=n-1 time.sleep(0.5) print(n) except KeyboardInterrupt: GPIO.output(EN_485,False) But when I started program it 'freeze' on the line ser=serial.Serial(port[...]). So it print only "Test1" and waiting. Maybe someone have any idea why this program stop and waiting in this line?
  6. Thanks for the links. I' m working on armbian 5.75 stable debian on my nano pi neo core 2. I modify WiringNP library to my armbian version and it works great.
  7. I tried to read data from this phyton library but when I try to simpletest.py the error is: File "/usr/local/lib/python3.5/dist-packages/Adafruit_DHT-1.4.0-py3.5-linux-aarch64.egg/Adafruit_DHT/common.py", line 63, in get_platform raise RuntimeError('Unknown platform.') RuntimeError: Unknown platform.
  8. Hi. I would like to ask you how to add and read temperature and humidity from sensor DHT11 on Nano Pi Neo Core 2 with armbian. I want to use PA13 pin (CS form SPI1) I try to enable overlay: sudo modprobe dht11 cat /sys/bus/iio/devices/iio:device0/in_temp_sclae return : -119 When I try add dht11 to overlay in /boot/armbianEnv.txt this module after reboot is still disable. Any suggestions?
  9. Hi everyone. I have nano pi neo core 2 with ARMBIAN 5.75 stable Debian GNU/Linux 9 (stretch) 4.19.20-sunxi64. I try to change i2c speed from 100 000 to 400 000. I try: sudo fdtput -t i sun50i-h5-nanopi-neo-core2.dtb i2c0 clock-frequency 400000 Error at 'i2c0': FDT_ERR_BADPATH Anyone have idea how to change i2c speed?