cynfab

Members
  • Content Count

    7
  • Joined

  • Last visited

  1. cynfab

    Orange Pi Zero Wifi connection Issues

    Well the security was the key, I had just assumed that if the network manager of jessie could handle an AP with no security that the one from Xenial could as well. My bad. When I turned on WPA and gave the AP a password, then tried to activate with nmtui, it immediately asked for a password, then associated and connected to the AP. Which can now ping out to the internet. After about 10 pings of 15ms to google.com I get 2-3 pings of 2000-4500ms then it's back to 15-20ms, then sporadically I'll get another looong ping time. BUT That's another issue. Thanks for the assistance.
  2. cynfab

    Orange Pi Zero Wifi connection Issues

    Most of my AP's have no security/encription. And since my jessie legacy kernel can connect to any of them I don't think it is a hardware issue with the OPi. I'll fiddle with different AP settings and see what happens.
  3. cynfab

    Orange Pi Zero Wifi connection Issues

    I have been having wifi connection issues with the OPi Zero as well. But only with the mainline kernel. With the legacy kernel, I can connect to my various access points and transfer data, SSH etc. I wanted to try out the mainline kernel, so about a month ago I downloaded one of the nightly builds I was not surprised that the WiFi didn't work at all. I waited several days while reading the forums and once folks were reporting a working mainline, I tried again. THis time I could see access points but could not associate. After a while I started investigating what could be wrong with my setup. At this point I had a working jessie 3.4.113 and a non working Xenial 4.9.0 (not working wifi that is). Both stock installs of Armbian 5.24. I tried several power sources, several usb cables, old slow SD cards, and new fast SD cards. All results were consistent, jessie 3.4.113 worked, Xenial 4,9.0 then 4.9.1,4.9.2,4.9.3 didn't. I then thought that maybe I had a bad OPi Zero, so I ordered and waited 3 weeks to get a second. It arrived the other day and all results with the new board were the same. Today I saw that there was an actual release of Xenial 4.9.4 for the OPi Zero. Downloaded it and got the same results. Ethernet works on both jessie and xenial. I have tried with the ethernet cable connected and disconnected. I have tried with power management on and off. I can do a iwlist scan and see access points on both systems. It almost seems like there is no data being sent from the OPi with Xenial. I probed the 1.8V and 3.3V power for the Wifi chip and both are at nominal levels. Both my boards are 512M and came with the SPI flash soldered on. This is a stock installation of the Armbian Xenial 4.9.4 I downloaded on 1/26/2017. No other packages have been loaded, upgraded or configurations changed. Messages which might be of interest: iwconfig wlan0 essid MyAP [ 1408.950945] xradio_wlan mmc1:0001:1: missed interrupt [ 1449.630902] wlan0: authenticate with 18:a6:f7:02:4d:fa [ 1449.630999] ieee80211 phy0: ignore IEEE80211_CONF_CHANGE_MONITOR (0)IEEE80211_CONF_CHANGE_IDLE (1) [ 1449.631309] wlan0: send auth to 18:a6:f7:02:4d:fa (try 1/3) [ 1449.631713] wlan0: send auth to 18:a6:f7:02:4d:fa (try 2/3) [ 1449.631858] wlan0: send auth to 18:a6:f7:02:4d:fa (try 3/3) [ 1449.631964] wlan0: authentication with 18:a6:f7:02:4d:fa timed out after ifconfig eth0 dowm then iwconfig wlan0 essid MyOtherAP [ 2237.719983] wlan0: authenticate with f4:f2:6d:a3:0e:5c [ 2237.720124] ieee80211 phy0: ignore IEEE80211_CONF_CHANGE_MONITOR (0)IEEE80211_CONF_CHANGE_IDLE (1) [ 2237.720154] ieee80211 phy0: Freq 2412 (wsm ch: 1). [ 2237.721079] wlan0: send auth to f4:f2:6d:a3:0e:5c (try 1/3) [ 2237.721619] wlan0: send auth to f4:f2:6d:a3:0e:5c (try 2/3) [ 2237.721951] wlan0: send auth to f4:f2:6d:a3:0e:5c (try 3/3) [ 2237.722278] wlan0: authentication with f4:f2:6d:a3:0e:5c timed out [ 2237.761757] ieee80211 phy0: ignore IEEE80211_CONF_CHANGE_MONITOR (0)IEEE80211_CONF_CHANGE_IDLE (1) modinfo xradio_wlan filename: /lib/modules/4.9.4-sun8i/kernel/drivers/net/wireless/xradio/xradio_wlan.ko alias: xradio_core license: GPL description: XRadioTech WLAN driver core author: XRadioTech alias: sdio:c*v0020d2281* depends: mac80211,cfg80211 intree: Y vermagic: 4.9.4-sun8i SMP mod_unload ARMv7 thumb2 p2v8 iw wlan0 info Interface wlan0 ifindex 3 wdev 0x1 addr 12:42:87:47:5c:af type managed wiphy 0 lsmod Module Size Used by evdev 10043 0 xradio_wlan 92375 1 mac80211 322651 1 xradio_wlan cfg80211 191902 2 mac80211,xradio_wlan rfkill 10928 3 cfg80211 sun8i_ths 3134 0 gpio_keys 8453 0 cpufreq_dt 3586 0 uio_pdrv_genirq 3354 0 thermal_sys 42239 2 cpufreq_dt,sun8i_ths uio 8012 1 uio_pdrv_genirq ip link show wlan0 3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000 link/ether 12:42:87:47:5c:af brd ff:ff:ff:ff:ff:ff uname -a Linux orangepizero 4.9.4-sun8i #3 SMP Fri Jan 20 22:11:20 CET 2017 armv7l armv7l armv7l GNU/Linux nmcli device show GENERAL.DEVICE: eth0 GENERAL.TYPE: ethernet GENERAL.HWADDR: 02:42:87:47:5C:AF GENERAL.MTU: 1500 GENERAL.STATE: 30 (disconnected) GENERAL.CONNECTION: -- GENERAL.CON-PATH: -- WIRED-PROPERTIES.CARRIER: on GENERAL.DEVICE: wlan0 GENERAL.TYPE: wifi GENERAL.HWADDR: 12:42:87:47:5C:AF GENERAL.MTU: 0 GENERAL.STATE: 30 (disconnected) GENERAL.CONNECTION: -- GENERAL.CON-PATH: -- GENERAL.DEVICE: lo GENERAL.TYPE: loopback GENERAL.HWADDR: 00:00:00:00:00:00 GENERAL.MTU: 65536 GENERAL.STATE: 10 (unmanaged) GENERAL.CONNECTION: -- GENERAL.CON-PATH: -- IP4.ADDRESS[1]: 127.0.0.1/8 IP4.GATEWAY: IP6.ADDRESS[1]: ::1/128 IP6.GATEWAY: systemctl status network-manager ��◠NetworkManager.service - Network Manager Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor p Active: active (running) since Sat 2017-01-21 01:39:25 UTC; 31min ago Main PID: 543 (NetworkManager) CGroup: /system.slice/NetworkManager.service ��└��─543 /usr/sbin/NetworkManager --no-daemon Jan 21 02:06:27 orangepizero NetworkManager[543]: <info> [1484964387.6761] devi Jan 21 02:06:27 orangepizero NetworkManager[543]: <info> [1484964387.6777] poli Jan 21 02:06:27 orangepizero NetworkManager[543]: <warn> [1484964387.6790] devi Jan 21 02:06:27 orangepizero NetworkManager[543]: <info> [1484964387.6810] devi Jan 21 02:06:27 orangepizero NetworkManager[543]: <info> [1484964387.6821] mana Jan 21 02:06:27 orangepizero NetworkManager[543]: <info> [1484964387.6829] poli Jan 21 02:06:27 orangepizero NetworkManager[543]: <warn> [1484964387.6840] devi Jan 21 02:06:27 orangepizero NetworkManager[543]: <info> [1484964387.6871] devi Jan 21 02:06:27 orangepizero NetworkManager[543]: <info> [1484964387.6945] devi Jan 21 02:06:32 orangepizero NetworkManager[543]: <info> [1484964392.9635] devi My question is this, where should I go from here to debug this issue, has anyone seen the same or similar problems. I have been able to rebuild the kernel from sources using the Armbian tools, but that was a few days ago with 4.9.3 and now that 4.9.4 is in use, I haven't had time to try building it again. My thoughts were to turn on wifi debugging and see what messages came out. For my project I could use the legacy kernel, but I'd rather not. BTW. I AM in a rural area where the only AP's I see are my own, and there is little other traffic on 2.4G (this may not last forever, but today I can use 2.4G.)
  4. cynfab

    OrangePih3 build fails

    I posted both issues because I have 2 separate projects, one with a PcDuino3 Nano Lite and one with an Orange Pi One. These issues may be related but then maybe not. Project #1 wanted to use a pre-built image for the PcDuino, It wouldn't boot even to getting past u-boot-spl to u-boot. Clearly something wrong with how the pre-built image was put together. Project #2 wanted to see how progress on getting the H3 supported was going and compiling my own kernel usually gives me a good indication of how bleeding the edge is. I wanted to provide some feedback as Igor requested on the opening Armbian page. So 2 posts for 2 issues, hoped my install.log would help.
  5. cynfab

    OrangePih3 build fails

    Thanks for the tip. I added BOOTBRANCH='v2016.03' to compile.sh but this patch still seems broken: /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/u-boot-02-support-cheap-mmc.patch u-boot-dev 2016.03 patch unexpectedly ends in middle of line I then tried v2016.05-rc1 and the compile of u-boot and the kernel succeded. install.log for 2016.03: Displaying message: Preparing host info Displaying message: Host system support was not tested rosa wrn Config: linux-sun8i-dev Kernel source: https://github.com/wens/linux Branch: h3-emac linuxsource: linux-sun8i-mainline Offset: 1 bootsize: 0 bootloader: git://git.denx.de/u-boot.git bootsource: u-boot bootbranch: v2016.03 CPU 480000 / 1296000 with ondemand 02.05.2016 10:06:52 Armbian 5.11 Orangepih3 Debian dev Displaying message: Starting Armbian build script @host info Displaying message: Compiling kernel orangepih3 info Displaying message: Syncing clock host info Displaying message: source downloading @host info Displaying message: ... creating a shallow clone u-boot v2016.03 info Displaying message: ... updating linux-sun8i-mainline info Displaying message: ... updating sunxi-tools info Displaying message: ... updating sunxi-display-changer info Displaying message: Compiling sunxi tools @host & target info Displaying message: Cleaning /media/kenm/usr5/OrangePiOne/Armbian/sources/u-boot/v2016.03 info Displaying message: Cleaning /media/kenm/usr5/OrangePiOne/Armbian/sources/linux-sun8i-mainline/h3-emac info Displaying message: Cleaning /media/kenm/usr5/OrangePiOne/Armbian/output/debs for orangepih3 dev info Displaying message: Started patching process for u-boot u-boot-dev 2016.03 info Displaying message: Looking for user patches in userpatches/u-boot/u-boot-dev info /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/add-awsom-uboot.patch u-boot-dev 2016.03 Displaying message: ... add-awsom-uboot.patch succeeded info /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/add-cubieboard4.patch u-boot-dev 2016.03 Displaying message: ... add-cubieboard4.patch succeeded info /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/u-boot-02-support-cheap-mmc.patch u-boot-dev 2016.03 patch unexpectedly ends in middle of line Displaying message: ... u-boot-02-support-cheap-mmc.patch succeeded info /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/u-boot-99-opi-change-build-settings.patch u-boot-dev 2016.03 1 out of 1 hunk FAILED -- saving rejects to file configs/orangepi_pc_defconfig.rej 1 out of 1 hunk FAILED -- saving rejects to file configs/orangepi_plus_defconfig.rej 1 out of 1 hunk FAILED -- saving rejects to file arch/arm/dts/Makefile.rej The text leading up to this was: -------------------------- |diff --git a/configs/orangepi_2_defconfig b/configs/orangepi_2_defconfig |index ff9ac09..992cfa1 100644 |--- a/configs/orangepi_2_defconfig |+++ b/configs/orangepi_2_defconfig -------------------------- No file to patch. Skipping patch. 1 out of 1 hunk ignored Displaying message: ... u-boot-99-opi-change-build-settings.patch failed wrn /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/u-boot-fix-3f9f8a5b83f8aec40c9f4ee496046a695e333c45-null-pointer-dereference.patch u-boot-dev 2016.03 1 out of 1 hunk FAILED -- saving rejects to file drivers/usb/host/ehci-hcd.c.rej Displaying message: ... u-boot-fix-3f9f8a5b83f8aec40c9f4ee496046a695e333c45-null-pointer-dereference.patch failed wrn /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/u-boot-set-safe-axi_apb-clock-dividers.patch u-boot-dev 2016.03 The text leading up to this was: -------------------------- |diff --git a/arch/arm/mach-sunxi/clock_sun6i.c b/arch/arm/mach-sunxi/clock_sun6i.c |index 15272c9..cedddc2 100644 |--- a/arch/arm/mach-sunxi/clock_sun6i.c |+++ b/arch/arm/mach-sunxi/clock_sun6i.c -------------------------- No file to patch. Skipping patch. 1 out of 1 hunk ignored The text leading up to this was: -------------------------- |diff --git a/arch/arm/mach-sunxi/clock_sun6i.c b/arch/arm/mach-sunxi/clock_sun6i.c |index cedddc2..3fe9305 100644 |--- a/arch/arm/mach-sunxi/clock_sun6i.c |+++ b/arch/arm/mach-sunxi/clock_sun6i.c -------------------------- No file to patch. Skipping patch. 1 out of 1 hunk ignored Displaying message: ... u-boot-set-safe-axi_apb-clock-dividers.patch failed wrn Displaying message: Compiling uboot. Please wait. info arm-linux-gnueabihf-gcc (Ubuntu/Linaro 4.8.4-2ubuntu1~14.04.1) 4.8.4 Displaying message: Target directory /media/kenm/usr5/OrangePiOne/Armbian/output/debs/ info Displaying message: Building deb linux-u-boot-dev-orangepih3_5.11_armhf.deb info Displaying message: ERROR in function compile_uboot common.sh:162 err Displaying message: Building u-boot failed, check configuration err Displaying message: Process terminated info
  6. cynfab

    OrangePih3 build fails

    Tried to build kernel only for OrangePih3 ( I have an Orange Pi One) and the build failed while trying to patch u-boot. Below is the install.log file since the forum software won't let me upload a file of type .log and once I tried, it won't let me attach anything, but that's another problem... Which turned out to be a cockpit problem ;>P +++++++++++++++++++++++++++++++++++ Displaying message: Preparing host info Displaying message: Host system support was not tested rosa wrn Config: linux-sun8i-dev Kernel source: https://github.com/wens/linux Branch: h3-emac linuxsource: linux-sun8i-mainline Offset: 1 bootsize: 0 bootloader: git://git.denx.de/u-boot.git bootsource: u-boot bootbranch: CPU 480000 / 1296000 with ondemand 02.05.2016 08:15:40 Armbian 5.11 Orangepih3 Debian dev Displaying message: Starting Armbian build script @host info Displaying message: Compiling kernel orangepih3 info Displaying message: Syncing clock host info Displaying message: source downloading @host info Displaying message: ... updating u-boot info Displaying message: ... updating linux-sun8i-mainline info Displaying message: ... updating sunxi-tools info Displaying message: ... updating sunxi-display-changer info Displaying message: Compiling sunxi tools @host & target info Displaying message: Cleaning /media/kenm/usr5/OrangePiOne/Armbian/sources/u-boot/branchless info Displaying message: Cleaning /media/kenm/usr5/OrangePiOne/Armbian/sources/linux-sun8i-mainline/h3-emac info Displaying message: Cleaning /media/kenm/usr5/OrangePiOne/Armbian/output/debs for orangepih3 dev info Displaying message: Started patching process for u-boot u-boot-dev 2016.05-rc3 info Displaying message: Looking for user patches in userpatches/u-boot/u-boot-dev info /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/add-awsom-uboot.patch u-boot-dev 2016.05-rc3 Displaying message: ... add-awsom-uboot.patch succeeded info /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/add-cubieboard4.patch u-boot-dev 2016.05-rc3 Displaying message: ... add-cubieboard4.patch succeeded info /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/u-boot-02-support-cheap-mmc.patch u-boot-dev 2016.05-rc3 patch unexpectedly ends in middle of line Displaying message: ... u-boot-02-support-cheap-mmc.patch succeeded info /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/u-boot-99-opi-change-build-settings.patch u-boot-dev 2016.05-rc3 1 out of 1 hunk FAILED -- saving rejects to file configs/orangepi_pc_defconfig.rej 1 out of 1 hunk FAILED -- saving rejects to file configs/orangepi_plus_defconfig.rej 1 out of 1 hunk FAILED -- saving rejects to file configs/orangepi_2_defconfig.rej Displaying message: ... u-boot-99-opi-change-build-settings.patch failed wrn /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/u-boot-fix-3f9f8a5b83f8aec40c9f4ee496046a695e333c45-null-pointer-dereference.patch u-boot-dev 2016.05-rc3 Reversed (or previously applied) patch detected! Skipping patch. 1 out of 1 hunk ignored -- saving rejects to file drivers/usb/host/ehci-hcd.c.rej Displaying message: ... u-boot-fix-3f9f8a5b83f8aec40c9f4ee496046a695e333c45-null-pointer-dereference.patch failed wrn /media/kenm/usr5/OrangePiOne/Armbian/lib/patch/u-boot/u-boot-dev/u-boot-set-safe-axi_apb-clock-dividers.patch u-boot-dev 2016.05-rc3 Displaying message: ... u-boot-set-safe-axi_apb-clock-dividers.patch succeeded info Displaying message: Compiling uboot. Please wait. info arm-linux-gnueabihf-gcc (Ubuntu/Linaro 4.8.4-2ubuntu1~14.04.1) 4.8.4 Displaying message: Target directory /media/kenm/usr5/OrangePiOne/Armbian/output/debs/ info Displaying message: Building deb linux-u-boot-dev-orangepih3_5.11_armhf.deb info Displaying message: ERROR in function compile_uboot common.sh:162 err Displaying message: Building u-boot failed, check configuration err Displaying message: Process terminated info +++++++++++++++++++++++++++++++++ I edited my compile.sh file to select Kernel only. Using the menu after running ./compile.sh I selected orangepih3 and the latest dev version of the kernel. ...ken...
  7. I downloaded: http://mirror.igorpecovnik.com/Armbian_5.10_Pcduino3nano_Debian_jessie_4.5.2_desktop.7z and burned it to an SD card, when I tried booting the board, all I get on the uart console is the u-boot SPL signon message +++++++++++++++++++++++++++++++ U-Boot SPL 2016.01-armbian-sun8i (May 01 2016 - 01:05:19) DRAM: 1024 MiB CPU: 912000000Hz, AXI/AHB/APB: 3/2/2 Could not determine boot source resetting ... +++++++++++++++++++++++++++++++ This repeats forever... I had previously used: http://mirror.igorpecovnik.com/Armbian_5.00_Pcduino3nano_Debian_jessie_4.4.1.zip and it worked fine on the same board. I tried recompiling u-boot from source using the Armbian build tools, with the same result. +++++++++++++++++++++++++++++++ U-Boot SPL 2016.05-rc3-armbian (May 01 2016 - 10:57:44) DRAM: 1024 MiB CPU: 912000000Hz, AXI/AHB/APB: 3/2/2 Could not determine boot source resetting ... +++++++++++++++++++++++++++++++ The board is a PcDuino3 Nano Lite which is the same as the non-Lite version except it is missing the NAND and IR receiver. any thoughts on what might be wrong?? ...ken...