Quang-vip

Members
  • Content Count

    13
  • Joined

  • Last visited

About Quang-vip

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Good news Several days ago, I tried armbian-config again to try to create a hotspot. And surprisingly, it worked :DD The hotspot has been running for days now. Thanks for your hard work @Igor, I really appreciate it
  2. Well, suddenly NetworkManager keeps telling rfkill to block the wlan interface (happens on boot and everytime I restart NetworkManager). But what's weirder is that even after I unblock the interface, it still can't scan for any wifi network. And as a result, the option to create a hotspot in armbian-config isn't available. However, if I start hostapd manually (an updated version thru apt I just updated yesterday), it will open a hotspot with that config file. But sadly it still doesn't want to authenticate. Welp I'll make more investigation on this.
  3. Surprisingly, it successfully ran with the config file in /etc, the network showed up in my phone But what I see weird is that despite the correct password I put into my phone, it didn't want to authenticate. I double checked the password in the config file and the one in my phone, they're the same but it kept telling me it wasn't correct Maybe I missed something or I didn't set it up correctly. But thanks for your temporary solution
  4. So I was trying to set up a portable wifi hotspot on my Orange Pi Zero (running Armbian buster with Linux 5.4.34-sunxi). But whenever I try to enable wifi hotspot on it through armbian-config, it refuses to create a hotspot. When I looked closely, it tried to probe the nl80211 driver without any error but then it also tried to probe realtek's driver, which is rtl871xdrv according to hostapd.conf in /etc . During its probing, in the corner of the terminal, it said: ioctl[SIOCSIWMODE]: Invalid argument And as a result, it returned the No compatible driver found error. I even tried to make NetworkManager ignore it (wlan0) and stop NetworkManager before enabling the hotspot, and start hostapd manually but no positive results. I'm using the pi's built-in wifi chip - XR819, I'm aware that this wifi chipset isn't greatly supported but before all of this mess, it ran without any hassle. I only encountered this problem after doing an apt upgrade. And I also tried to downgrade hostapd to an earlier version - 2.7 - but still, nothing. What can I do to make hostapd working again? Any help would be appreciated! I also included a screenshot of hostapd when I manually start it.
  5. Actually, I managed to get it to work, thanks to this thread and the author (It only applies to the H5 SoC from what I know..) https://forum.armbian.com/topic/9043-rtl8723bs-bluetooth/ And yes, I understand that Armbian is still being developed and not in anyway be perfect yet. But still, I really appreciate everyone's work to make this incredible OS for SBCs. Once again, thank you for helping me out You really saved my life
  6. Oh As I saw that it worked in the Android image flawlessly, oh well
  7. Oh and one more question Does the Bluetooth function work in Armbian for the Pi Prime? I can't seem to get it to work
  8. Ohh yesss This is exactly what I needed. I blacklisted it and walla, everything is normal now Though I don't know how it really worked (I thought Lima was the GPU's driver module), but yea, it did the job well. Thank you so much for your help, I really appreciate it
  9. Ok... So is there anyway to disable 3D hardware acceleration properly in Armbian? I have tried some solutions on Google (Stack overflow, ubuntu official forum). And they were to add some configurations in the 'xorg.conf', but that didn't bring any postive result..
  10. After some tinkering, I don't think have any 3rd hardware acceleration enabled...
  11. Alright, I'll give it a try when I have time but thanks for your suggestion
  12. So I just got my Orange Pi Prime board today and I tried the Ubuntu Bionic desktop image on it. (Armbian 20.02.3 Bionic current 5.4.18 desktop) Things didn't go like I expected... When I got into the desktop, all I saw was a missing taskbar, a white background (instead of a grey one) with a penguin on it. However, all the items on the taskbar worked normally. I thought that wasn't much until I tried to open Chromium, the whole window was white and I couldn't interact with it. I couldn't open the terminal either (clicking on its entry in the menu didn't launch it) I was shocked as I thought something was wrong with my board. So I told myself to try the Debian image instead. Surprisingly, it worked well (without any issues I mentioned above). What can I do to fix that issue? Is this a bug or software conflict? I really want to use the Ubuntu image (for now, I'm temporarily using the Debian one). Any suggestions would be appreciated! Oh and I'm wondering if the built-in bluetooth is supported on the Pi Prime right now?
  13. Soo, few weeks ago, I left the Orange Pi Zero unpowered. Then, now, after I power it on, I quickly ran the 'update' and 'upgrade' commands to upgrade my system... Well, then I ran 'armbianmonitor -m' to check my CPU's temperature and to see if I had installed the cooling fan correctly. Suddenly, I noticed its clock speed is no longer 1200Mhz maximum. I was freaked out then, so I quickly checked the CPU's lowest and highest clock speed using 'cpufreq', and it said that the maximum speed is 1008Mhz (About 1,008ghz), and the minimum speed is 120Mhz (About 0,12ghz). I don't understand why :v I only left it unpowered for a few weeks and now its clock speed just got decreased for no reasons (At least with my thoughts). So, do you have any workarounds for this problem (Like restoring its clock speed to the original, 1.2Ghz)? Any help would be appreciated! (And it's currently running Armbian 5.73 with the kernel version being '4.19.20-sunxi') Something like this: