thanxx

  • Posts

    11
  • Joined

  • Last visited

Everything posted by thanxx

  1. Sorry for a stupid question, but are those mainline builds able to detect the integrated wifi chip?
  2. Hi SteeMan, where one can find the 5.4 mainline images for amlogic? The balbes' resources hold only latest 5.10 builds
  3. I would like to enable the wifi/bt chip on Tanix TX5 MAX I am running armbian 20.10 with 5.90 kernel with the meson-g12a-tanix-tx5max.dtb The system does see the wifi chip, but it is not working / not listed in ifconfig as wlan0 dmesg output: [ 9.558455] RTW: module init start [ 9.558462] RTW: rtl88x2bs v5.2.21.3_28325.20180614_COEX20180430-5e5e [ 9.558464] RTW: build time: Oct 14 2020 11:49:19 [ 9.558466] RTW: rtl88x2bs BT-Coex version = COEX20180430-5e5e [ 9.558505] RTW: rtw_inetaddr_notifier_register [ 9.558718] RTW: == SDIO Card Info == [ 9.558723] RTW: clock: 50000000 Hz [ 9.558725] RTW: timing spec: sd high-speed [ 9.558728] RTW: sd3_bus_mode: FALSE [ 9.558730] RTW: ================ [ 9.558732] RTW: CHIP TYPE: RTL8822B [ 9.558796] RTW: [HALMAC]11692M [ 9.558798] RTW: [HALMAC]HALMAC_MAJOR_VER = 1 [ 9.558800] RTW: [HALMAC]HALMAC_PROTOTYPE_VER = 4 [ 9.558802] RTW: [HALMAC]HALMAC_MINOR_VER = 3 [ 9.558804] RTW: [HALMAC]HALMAC_PATCH_VER = 8 [ 9.558966] RTW: [HALMAC]12079M [ 9.558969] RTW: [HALMAC]HALMAC_MAJOR_VER_88XX = 1 [ 9.558971] RTW: [HALMAC]HALMAC_PROTOTYPE_88XX = 4 [ 9.558972] RTW: [HALMAC]HALMAC_MINOR_VER_88XX = 3 [ 9.558975] RTW: [HALMAC]HALMAC_PATCH_VER_88XX = 8 [ 9.559261] RTW: rtw_hal_config_rftype RF_Type is 2 TotalTxPath is 2 [ 9.559267] RTW: Chip Version Info: CHIP_8822B_Normal_Chip_UMC_D_CUT_2T2R_RomVer(3) [ 9.560221] RTW: WARN [HALMAC][WARN]halmac_mac_power_switch power state unchange! [ 9.567872] RTW: WARN rtw_halmac_poweron: Power state abnormal, try to recover...OK [ 9.568069] RTW: SetHwReg: bMacPwrCtrlOn=1 [ 9.636026] RTW: is_valid_id_status: HALMAC_FEATURE_DUMP_LOGICAL_EFUSE [ 9.636076] RTW: HW EFUSE [ 9.636082] RTW: 0x000: 29 81 00 3C 09 10 28 00 AA 04 AD 75 10 0E 30 0B [ 9.636104] RTW: 0x010: 27 27 27 27 27 27 27 27 27 27 27 02 00 00 FF FF .... [ 9.636967] RTW: EEPROM ID = 0x8129 [ 9.636970] RTW: EEPROM Version = 0 [ 9.637007] RTW: EEPROM Regulatory=0x01 [ 9.637011] RTW: EEPROM Board Type=0x01 [ 9.637014] RTW: EEPROM Enable BT-coex, ant_num=1 [ 9.637019] RTW: hal_com_config_channel_plan chplan:0x7F [ 9.637022] RTW: EEPROM crystal_cap=0x1e [ 9.637024] RTW: EEPROM ThermalMeter=0x1c [ 9.637026] RTW: EEPROM Customer ID=0x00 [ 9.637029] RTW: EEPROM SupportRemoteWakeup=0 [ 9.637033] RTW: EEPROM PAType_2G is 0x0, ExternalPA_2G = 0 [ 9.637036] RTW: EEPROM PAType_5G is 0x0, external_pa_5g = 0 [ 9.637038] RTW: EEPROM LNAType_2G is 0x0, ExternalLNA_2G = 0 [ 9.637041] RTW: EEPROM LNAType_5G is 0x0, external_lna_5g = 0 [ 9.637043] RTW: EEPROM TypeGPA = 0x0 [ 9.637045] RTW: EEPROM TypeAPA = 0x0 [ 9.637048] RTW: EEPROM TypeGLNA = 0x0 [ 9.637050] RTW: EEPROM TypeALNA = 0x0 [ 9.637053] RTW: EEPROM rfe_type=0x3 [ 9.637129] RTW: is_valid_id_status: HALMAC_FEATURE_DUMP_PHYSICAL_EFUSE [ 9.637137] RTW: EEPROM efuse[0x3D7]=0xf2 [ 9.637140] RTW: EEPROM efuse[0x3D8]=0xf0 [ 9.637667] RTW: rtl8822b_fw_dl fw source from array [ 9.712631] RTW: ERROR [HALMAC][ERR]Polling Bcn_Valid_Fail error!! [ 9.712705] RTW: ERROR [HALMAC][ERR]PLATFORM_SEND_RSVD_PAGE 0 error!! [ 9.712709] RTW: ERROR [HALMAC][ERR]halmac_send_fwpkt_88xx fail!! [ 9.713077] RTW: ERROR download_fw: download firmware FAIL! status=0x46 [ 9.713139] RTW: _debug_dlfw_fail: 0x80 = 0x0060 [ 9.713204] RTW: _debug_dlfw_fail: 0x10F8 = 0x00000000 [ 9.713272] RTW: _debug_dlfw_fail: 0x10FC = 0xfafafafa (0/5) [ 9.713335] RTW: _debug_dlfw_fail: 0x10FC = 0xfafafafa (1/5) [ 9.713398] RTW: _debug_dlfw_fail: 0x10FC = 0xfafafafa (2/5) [ 9.713462] RTW: _debug_dlfw_fail: 0x10FC = 0xfafafafa (3/5) [ 9.713524] RTW: _debug_dlfw_fail: 0x10FC = 0x80000275 (4/5) [ 9.713603] RTW: _debug_dlfw_fail: 0x3A = 0x28 [ 9.713679] RTW: _debug_dlfw_fail: 0xF6 = 0x01 [ 9.713741] RTW: _debug_dlfw_fail: 0xC0 = 0x800003f2 (0/5) [ 9.713803] RTW: _debug_dlfw_fail: 0xC0 = 0x8000008c (1/5) [ 9.713865] RTW: _debug_dlfw_fail: 0xC0 = 0x800003f2 (2/5) [ 9.713926] RTW: _debug_dlfw_fail: 0xC0 = 0x80000080 (3/5) [ 9.713986] RTW: _debug_dlfw_fail: 0xC0 = 0x80000080 (4/5) [ 9.717535] RTW: 0x0000 0x9e 0x82 0x03 0xdc 0x92 0x00 0x03 0x20 0x23 0x7c 0x20 0x00 0x00 0x00 0x00 0x00 ..... ..... I have firmware blobs extracted from the stock android. I tried to put them to different locations, like /lib/firmware/ , /lib/firmware/rtlwifi/ and so on but that didn't help Does anyone running the chip with success? Any thoughts on what I am missing? Thanks in advance
  4. Guys, how much free RAM your system shows on 4GB devices? thanks in advance for your input
  5. Looks like it's missing root@air:~# uname -a Linux air 5.5.0-rc6-aml-s9xxx #rc1.037 SMP PREEMPT Wed Feb 5 17:28:41 MSK 2020 aarch64 aarch64 aarch64 GNU/Linux root@air:~# grep --color=always -i PAE /proc/cpuinfo root@air:~# cat /proc/cpuinfo processor : 0 model name : ARMv8 Processor rev 0 (v8l) BogoMIPS : 48.00 Features : fp asimd evtstrm aes pmull sha1 sha2 crc32 atomics fphp asimdhp cpuid asimdrdm lrcpc dcpop asimddp CPU implementer : 0x41 CPU architecture: 8 CPU variant : 0x1 CPU part : 0xd05 CPU revision : 0 Updated the kernel to 5.77, the total memory is still the same No changes in cat /proc/cpuinfo
  6. Hi, quick noob question here: why the box with 4gb ram shows only ~3,3gb under Armbian? i have a Tanix tx5max on s905x2 and x96air on s905x3. Both of them are ~3,3gb under Armbian
  7. I have Tanix TX5 Max - it has 4GB RAM, but the system shows only ~3.3 GB . Tried different dtbs. What can be done? Anyone can explain the reason?
  8. @balbes150 thanks for your great work! I have a question: I run Armbian_20.02.0-rc1.037_Aml-s9xxx_bionic_current_5.5.0-rc6_20200205.img.xz on Tanix-tx5-max, using the dtb provided with the image. My device has 4gb RAM, but the system shows only 3367852 Is it a known issue? Any recommendations?
  9. I run several boxes with armbian, most are s905x and one is s912. Mostly running home services like openhab, zm, etc. on s912 I run builds with Java (for my work) and from time to time I get strange segfaults while never had them on s905x. The issue is persistent on different builds for s912. # # A fatal error has been detected by the Java Runtime Environment: # # SIGSEGV (0xb) at pc=0x0000ffff8f7817d0, pid=11561, tid=11590 # # JRE version: OpenJDK Runtime Environment (11.0.4+11) (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3) # Java VM: OpenJDK 64-Bit Server VM (11.0.4+11-post-Ubuntu-1ubuntu218.04.3, mixed mode, tiered, compressed oops, g1 gc, linux-aarch64) # Problematic frame: # V [libjvm.so+0x46e7d0] # # No core dump will be written. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again # # An error report file with more information is saved as: # /home/alex/hs_err_pid11561.log # # If you would like to submit a bug report, please visit: # https://bugs.launchpad.net/ubuntu/+source/openjdk-lts # I was thinking about overheating, but never seen temp above 55 Time big.LITTLE load %cpu %sys %usr %nice %io %irq CPU 15:26:41: 1000/1512MHz 3.12 19% 0% 17% 0% 1% 0% 49.0°C Has anyone faced similar issues?
  10. Hi @balbes150 First of all, thank you for your work! I have a few questions: 1. How to update your armbian builds? is it possible over armbian-config? 2. Can I install latest v 5.77 to eMMC?