Serge

Members
  • Content Count

    16
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Raffles

Applications

Everything posted by Serge

  1. may be will be helpful for anybody: https://github.com/shapotkin/NanoPi_neo_double-spi
  2. where to read about it? in forum information is sketchy
  3. I mean: now in /boot/armbianEnv.txt no "fdtfile" field only "overlay_prefix=sun8i-h3" Original DTB file which loadaed by the system is /boot/dtb/sun8i-h3-nanopi-neo.dtb (board is NanoPI Neo Core) I'd like to keep /boot/dtb/sun8i-h3-nanopi-neo.dtb as is and create /boot/dtb/sun8i-h3-nanopi-neo-core.dtb with all modifications described above. But in this case I have to direct the system to use a new DTB file.
  4. Hello martinayotte done. Double SPI is working 1. decompile /boot/dtb/sun8i-h3-nanopi-neo.dtb by command dtc -b 0 -O dts -I dtb -o sun8i-h3-nanopi-neo.dts sun8i-h3-nanopi-neo.dtb all warnings ignored 2. remove all rows with UART3 because pins conflict (https://docs.armbian.com/User-Guide_Allwinner_overlays/ Overlay pinmux conflicts) 3. backup a old .dtb and compile a new .dtb dtc -b 0 -O dtb -I dts -o sun8i-h3-nanopi-neo.dtb sun8i-h3-nanopi-neo.dts all warnings ignored 4. create a new double-spi.dts as you wrote before (similar to https://github.com/armbian/sunxi-DT-overlays/blob/master/sun8i-h3/sun8i-h3-spi-spidev.dts) 5. compile a double-spi.dts with armbian-add-overlay double-spi.dts (refer to https://docs.armbian.com/User-Guide_Allwinner_overlays/) after that checked /boot/overlay-user for double-spi.dtbo presenting 6. in /boot/armbianEnv.txt remove from "overlay=...." all parameters about spi and all rows with "param_spi_xxx" 7. reboot 8. both spidev0.0 and spidev1.0 in /dev presents 9. in armbian-config load all kermel sources and compile spidev_test in /usr/src/linux-source-xxx/tools/spi 10. MISO_0 and MOSI_0 are connected, MISO_1 and MOSI_1 are connected (refer to https://github.com/rm-hull/spidev-test) spidev_test --device /dev/spidev0.0 -v spidev_test --device /dev/spidev1.0 -v all responds are identical PS. how to use a new sun8i-h3-nanopi-neo-core.dtb with all modufucations which I need instead sun8i-h3-nanopi-neo.dtb?
  5. martinayotte, I've tried to use a SPI1 only. /dev/spidev1.0 presents. tried to use a standard IO C functions (open(), read()....) and with wiringPI lib - no result tried to analyse a phisical levels with PulseView - looks like confusion between pins and signals and wrong timing of signal. checked pins deffinition in .dts file - all according pin names from datasheeet tried to assign pins in .dts according results of signals from PulseView... no result because of urgent I wrote SPI "driver" manually - now all works please advice how to check what's wrong with hardware SPI1?
  6. martinayotte, I've decompile original ...nanopi-neo.dtb file and found there are both spi's are enabled in .dtb file the question is about correct parameter in armbianEnv.txt: param_spidev_spi_bus=0 param_spidev_spi_bus=1 or param_spidev_spi_bus=0 1 or how? I didn't find any examples for using both SPIs. The most examples about SPI0 only. at present project SPI1 will be used as well (it's a hardware connections of the shield) and SPI0 pins wil be used as GPIO pins. later, I'd like to have possibility to use SPI0 also. upd.: param_spidev_spi_bus=1 - doesn't work .....upd2: conflict with serial because pin PA15 already requested by 1c28cc00.serial..... PA15 is used bu uart3_rts_cts also (according original .dts file) but no UART3 interfaces on pinout: http://wiki.friendlyarm.com/wiki/index.php/NanoPi_NEO_Core I'm not going to use uart3 with rts_cts. udp3: I've remove all uart3 sections from decompiled .dts now "param_spidev_spi_bus=1" is working and I can see /dev/spidev1.0 last question: for both SPIs using how I must setup a "param_spidev_bus"?
  7. if you are working with NanoPi Neo Core you have to change sunxi_board_id: 5(0) please refer to boardtype_friendlyelec.c for BoardHardwareInfo gAllBoardHardwareInfo[]
  8. does it mean the way to ./build/patch/kernel/sunxi-dev/my-super-2spi.patch?
  9. board: http://nanopi.io/nanopi-neo-core.html image: Armbian Bionic mainline based kernel 4.19.38 from https://www.armbian.com/nanopi-neo/ There are two SPI separated buses with separated pins on NanoPi Core: SPI0 and SPI1 /boot/armbianEnv.txt: ... overlay-prefix=sun8i-h3 overlays=analog-codec i2c0 spi-spidev uart1 usbhost3 param_spidev_spi_bus=0 ... /dev/spidev0.0 presents How to activate a SPI1?
  10. let me some time for cooling down. there are many steps have been taken for the first time and need to be realized "directly to the build sript" - with "config-default.conf"or ./lib/compilation.sh? ...OFFTOPIC: now brain braking with HW connection between Core and SFP..
  11. martinayotte: now it's clear. thank you. Igor: please check attahed files u-boot-sunxi-with-spl.bin my-neo-emmc.patch
  12. added &mmc2 section into ****nanopi-neo.dts from folder /usr/src/build/cache/sources/u-boot/v2019.04 run "git diff arch/arm/dts/sun8i-h3-nanopi-neo.dts > /usr/src/build/patch/kernel/sunxi-dev/my-neo-emmc.patch" from /usr/src/buid run ./compile.sh ... "dd if=/tmp/u-boot-sunxi-with-spl.bin of=/dev/mmcblk1 bs=1024 seek=8" reboot without SD - fault BTW. ***nanopi-neo.dts hasn't &mmc2 section again. Looks like patch wasn't applied. I've copied .diff file to the same folder as Igor's destination: ./patch/u-boot/u-boot-sunxi from /usr/src/buid run ./compile.sh ... "dd if=/tmp/u-boot-sunxi-with-spl.bin of=/dev/mmcblk1 bs=1024 seek=8" and "dd if=/tmp/u-boot-sunxi-with-spl.bin of=/dev/mmcblk1p1 bs=1024 seek=8" (I'm not sure but I did it) reboot without SD - SUCCESS!!! Thank you martinayotte&Igor for your support P.S. last (I hope) doubt.... "dd if=/tmp/u-boot-sunxi-with-spl.bin of=/dev/mmcblk1 bs=1024 seek=8" this command will copy a .bin file into the root folder on eMMC... how it will be read by system during the load? no .bin files in SD-card's nor "/boot" folder nor "/ "folder current configuration: ls /dev | grep mmcblk mmcblk0 mmcblk0p1 mmcblk1 mmcblk1boot0 mmcblk1boot1 mmcblk1p1
  13. martinayotte, something wrong I'm doing... attached .dts file - I've added a &mmc2 section only attached .dtb file - result after compilation all that files from ./cache/sources/u-boot/v2019.04/arch/arm/dts folder in virtual machine start script ./compile.sh again "U-boot and kernel package" selected "Do not change kernel configuration" selected "nanopineo" selected "next Mainline" seleted .... what is strange the script is cheking the git for orangepi board... anyhow let's wait.... ..continue for a long time.... ... finish .deb files have been prepared in ./output/debs a new "u-boot-sunxi-with-spl.bin" copied from Virtual machine to the /tmp folder of NanoPi in NanoPI shell runs "dd if=/tmp/u-boot-sunxi-with-spl.bin of=/dev/mmcblk1 bs=1024 seek=8" (also I've run "dd if=/tmp/u-boot-sunxi-with-spl.bin of=/dev/mmcblk1p1 bs=1024 seek=8" because system copied to /dev/mmcblk1p1) SD-card removed result?.... - no result. still u-boot shell available.... ((( Questions: may be some files must be renamed? may be .deb files must be copied also? what else could be wrong? Thank you in advance sun8i-h3-nanopi-neo.dtb sun8i-h3-nanopi-neo.dts
  14. martinayottte, I've install a virtual ubuntu machine acoding https://github.com/armbian/build on my PC run ./compile.sh script has loaded a sources for kernel and u-boot. After revision results I found that patch applied for sun8i-h3-nanopi-r1.dts and ..du2.dts only sun8i-h3-nanopi-neo.dts (I'm using nanopi neo core so I suppose that file will be used for u-boot/kernel compilation) wasn't changed for mmc. So I suppose I have to add similar rows about &emac and &mmc2 into sun8i-h3-nanopi-neo.dts Then compile.sh again and what then? copy a binary u-boot to to the SD-card of NanoPi Neo Core board, "nand-sata-install". Right? Please confirm.
  15. thank you for quick respond, Igor as I understod that patch must be applied to the some src of u-boot program and then image must be rebuilt, isn't it? Actually I didn't try it before. or can I decompie a current .dtb file for nanopi-neo from /boot/dtb/ folder to the *.dts file, then some modifiations similar to your patch and then comile a .dts file to the new .dtb file. Possible?
  16. board: http://nanopi.io/nanopi-neo-core.html image: Armbian Bionic mainline based kernel 4.19.38 from https://www.armbian.com/nanopi-neo/ after "nand-sata-install" I can see system copy on emmc (by mount /dev/mmcblk1p1 /mnt) UUID in eMMC copy of armbianEnv.txt is correct for eMMC "poweroff" remove SD-card power on no system start. U-boot shell only with "no MMC card" messages please advice what to check/fix more?