jevgienij

Members
  • Content Count

    6
  • Joined

  • Last visited

  1. It's just like you said. The first press is lost and reconnection takes more than one second. But that I can live with.
  2. https://aliexpress.com/item/32891411315.html I'll take a look at triggerhappy. Thanks!
  3. I have this cheap bluetooth multimedia controller with 5 keys (play, prev, next, vol up, vol down). It's all connected and key presses are recognised: [root] [~] # showkey kb mode was UNICODE [ if you are trying this under X, it might not work since the X server is also reading /dev/console ] press any key (program terminates 10s after last keypress)... keycode 164 press keycode 164 release How do I go from here? How do I make this 164 key press to run "mpc toggle" command? It's an Orange Pi PC+ and Armbian 5.90. This is a console-only machine. No any X window system (most of the keybind solutions I've found were X related).
  4. Thanks. I managed it with a chattr +i .config workaround but I still wonder what is the proper way of opening u-boot menu config...
  5. How do I make compile.sh open u-boot menu config? It only asks if I want to open kernel menu config. If I manually go to cache/sources/u-boot/v2019.04 and exec make menuconfig there, then set what I need to set and save the settings, they are being overridden anyway.
  6. I'm building a device where fast boot time is essential. I've found that this: starting USB... USB0: USB EHCI 1.00 USB1: USB OHCI 1.0 USB2: USB EHCI 1.00 USB3: USB OHCI 1.0 USB4: USB EHCI 1.00 USB5: USB OHCI 1.0 USB6: USB EHCI 1.00 USB7: USB OHCI 1.0 scanning bus 0 for devices... 1 USB Device(s) found scanning bus 1 for devices... 1 USB Device(s) found scanning bus 2 for devices... 1 USB Device(s) found scanning bus 3 for devices... 1 USB Device(s) found scanning bus 4 for devices... 1 USB Device(s) found scanning bus 5 for devices... 1 USB Device(s) found scanning bus 6 for devices... 1 USB Device(s) found scanning bus 7 for devices... 1 USB Device(s) found scanning usb for storage devices... 0 Storage Device(s) found Is taking whole 7 seconds - one for each device scan. If I have my OS installed on eMMC and I don't even need the possibility of booting the OS from any flash drives I don't need this functionality, right? If so, how could I remove/disable it so my board starts faster? It's Orange Pi PC Plus v1.1