larrylart

Validating
  • Content Count

    0
  • Joined

  • Last visited

About larrylart

  • Rank
    Validating

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I trying to get the USB3 working with orange pi lite 2 and the latest nigtly snapshot 5.1.3-sunxi64 #5.87.190522. I notice that the usb3 is disabled in the the dtb file: dwc3@5200000 { compatible = "snps,dwc3"; reg = <0x5200000 0x10000>; interrupts = <0x0 0x1a 0x4>; clocks = <0x2 0x72 0x2 0x72 0xa 0x0>; clock-names = "ref", "bus_early", "suspend"; resets = <0x2 0x33>; dr_mode = "host"; phys = <0x1f>; phy-names = "usb3-phy"; status = " disabled "; phandle = <0x52>; }; phy@5210000 { compatible = "allwinner,sun50i-h6-usb3-phy"; reg = <0x5210000 0x10000>; clocks = <0x2 0x6a>; resets = <0x2 0x2d>; #phy-cells = <0x0>; status = "disabled"; phandle = <0x1f>; }; I changed the status (from disable to okay) on both and recompile the dts file, and now I can see the usb3 HUB: lsusb -t /: Bus 07.Port 1: Dev 1, Class=root_hub, Driver=musb-hdrc/1p, 480M /: Bus 06.Port 1: Dev 1, Class=root_hub, Driver=ohci-platform/1p, 12M /: Bus 05.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M /: Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M /: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ohci-platform/1p, 12M /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M However no devices are detected, no even powering when plugged into the USB port. I contacted Icenowy, who currently maintains the usb3 driver, and have been advised that current driver should be working. I wonder if the issue rests in the dts file setup, current parameter setup, given the fact it was marked as disabled? I noticed someone in the H6 dev forum mentioned that this was working back a month or so ago, however it does not seem to be working in the latest sanpshot.