Sico

  • Content Count

    15
  • Joined

  • Last visited

About Sico

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thank you @balbes150. Almost all DTBs works without eMMC, ethernet and Wifi except for the rk3328-box-h96mp.dtb from @easyb that has working both ethernet and eMMC. Thanks @easyb for sharing. I've still problems to install Armbian to the eMMC because the boot is from Libreelec SD and the system is from Armbian USB. But I think I will edit the install script to fix the issues. Now I'm wondering if I can edit the rk3328-box-h96mp.dtb and get Wifi working which is far faster than the 100Mb ethernet. I've extracted the dts and when I recompile it, it still works. But when
  2. Hello again, I tried many ways to copy the u-boot from Libreelec using dd with different values but with no success. Finally I managed to boot Armbian by burning the image Armbian_20.02.0-rc1.038_Rk3328-tv_buster_current_5.5.0-rc6_20200205.img into an usb and a Libreelec into the SD Card. In the SDCard I've removed the Libreelec boot files and I've copied inside everything from the boot partition of the Armbian USB. The dtb used is the default rk3328-box.dtb. T9 from hexdump, others, and mine (extracted from Android) are not working. Now Armbian seems to be working very we
  3. Thank you Balbes. I didn't mean to bother you. I looked for this procedure but I can't find it. That's why I tried this wrong method before asking.
  4. Thank you so much Balbes, I really don't know how to do it but I tried this way: - Copied all the files from the Armbian boot partition to Libreelec boot partition. - Edited the config file to use the Armbian images: (tried with my own dtb extracted from Android and also with the one provided with libreelec and some of yours) LINUX /zImage INITRD /uInitrd FDT /rk3328-box.dtb APPEND root=LABEL=ROOTFS rootflags=data=writeback rw console=uart8250,mmio32,0xff130000 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 - Boot w
  5. Hello everyone, I made some efforts in the past to install Armbian into my H96 max+ (2GB RAM / 16GB ROM) but I abandoned it for a while. Now some months after I'm trying again to get it working. Libreelec works but Armbian doesn't. My problem is always the same, boot is stuck at this point (may be a RAM issue). I tried many .dtb including one generated by my from Android, the result is always the same. DDR version 1.13 20180428 ID:0xFFF In DDR3 333MHz Bus Width=32 Col=11 Bank=8 Row=15 CS=1 Die Bus-Width=16 Size=2048MB ddrconfig:2 OUT Boot1 Release Time: Feb 2 2018
  6. There is something I can do? Thank you.
  7. Hi @hexdump , @balbes150, I finally got some serial output but I don't understand what is wrong. Here is the output: DDR version 1.13 20180428 ID:0xFFF In DDR3 333MHz Bus Width=32 Col=11 Bank=8 Row=15 CS=1 Die Bus-Width=16 Size=2048MB ddrconfig:2 OUT Boot1 Release Time: Feb 2 2018 15:41:39, version: 2.46 ChipType = 0x11, 194 SdmmcInit=2 0 BootCapSize=2000 UserCapSize=15028MB FwPartOffset=2000 , 2000 SdmmcInit=0 0 BootCapSize=0 UserCapSize=15193MB FwPartOffset=2000 , 0 StorageInit ok = 171624 Raw SecureMode = 0 SecureInit read PBA: 0x4 SecureInit read PBA: 0x404 SecureInit read PBAt read P
  8. Hey @hexdump I got the UART cable, and I tried to connect in many ways, using the console in Mac and using Putty in Windows as described here: https://learn.adafruit.com/welcome-to-circuitpython/advanced-serial-console-on-mac-and-linux (in the previous case not listed in the device list) and here: https://forum.armbian.com/topic/8237-serial-console-access-via-usb-uartgadget-mode-on-linuxwindowsosx/ Can you tell my please how you got it working? Maybe my system is no booting at all? Thanks.
  9. Thank you again @hexdump . I'll go with the serial console. I've just purchased a USB to Serial adapter, I will post my progress as soon as I receive it and can work on this.
  10. @armar Yes, I tried with and without USB but it doesn't work either @hexdump I tried to change these entries and many more but with no success. Maybe a silly question, can we just take and build the dtb from the android dts changing the boot references? There are other important parameters? Thank you again.
  11. Thank you very much @hexdump, I really appreciate your help. I tried what you said with no success. You can find attached the non-working .dts & .dtb. Maybe there are other parameters to change? I tried another dtb replacing also opp-hz and rockchip,leakage-voltage-sel but it doesn't works neither. When booting with tAndroid the front light changes from red to blue, and when I try to boot from the SD the light keep red. @armar Thank you too for your advice. I not an expert but the memory parameters seems to be the same. rk3328-t9-2g.dtb rk3328-t9-2g.dts
  12. Hey @hexdump, no luck with the new SD card. Nevertheless I followed your steps and here you can find attached the result of the script. Thank you again. device-tree-copy.tar.gz
  13. Thank you @balbes150 for your advice. I successfully flashed the SD with Etcher and when I try to boot from it I've the same result: blackscreen, no boot. Maybe there is something wrong with my SD card (Transcend 16GB class 10, HC I). I just ordered a new one (Sandisk Ultra 16GB class 10, A1, HC I) that I expect to receive on Monday. I'll post the progress about this.
  14. Thank you very much @hexdump for your quick response. The file exists at /dtb/rockchip/ and my /extlinux/extlinux.conf looks like that: LABEL Armbian LINUX /Image INITRD /uInitrd FDT /dtb/rockchip/rk3328-t9.dtb # FDT /dtb/rockchip/rk3328-mx10-fast.dtb # FDT /dtb/rockchip/rk3328-a5x.dtb # FDT /dtb/rockchip/rk3328-box-trn9.dtb APPEND root=LABEL=ROOTFS rootflags=data=writeback rw console=uart8250,mmio32,0xff130000 console=tty0 no_console_suspe$ I've opened the box, it quite easy, no glue, only two screws. In the board I can see that the chip is a RK3328_8D4_V1.1. The m
  15. Hello everybody, I'm new in this forum and after I saw your posts and see that @amirul got it working, I decided to buy a H96max+ (cheap but yet powerful) and tried to make it run with linux (believing that it could be possible for me). I tried to follow these steps: - write the image provided by @balbes150 (5.82) with dd command, in both sd card and usb stick (Armbian_5.82_Rk3328-tv_Ubuntu_bionic_default_4.4.154_desktop_20190427.img) - mounted the first partition and copied the dtb files provided by @hexdump into /dtb/rockchip and use them from the extlinux/extlinux.conf. (tri