t-bob

Members
  • Content Count

    36
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Raffles

Applications

Everything posted by t-bob

  1. t-bob

    Allwinner H5 SID

    here's the patched devmem2 if anyone needs it devmem2-64.c
  2. t-bob

    Allwinner H5 SID

    excellent. many thanks for that. now i get this which seems like an impressive SID 6400462092C000BA:541500CE50368518
  3. t-bob

    Allwinner H5 SID

    i get bus errors on memory access for 0x01c14204 & 0x01c1420c. is this expected ? 92C000BA 50368518
  4. t-bob

    Allwinner A64 kernel 3.10

    easy ... just use the armbian build process to generate a new image and select "stable" but i did find that in 5.5x that the wifi wouldn't automatically connect and doing an ifdown/ifup would work 50% of the time.
  5. I've built the latest armbian (5.48 & 5.46) for all the different versions (default, next & dev) and they all have issues starting the wifi ! If i manually do an ifdown/ifup it usually comes up (say 80% of the time) I was just wondering if anyone else had seen this issue or is it just me ..... Thanks, TB
  6. t-bob

    There any jessie Suport for Pine64so??

    I built a 18.04 for opiwin+ ... mostly works but for some reason wifi needs to be manually started
  7. t-bob

    A64 and the 3.10 kernel

    you'll need to stick with 3.10 for the moment. 4.xx has several issues which will be fixed but not yet. not much you can do
  8. Hi, I was wondering if anyone was having issues with the ethernet port using the legacy kernel ? It does seem to kind of work ... it will get DHCP from the router and configure the routing tables etc but after that it goes wonky. When I do a ping test from the router I get "50/50 transmitted, 15/50 received, 70% loss". A ping test from the opi-win to the router gets a similar result. If I try a ping/ssh from a PC connected to the router I get a 95% packet loss Everything else seems to work fine ... HDMI, USB, WiFi (AP/STA modes) which is really, really nice. Thanks TB
  9. Can you tell me how you go with network speeds. I tried it yesterday and ethernet/wifi worked but was really, really slow. Just not sure if it was me or the O/S ....
  10. t-bob

    OPi Win - Status update

    The only odd thing so far is the that USB ports dont seem to work The hubs appear but when you insert a usb key nothing appears in /dev or the syslog/kernel log etc etc. Will keep looking. Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  11. I just built the latest OPi Win image and WOW ... just about everything seems to be working. I'll test it over the coming days but AWESOME work guys. Wifi is back, eth0 is back and HDMI works !!!!! I've not tried any kind of GUI yet but I can get a console prompt on the TV & see the kernel boot messages Now for more testing, testing & testing .... TB
  12. Hi, I've been playing around with the latest build (Armbian_5.37_Orangepiwin_Debian_stretch_next_4.14.5.img.gz) just to see how things are going and I've noticed that the wifi has gone ? I saw that it doesnt talk about patching the ap6212 firmware anymore. Had a look around but couldnt see anything. I know it's a dev build but I hope that it's just a missing config file from that build branch or something. Thanks TB
  13. You have to build it using the various toolsets to do that. Quite easy. Their system is well put together https://github.com/armbian/build
  14. And I also found that it was missing from /boot/armbianEnv.txt as it wasnt loading the fixup scripts overlay_prefix=sun50i-a64
  15. Hi, I've been playing around with a OPi Win+ which is aint bad but full support seems a while off ... I'm looking for a quad core, 2G, good wifi with external antenna and this seems to fit the requirements. I dont care too much about hdmi but if it works all the better. I was just wondering what current owners thought of it. Can the internal wifi do AP mode and will it do dual modes ... hostapd-8188 will create wlan0 & wlan1 so that you both connect to an AP and be an AP. Google doesnt show much about 8189ETV Given that the armbian download shows it with a legacy kernel but stable I expect that everything 'works' ... Thanks TB
  16. t-bob

    Orange Pi Plus 2E - is it any good ?

    Yes, we'd never get complete agreement on a config ... but even if we could get an agreement on say the wifi chipset(s) and always include usb3 on anything that's not a 'zero' clone. Stuff like that would be good. The Wemos stuff looks interesting and not too pricey like some other ones. Well, the whole trickle down economy thing worked so well for everyone didnt it The master mode would only need OK performance and not excellent ... just web traffic (5+ users)
  17. t-bob

    Orange Pi Plus 2E - is it any good ?

    Many thanks for the comments & info. Yes, the only guarantee in life is death & taxes All these SBC's have compromises that have to be made. Even the RPi which has awesome s/w support but no external wifi antenna, bad microSD slot (why didnt they pay an extra 5 cents and get the one that clicks in) & only 1G of ram. It's a pity we couldnt get someone to make a SBC with all the stuff that we want but I doubt that would ever happen
  18. t-bob

    OPiWin - stretch testing

    I had a play with reverting the DTS files but with no luck. I expect there may be some u-boot changes that need to be added given that it doesnt find it on boot either. It complained about pinctrl I think. cp /boot/dtb/allwinner/sun50i-a64-orangepi-win.dtb /boot/dtb/allwinner/sun50i-a64-orangepi-win.dtb.orig dtc -I dtb -O dts -o /boot/dtb/allwinner/sun50i-a64-orangepi-win.dts /boot/dtb/allwinner/sun50i-a64-orangepi-win.dtb vi +/ethernet /boot/dtb/allwinner/sun50i-a64-orangepi-win.dts dtc -I dts -O dtb -o /boot/dtb/allwinner/sun50i-a64-orangepi-win.dtb /boot/dtb/allwinner/sun50i-a64-orangepi-win.dts
  19. i've built and started testing stretch ... it mostly looks pretty good with these issues found so far lircd - goes wild. systemd goes to 100% cpu it need to be blacklisted or the like. stopping/disabling it didnt work. i need to remove it to stop the cpu usage problem https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=860551 install python-wheel as default package as pip breaks without it eth0 has gone but seems to be a known issue https://irclog.whitequark.org/linux-sunxi/2017-09-19 and I see that hdmi has made progress (by smaeul) https://irclog.whitequark.org/linux-sunxi/2017-09-26
  20. t-bob

    OPiWin - stretch testing

    the hdmi part of linux doesnt work yet so you'll see the part of the booting up process and then nothing. we dont have an eta on hdmi working yet buy a usb-ttl device and hook that to the serial connection the ethernet port may not work either as they have pulled support for that for the moment. wifi only
  21. Igor, I truly sympathize with you about stuff. I think we're up to 5 with OPiWin and hdmi not working IMHO, to limit most of these questions with the WIP boards you need to some kind of pop-up window when they go to download it to display a basic status page (just what works at this point, no need to update it until stable), a big warning message and what not to do (like apt-get upgrade) People dont read or really understand what WIP/experimental means .... TB
  22. I like many others would like to help. We seem to have many general unix coders and not enough driver people Where do we go to find problems to correct ? From that I can see/read it's the Issues section on github which has 3 in config and 27 in build.
  23. Hi, I was wondering if anyone had been able to get this working ? And, yes i know that OPI-Win is WIP/testing. I read some stuff here & on the linux-sunxi irc log that seemed to say that it should work & I've tried the following without luck. I was wondering if someone with alittle more knowledge about this may be able to help or point me in the right direction. I also tried to compile u-boot v2017-09 but it fails with a sdram too big error I tried to backport some of the config to 2017-07 but that'll take time i expect ... /boot/armbianEnv.txt (many combinations of this) disp_mode=720p60 disp_dvi_compat=1 verbosity=7 /boot/boot.cmd (many combinations of this) setenv stdout=serial,vga setenv stderr=serial,vga setenv console=tty1 (i've also tried tty0, tty2 etc) setenv bootargs console=tty0 hdmi.audio=EDID:0 disp.screen0_output_mode=720p60 root=/dev/mmcblk0p1 rootwait panic=10 setenv video-mode sunxi:1024x768-24@60,monitor=dvi,hpd=0,edid=0 Many thanks in advance TB
  24. If you want HDMI then you'll need to try the images on the orangepi website. The do kind of mostly/sometimes work. The kernel is old but if you want HDMI then they are your only real option at this stage. Armbian etc will get there and will be a much better option IMHO. If you need non wifi access the grab a USB-TTL converter (ebay/amazon) and do a serial connection to the debug port.
  25. t-bob

    Orange PI Win+ - apt upgrade issue

    The gpio/i2c were just there as examples not as the truth OK, let me think further on this and i'll see if i can come up with something that may be usable .. then put it up for comment. I would like to help but I'm not really a kernel coder ... sysadmin/dba/integrator yes .... I know that one of the 'problems' is that users keep asking the same question over & over ... in general terms is it more about the status of X or 'this doesnt work' ? Again, not trying to be annoying but trying to find out where I can help. Do you have any suggestions as to where I could help to make your lives easier ? Yes, I have several users here I'd pay to be sent to a CIA re-education camp Perhaps we can get a bulk booking discount With users downloading WIP images, if when they click on the link to get the image could you put a dialog window that says something like "This is an unstable image and should not be used for anything other than testing. Somethings may work or not blah blah blah. Press 'I understand the risks' " ? I've found you really have to get in their faces with stuff as they dont read the page, they just want the image to run on their board.