Diamond

  • Posts

    20
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Diamond's Achievements

  1. Hello, Is there anyone that has problem with USB keyboard on armbian 20.11.9 buster. I have tried both 20.11.6 and 20.11.9 buster nut the keyboard can't be recognized in armbian. (caplock, numlock LED don't work as well) I tried 4 USB ports on the port but doesn't work. The keyboard is working fine with my Windows PC. Thanks
  2. Hello Armin, I'm using armbian 20.07 buster Armbian 20.07 Buster uname -a Linux x96-air 5.7.16-arm-64 #20.08 SMP PREEMPT Fri Aug 28 09:43:05 MSK 2020 aarch64 GNU/Linux # This to workaround the issue couldn't find aarch64 cp -r /usr/src/linux-headers-5.7.16-arm-64/arch/arm64 /usr/src/linux-headers-5.7.16-arm-64/arch/aarch64 git clone https://github.com/RinCat/RTL88x2BU-Linux-Driver.git cd RTL88x2BU-Linux-Driver make ... ... CC [M] /root/RTL88x2BU-Linux-Driver/hal/btc/halbtc8822b1ant.o CC [M] /root/RTL88x2BU-Linux-Driver/hal/btc/halbtc8822b2ant.o CC [M] /root/RTL88x2BU-Linux-Driver/platform/platform_ops.o CC [M] /root/RTL88x2BU-Linux-Driver/core/rtw_mp.o LD [M] /root/RTL88x2BU-Linux-Driver/88x2bu.o MODPOST 1 modules ERROR: modpost: "__stack_chk_guard" [/root/RTL88x2BU-Linux-Driver/88x2bu.ko] undefined! make[2]: *** [scripts/Makefile.modpost:99: __modpost] Error 1 make[1]: *** [Makefile:1645: modules] Error 2 make[1]: Leaving directory '/usr/src/linux-headers-5.7.16-arm-64' make: *** [Makefile:2373: modules] Error 2 There is error when I tried to install...
  3. I am able to install rtl88x2bu by installing linux-header package first. Unfortunately, it seems kernel 5.7.7-arm-64 already included the driver with newer version. In the end, I am unable to have the interface. I guess there is something to do on dtb to activate it?
  4. Hello, What does that mean? Is it related to ethernet of x96-air? I couldn't find fec.c in /lib/modules/5.7.7-arm-64/kernel/drivers/net
  5. Restart loop could be incorrect dtb file. I'm not sure the correct one for your box. For X96 Air: Is there way to have LED clock works? After installing ARMBIAN, the clock on box is off.
  6. OK. I get it works by using USB flash drive/USB card reader. I guess there is bug with Box's mircoSD card reader driver.
  7. Hello, Have you manged to get Micro SD card work? I am having same problem with repeated error mmc1 error -84 whilst initialising sd card My box is X96 Air P3 - 4G RAM, 32G ROM My MicroSD card is SamsungEVO plus U1 32G. Detail:
  8. Hello, I'm using X96 Air P3 4G 32G I'm using "toothpick method" to boot the SD card. Images are used on https://yadi.sk/d/_rQgn_FosYuW0g/20.05.3/20200502 Armbian_20.05.0_Arm-64_bionic_current_5.6.0-rc6_desktop_20200326.img Armbian_20.05.3_Arm-64_buster_current_5.7.0-rc3_desktop_20200502.img Armbian_20.05.3_Arm-64_bionic_current_5.7.0-rc3_desktop_20200502.img I tested by burning those images with balena Etcher. (Enabled Validate write on success) I tried to use ethfix from FDT=/dtb/amlogic/meson-sm1-sei610-ethfix.dtb APPEND=root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 or FDT=/dtb/amlogic/meson-sm1-sei610.dtb APPEND=root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 Same result that I can't boot with error message: mmc error -84 whilst initialising sd card Console is being spammed by tons of those messages. It failed to initramfs 1 more thing is I can't boot from original android by using "Update" - >aml_autoscript.zip with the error in attachment. E: Block map file is too short: 3 E: Map of '@/cache/recovery/block.map': failed E: failed to map file Installation aborted. From the forum search, poster said that we need to have correct dtb file. I guess I provided correct file for x96 Air already. Any advice for me? Thanks
  9. Check this https://yadi.sk/d/_rQgn_FosYuW0g/20.05/20200326
  10. Same issue on S805 Armbian_20.05.3_Aml-s812_buster_current_5.7.0-rc3_desktop_20200503.img uname -a Linux aml-s805 5.7.0-rc3-aml-s812 #20.05.3 SMP Sun May 3 12:19:42 MSK 2020 armv7l GNU/Linux
  11. I am using S805 box. I am testing Armbian_20.05.3_Aml-s812_buster_legacy_5.6.0_desktop_20200501.img with meson8b-ec100.dtb. The box can boot and start GUI - It can recognize USB devices However, there is error: Message from syslogd@localhost at May 3 06:40:02 ... kernel:[ 284.025994] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [kworker/0:1:12] [ 284.029429] CPU: 0 PID: 12 Comm: kworker/0:1 Not tainted 5.6.0-aml-s812 #20.05.3 [ 284.029556] Hardware name: Amlogic Meson platform [ 284.030073] Workqueue: events dbs_work_handler [ 284.030453] PC is at skb_put+0x0/0x50 [ 284.030880] LR is at stmmac_napi_poll_rx+0x8dc/0xca8 [ 284.031070] pc : [<c0ebcb7c>] lr : [<c0d00b04>] psr: 400f0113 [ 284.031242] sp : c02b3a60 ip : 00000000 fp : ed95c580 [ 284.031413] r10: ed95d580 r9 : 000005e2 r8 : ec5029c0 [ 284.031609] r7 : 00001fe0 r6 : ed95c580 r5 : 00000000 r4 : 000005e2 [ 284.031802] r3 : 5ed5f3a9 r2 : 00000000 r1 : 000005e2 r0 : ec5029c0 [ 284.032031] Flags: nZcv IRQs on FIQs on Mode SVC_32 ISA ARM Segment none [ 284.032236] Control: 10c5387d Table: 2b42c04a DAC: 00000051 [ 284.032513] CPU: 0 PID: 12 Comm: kworker/0:1 Not tainted 5.6.0-aml-s812 #20.05.3 [ 284.032630] Hardware name: Amlogic Meson platform [ 284.032938] Workqueue: events dbs_work_handler [ 284.033685] [<c030f744>] (unwind_backtrace) from [<c030ab3c>] (show_stack+0x10/0x14) [ 284.034116] [<c030ab3c>] (show_stack) from [<c0a67020>] (dump_stack+0xc0/0xd4) [ 284.034559] [<c0a67020>] (dump_stack) from [<c03f0e64>] (watchdog_timer_fn+0x20c/0x280) [ 284.035014] [<c03f0e64>] (watchdog_timer_fn) from [<c03ad114>] (__hrtimer_run_queues+0x154/0x200) [ 284.035453] [<c03ad114>] (__hrtimer_run_queues) from [<c03ad950>] (hrtimer_interrupt+0x11c/0x2ac) [ 284.035896] [<c03ad950>] (hrtimer_interrupt) from [<c030e3a8>] (twd_handler+0x30/0x38) [ 284.036372] [<c030e3a8>] (twd_handler) from [<c0397d44>] (handle_percpu_devid_irq+0x78/0x138) [ 284.036885] [<c0397d44>] (handle_percpu_devid_irq) from [<c0391c50>] (generic_handle_irq+0x34/0x44) [ 284.037377] [<c0391c50>] (generic_handle_irq) from [<c039224c>] (__handle_domain_irq+0x5c/0xb4) [ 284.037928] [<c039224c>] (__handle_domain_irq) from [<c0a7ed20>] (gic_handle_irq+0x3c/0x78) [ 284.038397] [<c0a7ed20>] (gic_handle_irq) from [<c0300b0c>] (__irq_svc+0x6c/0x90) [ 284.038583] Exception stack(0xc02b3a10 to 0xc02b3a58) [ 284.038901] 3a00: ec5029c0 000005e2 00000000 5ed5f3a9 [ 284.039320] 3a20: 000005e2 00000000 ed95c580 00001fe0 ec5029c0 000005e2 ed95d580 ed95c580 [ 284.039660] 3a40: 00000000 c02b3a60 c0d00b04 c0ebcb7c 400f0113 ffffffff [ 284.040147] [<c0300b0c>] (__irq_svc) from [<c0ebcb7c>] (skb_put+0x0/0x50) [ 284.040559] [<c0ebcb7c>] (skb_put) from [<00000000>] (0x0)
  12. Is there way to load cp210x? root@aml-s805:~# uname -a Linux aml-s805 5.6.0-aml-s812 #20.05.0 SMP Tue Mar 31 12:44:09 MSK 2020 armv7l GNU/Linux root@aml-s805:~# modprobe cp210x modprobe: FATAL: Module cp210x not found in directory /lib/modules/5.6.0-aml-s812
  13. Armbian_5.65_Orangepiplus_Debian_stretch_next_4.14.78 - not work root@orangepiplus:~# uname -a Linux orangepiplus 4.14.78-sunxi #412 SMP Fri Oct 26 11:37:04 CEST 2018 armv7l GNU/Linux root@orangepiplus:~# lsusb lBus 002 Device 002: ID 05e3:0718 Genesys Logic, Inc. IDE/SATA Adapter Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub root@orangepiplus:~# lsusb -t /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 480M /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M [ 3.178172] reg-fixed-voltage usb3-vbus: could not find pctldev for node /soc/pinctrl@01c20800/usb3_vbus_pin@0, deferring probe root@orangepiplus:~# ls -la /lib/modules/4.14.78-sunxi/kernel/drivers/phy/ ls: cannot access '/lib/modules/4.14.78-sunxi/kernel/drivers/phy/': No such file or directory
  14. Armbian_5.90_Orangepiplus_Debian_buster_next_4.19.57 - not work root@orangepiplus:~# uname -a Linux orangepiplus 4.19.57-sunxi #5.90 SMP Fri Jul 5 17:58:43 CEST 2019 armv7l GNU/Linux root@orangepiplus:~# lsusb Bus 002 Device 002: ID 05e3:0718 Genesys Logic, Inc. IDE/SATA Adapter Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub root@orangepiplus:~# lsusb -t /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 480M /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M root@orangepiplus:~# ls /lib/modules/4.19.57-sunxi/kernel/drivers/phy/allwinner/ phy-sun50i-usb3.ko
  15. Flash with old image: Armbian_5.59_Orangepiplus_Debian_stretch_next_4.14.65. USB can be detected. root@orangepiplus:~# uname -a Linux orangepiplus 4.14.65-sunxi #68 SMP Tue Aug 21 19:57:06 CEST 2018 armv7l GNU/Linux root@orangepiplus:~# lsusb Bus 002 Device 002: ID 05e3:0718 Genesys Logic, Inc. IDE/SATA Adapter Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode) Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub So problem above is from new image. I will try to test to see latest one that works...