jbolanosg

Members
  • Posts

    13
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

jbolanosg's Achievements

  1. please in this forum have to take part a user that he is using armbian with mecool km3 or mecool km9 pro tv box. could he share his dtb file? Thanks.
  2. Hi, Does Someone have a dtb file that enabled the ethernet network for mecool the km3 tv box? The meson-g12a-sei510.dtb file does not enable the ethernet network card in my mecool km3 tv box. The speed of the ethernet network card of my mecool km3 is 100 MB. The motherboard is km9 X2 LP4 v 2.2 Two year ago i installed armbian in this tv box with network ethernet card running without problem, now i need to install armbian again but i do not remember that dbt file i used...It only i remeber is that i download from this forum and it was shared per someone but now i hasn't found the dbt file. The error that is showed in Dmesg files is: 20.765724] systemd-journald[941]: Received client request to flush runtime journal. [ 26.508116] meson8b-dwmac ff3f0000.ethernet eth0: validation of rmii with support 0000000,00000000,00006280 and advertisement 0000000,00000000,00006280 failed: -22 [ 26.528442] meson8b-dwmac ff3f0000.ethernet eth0: no phy at addr -1 [ 26.540074] meson8b-dwmac ff3f0000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 26.871298] meson8b-dwmac ff3f0000.ethernet eth0: validation of rmii with support 0000000,00000000,00006280 and advertisement 0000000,00000000,00006280 failed: -22 [ 26.884537] meson8b-dwmac ff3f0000.ethernet eth0: no phy at addr -1 [ 26.890484] meson8b-dwmac ff3f0000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 26.971249] meson8b-dwmac ff3f0000.ethernet eth0: validation of rmii with support 0000000,00000000,00006280 and advertisement 0000000,00000000,00006280 failed: -22 [ 26.984577] meson8b-dwmac ff3f0000.ethernet eth0: no phy at addr -1 [ 26.990555] meson8b-dwmac ff3f0000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 27.067959] meson8b-dwmac ff3f0000.ethernet eth0: validation of rmii with support 0000000,00000000,00006280 and advertisement 0000000,00000000,00006280 failed: -22 [ 27.081513] meson8b-dwmac ff3f0000.ethernet eth0: no phy at addr -1 [ 27.087453] meson8b-dwmac ff3f0000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 27.194560] meson8b-dwmac ff3f0000.ethernet eth0: validation of rmii with support 0000000,00000000,00006280 and advertisement 0000000,00000000,00006280 failed: -22 [ 27.208229] meson8b-dwmac ff3f0000.ethernet eth0: no phy at addr -1 [ 27.214218] meson8b-dwmac ff3f0000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) Thanks.
  3. Hi @SteeMan, Please inform me what is the step by step you used to boot the 5.10 kernel using @hexdump boot. I have a s905x3 (Tanix TX3) and another s905x2 (Mecool KM3) tv box where I could try the step to step that you indicate. Does that work only with Sdcard or can it also be tested with emmc?
  4. Hello, could you please detail step by step how to do this and finally have armbian with linux kernel 5.10 on my Tanix TX3 tv box. Another thing that I wonder is if I achieve this by running armbian only on the Sdcard or I also install it on the emmc, which is my goal. I am very aware of your guidance ... thank you for what you can help me.
  5. Hi @golfsmith, according your log you have a problem with dtb file...You are using "meson-gxl-s905x-khadas-vim.dtb...This, you must modify in uEnv.ini and extlinux.conf (Required for booting Armbian).
  6. Hi, @skyfly555, Thanks for your answer...I saw that your tv box also it has installed android 8.1 while my tv box Mecool km3 has installed Android TV 9.0!!! Then, it seems that the problem is to install armbian from android tv 9. Someone knows why this?
  7. That model has an Ethernet interface of 100MB according a this page :https://www.gearbest.com/tv-box/pp_009497151557.html?wid=1433363&lkid=16601880...Does the ethernet interface work for you in Armbian using dbt file "meson-g12a-x96-max.dtb" ?
  8. Hi, Someone knows If Android TV 9 has locked the boot process that to prevents the already documented process to start Armbian by doing the update process from android? @balbes150...What is your opinion of my question? I very much appreciate what you can tell us about this topic.
  9. Peyton, I appreciate your quick response very much. Other question: Where can i find an image with android 8.1 for my Mecool km3? I would like to try putting this operating system in km3 before to try again to make armbian boot.
  10. Hi i have the following question: 1. My km3 has operating system "Android TV 9"...What does operating system has your km9?? 2. what difference will have between to do the processs with usb stick that i use and sdcard how you do it?? 3. the file aml.zip that you say is the file "aml_autoscript.zip" that is in the image?? Basicly i do the same process but in my case when km3 boot up it shows an error in screen!! I believe that the trouble with eth interface is because the X96 max has a eth interface to Gigaethernet while km9 and km3 have a eth interface to 100 MB. We must find a dtb file for km9 and km3. Tonight i am going to test with the same image that you used.
  11. My firts step was from android TV to execute the process of updating with USB stick in Mecool km3..i choose local update and also choose aml_autoscript.zip from USB Stick. After the tv box to do automatic reboot and when it up to generate an error in screen and after again to boot in Android TV. It is very important for me that you try it your mecool km9 as km3 and km9 are very similar models. I remain pending for your test in km9 I'm glad you share what you find with me.
  12. Hi i am traying to install armbian in my new tv box (Mecool km3). i have used the image: "Armbian_5.89_Aml-s905_Ubuntu_bionic_default_5.1.0_desktop_20190617" but my tv box only show the initial screen "Tv box" and never follow there. The step to step that i have used is: 1. Burn the image "5.89_Aml-s905_Ubuntu_bionic_default_5.1.0_desktop_20190617" in an usb pen using etcher. 2. I have activated the multiboot mode ( Pushing internal button while a power the tv box for 5 seconds). 4. I have setup "meson-g12a-x96-max.dtb" like as dbt file in uEnv.ini file. 3. The tv box shows in its screen "Tv box" and it does not continue. Can you help me??
  13. Hi i am traying to install armbian in my new tv box (Mecool km3). i have used the image: Armbian_5.89_Aml-s905_Ubuntu_bionic_default_5.1.0_desktop_20190617 but my tv box only show the initial screen "Tv box" and never follow there. The step to step that i have used is: 1. Burn the image 5.89_Aml-s905_Ubuntu_bionic_default_5.1.0_desktop_20190617 in an usb pen using etcher. 2. I have activated the multiboot mode ( Pushing internal button while a power the tv box for 5 seconds). 3. The tv box shows in its screen "Tv box" and it does not continue. Can you help me??