Jump to content

Janaboy

Members
  • Posts

    24
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Applications

Everything posted by Janaboy

  1. Thanks, i spent sever hours but finally have some progress. First of all i am not sure which kernel i had, i used this img before: Armbian_5.91_Aml-s905_Ubuntu_disco_default_5.1.0_desktop_20190708.img But yesterday started to play around with the rest of the dtbs and voila the nexbox a95x seems to be working, i have wifi, usb, eth etc. So finally i could boot from my SD card, then i started to move to emmc, i had some nightmares here. I used first the install-aml-s905-emmc.sh, seems to copied but after restart it did not want to boot from emmc But still could boot form SD. I have no idea why did not work, but i found that i should use install-aml.sh, so i did. This is bricked my device so deeply, that i have spent several hours until i could figure out how to short my emmc and restore my android. But after that i have boot again from SD card and i used at first the install-aml.sh and after reboot it did not boot automatically, i have to use an SD which has an u-boot or similar (created with USB Card maker but deleted all the files). Now it seems to be working and running from emmc. Wasn't easy..
  2. Okay it seems my issue is related to the dtb file, i have used the wetek-hub's dtb and it was booted..unfortunately usb is not working. But this is really strange, i am 100% sure i have to use gxbb p200 dtb.
  3. Yes, i have restored the Android and used this method: option A - Connect the prepared media to the device and turn on the power, boot into Android - Open the app "Update&Backup" - Click on "Select" local update and chose the file on the removable media aml_autoscript.zip - Start "Update" - System will reboot twice and start running the system from external media. For me the option B never worked. The only thing, that i guess it did not restart twice. btw is that normal that aml_autoscript.zip size is 0?
  4. Hi All, So i have decide to update my system with a clean install. First of all i have a Beelkink Mini MXIII S905 box, i had running so far 19.04 Ubuntu (updated to 19.10). I have downloaded this image: Armbian_20.10_Arm-64_focal_current_5.9.0_desktop.img.xz and wrote to an SD card, booted up. extlinux.conf: FDT /dtb/amlogic/meson-gxbb-p200.dtb APPEND root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 I use s905 u-boot > u-boot.ext The dtb should be the good one as i used that for my previous linux. When i boot i get this error: ALERT! LABEL=ROOTFS does not exists! I have tried 2 different SD cadrs, but the same. Anybody has any idea what can be the problem? Thanks
  5. Dear All, I have a Beelink s905 box with Armbian (Ubuntu 19.10). I have problems to install Mosquitto as it is required a package which i don't know how to install: The following packages have unmet dependencies: mosquitto:armhf : Depends: libwebsockets8:armhf (>= 1.6.0) but it is not installable E: Unable to correct problems, you have held broken packages. I am okay to use another type of Mqtt broker but couldn't find a solution I am searching for hours now.. Somebody has any ideas? Thank you in advance
  6. Okay i have created lot of logs, i hope this will help. uart-android boot.txt install.sh output.txt uart-armbian-external boot.txt after install.sh.txt armbian emmc boot with recovery sd card with uboot from the android img.txt
  7. Wait I guess this conversation went into a wrong way I have restored the Android and sent you the requested fdisk -l result. My issues is that after using the install.sh it is not able to boot Armbian from eMMC only if i use a recovery sd (which only contains an u-boot). This is where the log has been provided from the console. So the question how can i restore the u-boot to able to boot from eMMC without using the SD Card? I was able to unpack the original firmware image and i have the u-boot if that is help. But not sure what is the exact way to solve this. Thanks
  8. Yes, but how this help me to solve the issue with the missing u-boot?
  9. Trying to figure out how to make backup, not that expert..
  10. Can it be solved without deleting my armbian? I've installed lot if things, i dont want to loose them What if i burn the u-boot img from the stock rom into emmc? Like it is on the sd card?
  11. Additional comment, this point where you can see the end of the log, my armbian stops booting. This happens if i restart or just start, after replug the power cable, starting fine. Any ideas? boot with recovery sd.txt
  12. I was able to access the console, this is the message: GXBB:BL1:08dafd:0a8993;FEAT:EDFC318C;POC:3;RCY:0;EMMC:0;READ:0;CHK:17A;SD:800;USB:8;LOOP:1;EMMC:0;READ:0;CHK:17A;SD:800;USB:8;LOOP:2;EMMC:0;READ:0;CHK:17A;SD:800;USB:8;LOOP:3;EMMC:0;READ:0;CHK:17A;SD:800;USB:8;LOOP:4;EMMC:0;READ:0;CHK:17A;SD:800;USB:8;LOOP:5;EMMC:0;READ:0;CHK:17A;SD:800;USB:8;LOOP:6;EMMC:0;READ:0;CHK:17A;SD:800;USB:8;LOOP:7;EMMC:0;READ:0;CHK:17A;SD:800;USB:8; and this when i plugin the sd card: D:800;USB:8;LOOP:16;EMMC:0;READ:0;CHK:17A;SD:800;USB:8;LOOP:17;EMMC:0;READ:0;CHK:17A;SD:0;READ:0;CHK:0; TE: 119595608 no sdio debug board detected BL2 Built : 13:55:05, Jan 28 2016. gxb g3625dd5 - xiaobo.gu@droid05 Board ID = 0 set vcck to 1100 mv set vddee to 1000 mv
  13. 2. I always used the Update&Backup and start the aml_script.zip from Android and then used the install.sh, not sure is this the proper step? What i found it is. About the UART logs, unfortunately no UART port specified on the board, so not sure how to get access to the console. But i was able to start the Armbian form the emmc, this way: used the android image and the Boot SD card maker software, with the img burned to an SD card (which is interesting so far only my 4GB SDHC is working), the tool reformatted my sd card (and i understand properly burn the uboot img into the beginning of the sd card) and copied 3 files. I have deleted the 3 files and with the plugged in SD card i am able to boot the Armbian. Would be great to fix this somehow. Not sure how i can provide you any other logs.
  14. Okay very-very insteresting situation.. So i am working to resolve the booting issue, so i looked for some solutions. I've used the AML Boot SD card maker software to recover my android. This software reformatted my sd card (i have a 16 mb unknown at the beginning of the card), and copied 3 files, i have deleted all the three files and without doing anything special step (like using the reset button) the Armbian on the eMMC just booting fine. Any idea why? Or how i can solve this without using the SD Card? Update: I've tried to compare my /boot partition (fat16) with the SD card partition (fat32) and the only different that from my /boot was missing the boot flag, (it has only lba), I've added, but did not solve the issue. Thinking testing, but not sure which way to go. Thanks
  15. Hi @balbes150, I hope i can ask a little help from you. I have a Beelink Mini MXIII box (S905, 2G/16). I have downloaded this img: Armbian_5.91_Aml-s905_Ubuntu_disco_default_5.1.0_desktop_20190708.img installed on a 8gb sd card and renamed the dtb in uenv.ini and extlinux.conf to meson-gxbb-p200.dtb. From Android i have selected the Update&Backup and used the aml_script.zip to install/start my linux. It is starting just fine, but i would like to move the whole thing to the eMMC. I saw in the dmesg that my emmc is mmcblk0, so i renamed it in install.sh, which ran without error but after restart there is nothing, not even black screen (basically no signal). Can you please help me to figure out what could be the problem? Thank you
  16. You were right, my inside mmc is on mmcblk0 and in the script it was set to mmcblk1, this is my dmesg: [ 2.883038] meson-gx-mmc d0074000.mmc: allocated mmc-pwrseq [ 3.078893] mmc0: new HS200 MMC card at address 0001 [ 3.079860] mmcblk0: mmc0:0001 NCard 14.5 GiB [ 3.083401] mmcblk0boot0: mmc0:0001 NCard partition 1 4.00 MiB [ 3.089259] mmcblk0boot1: mmc0:0001 NCard partition 2 4.00 MiB [ 3.094559] mmcblk0rpmb: mmc0:0001 NCard partition 3 4.00 MiB, chardev (241:0) [ 4.303249] meson-gx-mmc d0072000.mmc: Got CD GPIO [ 4.538643] mmc1: new high speed SDHC card at address 278a [ 4.544076] mmcblk1: mmc1:278a SD08G 7.42 GiB [ 4.551476] mmcblk1: p1 p2 [ 6.165136] EXT4-fs (mmcblk1p2): mounted filesystem with writeback data mode. Opts: data=writeback [ 8.265708] EXT4-fs (mmcblk1p2): re-mounted. Opts: commit=600,errors=remount-ro [ 15.436620] meson-gx-mmc d0070000.mmc: allocated mmc-pwrseq [ 15.488876] mmc2: new high speed SDIO card at address 0001 [ 27.944396] EXT4-fs (mmcblk1p2): resizing filesystem from 669696 to 1872896 blocks [ 28.894929] EXT4-fs (mmcblk1p2): resized filesystem to 1872896 I changed the value in the install.sh to mmcblk0 and it seems was okay (no error message or anything) but now i have a fully black screen Can i fix somehow the linux? Or what is the best method to install to emmc? I was using this distro: Armbian_5.90_Aml-s905_Ubuntu_disco_default_5.1.0_desktop_20190701 with meson-gxbb-p200.dtb Thanks
  17. I would like to request for a little help, my Ubuntu was running on an SD card (Beelink Mini MXIII) and i wanted move to emmc, used the ./install.sh command. It was doing for around 10 minutes and ending with this: tar: var/cache/man/it: file changed as we read it tar: var/cache/man/ja/index.db: file changed as we read it tar: var/cache/man/ja: file changed as we read it tar: var/cache/man/nl/index.db: file changed as we read it tar: var/cache/man/nl: file changed as we read it tar: var/cache/man/es/index.db: file changed as we read it tar: var/cache/man/es: file changed as we read it tar: var/cache/man/index.db: file changed as we read it tar: var/cache/man/fr/index.db: file changed as we read it tar: var/cache/man/fr: file changed as we read it tar: var/cache/man: file changed as we read it Copy fstab ******************************************* Complete copy OS to eMMC ******************************************* After restart my Android was starting normally and the Ubuntu from my SD card is disappeared. Then i flashed the img to a clean SD card (another sd card) and used the aml_script update from android, which says ALERT! LABEL=ROOTFS does not exists. Did i mess up? or what can be the issue? Thank you
  18. Thanks @erew You are right, probably easier to buy a cheap dongle which is comptablie as it is not working out of the box, but you know, i like to use those devices. btw it has RTL8723BS chip in it, and tried some topics, but couldn't make it work. So i won't spent much time with it. However would be great to know about a 100% working dongle, so i hope someone will send me a model.
  19. Would be great to see how the bluetooth could be activated? I have a Beelking Mini MXIII (s905,2/16) using with gxbb-p200 dtb, and the wifi is working, but the bluetooth is not
  20. @erew: your post is really helpful and solved my installing issues in 2 minutes. The first post should be updated with this. Thanks.
×
×
  • Create New...