cabela

  • Content Count

    5
  • Joined

  • Last visited

  1. With bionic - Moved a little bit forward but still Kernel Panic... It asks for password, and after correct password given - starts to boot but then hangs [ 6.525588] device-mapper: ioctl: 4.39.0-ioctl (2018-04-03) initialised: dm-devel@redhat.com Please unlock disk armbian-root: [ 31.872802] NET: Registered protocol family 38 [ 33.058377] random: cryptsetup: uninitialized urandom read (2 bytes read) cryptsetup (armbian-root): set up successfully done. Begin: Running /scripts/local-premount ... Scanning for Btrfs filesystems done. Begin: Will now check root file system .
  2. Do you think it is only broken for this specific board or broken at all ? I have some other boards at work and will try tomorrow to build image for another board with cryptroot. as seen in my screen - it shows that /dev/mapper/armbian-root does not exist do not know if this helps
  3. Fortunately when changed SD card I succeeded in booting normal image ( without cryptroot ) however when I enable verbosity=7 and console=serial when tried to load my cryptto Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done. [ 5.211099] mmc1: new high speed SDIO card at address 0001 Begin: Running /scripts/local-premount ... Scanning for Btrfs filesystems[ 5.240369] random: fast init done done. Begin: Waiting for root file system ... Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin:
  4. Dear Werner, I understand I have given some basic info because expected this to be some kind of known issue. I do have USB UART and it is connected. I have not touched the armbianEnv with more verbosity ( I will do this later today and will give output ) but this is on unencrypted version which also fails from my own image. About root encryption - I am thinking of storing the key on some external memory ( some SPI flash or NVRAM ) and also all the IC on the PCB will be glued with some black resin for not being able to disassemble. The software cannot be chrooted because it is playing ro
  5. Hi Igor, Hi Everyone, I am very new here. I have Orange Pi R1 and using Armbian everything is working, however I have proprietary software and want to secure it ( as much as possible ) Read a lot of articles and read about Armbian supporting CRYPTROOT_ENABLE , so decided to try to build my own image. I have succeeded in building 5 images but unfortunatelly none of them boots correctly. I decided to first build image without CRYPTROOT_ENABLE but still cannot succeed. It gives me KERNEL PANIC after truing to load/uncompress Linux. I Basicly want default Armbian image