christophergilchrist

Members
  • Content Count

    4
  • Joined

  • Last visited

About christophergilchrist

  • Rank
    Newbie
  1. Ok its fixed and stable for three days. Updated firmware, removed mate and gnome desktops. Permanently mounted USB drive at boot. Samba running fine. Cheers, Chris
  2. Ok its back again. Ive added the usb drive to fstab so its automatically mounted and the box has started shutting down again every 25 minutes. Everytime I make a configuration change it starts shutting down. Still getting the kernel error below? [ 404.576413] meson-aiu-i2s meson-aiu-i2s.4.auto: Unable to set i2s description [ 404.576417] meson-aiu-i2s meson-aiu-i2s.4.auto: ASoC: can't set meson-aiu-i2s.4.auto hw params: -22 Any help to debug would be great. Chris
  3. Ok guys. It's been stable all night. I removed the sd card and it seems to have solved the problem. Chris
  4. Ok guys looking for some help on shutting down issue. I installed Armbian_5.90_Aml-s905_Ubuntu_bionic_default_5.1.0_desktop_20190701.img.xz using S905.p212.dtb two days ago. It was logging ADC errors in the kernel log every three seconds but they have gone now , it is now logging the errors below in the kernel log and ttyS0 errors in the syslog and kernel log as well. I disabled the ttyS0 service to stop it logging all the time and around 25 minutes later it shutdown, There are no errors in the kernel log apart from the ones below. It was stable for 1.5 days until I disabled the ttyS0. It keeps shutting down every 25 minutes but was stable all day yesterday and today until I disabled and removed ttyS0! I have re-enabled ttyS0 but it is still shutting down every 25 minutes. The box is G10SX S905X MXQ CLK . I have installed the boot partition to eMMC and it is booting fine from there with out the SD card. I've frozen img updates for now. Kernel Error happening every 3 seconds [ 404.576413] meson-aiu-i2s meson-aiu-i2s.4.auto: Unable to set i2s description [ 404.576417] meson-aiu-i2s meson-aiu-i2s.4.auto: ASoC: can't set meson-aiu-i2s.4.auto hw params: -22 Syslog ttyS0 stopping and starting all the time. Oct 9 20:31:56 localhost systemd[1]: serial-getty@ttyS0.service: Scheduled restart job, restart counter is at 139. Oct 9 20:31:56 localhost systemd[1]: Stopped Serial Getty on ttyS0. Oct 9 20:31:56 localhost systemd[1]: Started Serial Getty on ttyS0. Oct 9 20:32:06 localhost systemd[1]: serial-getty@ttyS0.service: Service hold-off time over, scheduling restart. Oct 9 20:32:06 localhost systemd[1]: serial-getty@ttyS0.service: Scheduled restart job, restart counter is at 140. Oct 9 20:32:06 localhost systemd[1]: Stopped Serial Getty on ttyS0. Oct 9 20:32:06 localhost systemd[1]: Started Serial Getty on ttyS0. Oct 9 20:32:17 localhost systemd[1]: serial-getty@ttyS0.service: Service hold-off time over, scheduling restart. Oct 9 20:32:17 localhost systemd[1]: serial-getty@ttyS0.service: Scheduled restart job, restart counter is at 141. Oct 9 20:32:17 localhost systemd[1]: Stopped Serial Getty on ttyS0. Oct 9 20:32:17 localhost systemd[1]: Started Serial Getty on ttyS0. Looking for advice/help on making it stable again? Cheers for your help. Chris