e226329

  • Posts

    2
  • Joined

  • Last visited

e226329's Achievements

  1. Looks like some of targets have this option already enabled: linux-imx6-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-imx6-edge.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-imx7d-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-imx7d-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-jetson-nano-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-jetson-nano-edge.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-jetson-nano-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-meson64-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-meson64-edge.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-meson64-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-meson-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-meson-edge.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-meson-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-mt7623-edge.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-mt7623-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-mvebu64-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-mvebu64-edge.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-mvebu64-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-mvebu-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-mvebu-edge.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-mvebu-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-odroidxu4-current.config CONFIG_MODULE_FORCE_UNLOAD=y linux-odroidxu4-edge.config CONFIG_MODULE_FORCE_UNLOAD=y linux-odroidxu4-legacy.config CONFIG_MODULE_FORCE_UNLOAD=y linux-rk322x-current.config CONFIG_MODULE_FORCE_UNLOAD=y linux-rk322x-edge.config CONFIG_MODULE_FORCE_UNLOAD=y linux-rk322x-legacy.config CONFIG_MODULE_FORCE_UNLOAD=y linux-rk3399-legacy.config CONFIG_MODULE_FORCE_UNLOAD=y linux-rk35xx-legacy.config CONFIG_MODULE_FORCE_UNLOAD=y linux-rockchip64-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-rockchip64-edge.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-rockchip64-legacy.config CONFIG_MODULE_FORCE_UNLOAD=y linux-rockchip-current.config CONFIG_MODULE_FORCE_UNLOAD=y linux-rockchip-edge.config CONFIG_MODULE_FORCE_UNLOAD=y linux-rockchip-legacy.config CONFIG_MODULE_FORCE_UNLOAD=y linux-rockpis-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-s5p6818-legacy.config CONFIG_MODULE_FORCE_UNLOAD=y linux-sun50iw9-legacy.config CONFIG_MODULE_FORCE_UNLOAD=y linux-sunxi64-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-sunxi64-edge.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-sunxi64-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-sunxi-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-sunxi-edge.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-sunxi-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-virtual-current.config # CONFIG_MODULE_FORCE_UNLOAD is not set linux-zynq-legacy.config # CONFIG_MODULE_FORCE_UNLOAD is not set Due to limited environment I can't do pull request on github, so I'm attaching patched configs here for remaining of them. Configs-for-CONFIG_MODULE_FORCE_UNLOAD.7z
  2. Dear developers! Could you please consider possibility to change default kernel config, used in release versions of Armbian, so it enable to forcefully unload of kernel modules ( to do this config option CONFIG_MODULE_FORCE_UNLOAD needs to be enabled). This is seldom but regular needs for me and I beleive for many others in case of external hardware malfunctions, for example. Previosly I have used selfcompiled version of Armbian 5.15 where named option was enabled and anything was fine. Now I have upgraded to Armbian 21.08.1 Buster by installing release version of it because it seems dramatically more complicated to compile by myself. Now in case of freezes of my bluetooth adapter which connects to gsm phone to send some alerts, the only way to restore its functioning is to do system restart, while uloading an reloading (rmmod -f btusb; moprobe btusb) bluetooth driver was enough.