Dennix

Members
  • Content Count

    7
  • Joined

  • Last visited

About Dennix

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi everybody, I have encountered an unusual problem with starting Cubietruck (cubieboard3) with Armbian installed on microSD Card 8GB and the RAID subboard (two SSD 120GB), see below: Loading, please wait... Starting version 241 Begin: Loading essential drivers ... done. Begin: Running /scripts/init-premount ... done Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done. Begin: Running /scripts/local-premount ... Scanning for Btrfs filesystems done. Begin: Waiting for root file system ... Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. Begin: Running /scripts/local-block ... done. done. Gave up waiting for root file system device. Common problems: - Boot args (cat /proc/cmdline) - Check rootdelay= (did the system wait long enough?) - Missing modules (cat /proc/modules); ls /dev ALERT! UUID=caf39fe8-f63f-4a71-b9be-e15597b4f987 does not exist. Dropping to a shell! (initramfs) I had installed the Armbian system using the script "nand-sata-install" and configured some server applications such as Apache, ISPConfig, Mariadb etc . , and Docker ... and it seemed to work out well. However, sometimes the system have had failures during starting with the boot message as described above. I could turn off the machine and restarted it (hard reboot), but now it is still blocked. I checked the microSD Card file system (ext4) with GParted. Unfortunately it did not work. Nothing has changed. See below my previous topic about the Cubieboard3 and the RAID subboard documents. Thanks in advance for your enlightning reply.
  2. What is the reason for this, see below (from wikipedia)? Linux controversies GPL controversy Allwinner has been accused multiple times[68] of violating the GPL license by not providing Linux/Android kernel source code or U-Boot source, and by using LGPL-licensed code within their binary blobs, etc.[69] Backdoor controversy Allwinner has also been accused of including a backdoor in its published version of the Linux kernel.[70][71] The backdoor allows any installed app to have full root access to the system. While this may be a remnant of debugging during the development process, it presents a significant security risk to all devices using the Allwinner provided kernel.
  3. Should I understand that you do not want to support any new cubietech product except the cubietruck?
  4. Hi Igor, Thank you for your reply. I am glad to hear from you. I just found the solution to my RAID subboard problem. Indeed, I had not connected the special cable between CB3 and the RAID subboard. I was missing this cable which I finally found in the box of the cubietruck. I now see the SSD (sda) in RAID 1. Sorry for the inconvenience. But do I have to install armbian on the SSD (sda1) by running the nand-sata-install script, right? I put the web links of cubietech's websites below which helped me to solve this hardware problem: http://dl.cubieboard.org/addon/HDD-RAID/Docs/HDD-RAID Hardware Development Guide V1.0.pdf http://cubieboard.org/2016/03/15/cubietruck-pluscubieboard5-released-now/ http://www.cubietech.com/product-detail/120gb-ssd/ The RAID subboard is compatible with CB3 (cubietruck) and CB5 (cubietruck plus). I use currently the CB3 because i have seen on your armbian's website that armbian is not compatible cubietruck plus (CB5). I would like to know if you plan to create a version of armbian for cubieboard9? http://www.cubietech.com/product-detail/cubieboard9/
  5. Hi, Could anyone please help me to configure CB3 and the subboard RAID? In fact, I own a CB3 and the RAID subboard with two SSD 120GB that I bought at Cubietech three years ago and I have already assembled it. I use the Armbian distribution for Cubietruck and I installed it on a SD Card, but now I would like to install this distribution (Armbian for CB3) on the two SSD from the SD card. If I type the following commands 'hwinfo --block' or 'fdisk -l' or 'lsusb' or 'lsblk -o name' at the prompt (as root), I do not see any SSD except the SD Card (mmcblk0) I also launched 'armbian-config' but nothing appear in the menu about that. I have done some online reconnaissance, but I did not find any informations ou explanations on the topic. How I have to configure the RAID subboard with the CB3 and a GNU/Linux distribution? Does anyone have any idea? Thank you in advance for your reply and support.