Jump to content


  • Posts

  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi Myy, Thank you for taking the time to respond. I have attached the dmesg file. There is an update which I hope will help you, it doesn't me :-( I performed a fresh install of Focal server and plugged in the screen. I installed openbox etc using and when I tried to run openbox using startx It didnt and timed out I then noticed in /var/log/Xorg.0.log the message Screen(s) found, but none have a usable configuration. I plugged in another monitor and it worked fine. Does this shed any light on it? I am able to set a resolution of 1024x768 with no issues, its just the resolution of 1024x600_60.00 that is giving me problems. dmesg
  2. I logged an issue a little while ago with Armbian running on the Tinkerboard that the screen when rotated 90 degrees couldn't draw the screen at any speed. I have been playing with a few alternatives incl going back to the original tinkeros. All have issues so I was delighted to see the FOCAL port. I am using the recommended Waveshare 7" touchscreen that you advertise on the home page as tested 3rd party hardware. Both the desktop and the server versions of Focal come up with the error Configure crtc 0 failed setting mode when I manually set the supported resolution of 1024 x 600 at 60Hz using xrandr Exactly the same settings on TinkerOS works perfectly., but has many other issues! In the /var/log/Xorg.0.log file there is an message Allocate new frame buffer 1024 x 600 stride failed to set mode : Invalid argument. I used cvt to generate the modeline using settings 1024 600 60 then I used xrandr --newmode and added the modeline xrandr --addmode HDMI-1 1024x600_60.00 When I set the output to use this setting xrandr --output HDMI-1 --mode "1024x600_60.00" I get the error crtc 0 failed. As mentioned this works on TinkerOS and is the device that is included in the tested 3rd party hardware. What I am doing wrong? Thanks in advance.
  3. I would prefer to run this in Buster, as I am trying to make this as lightweight as possible. Is there a similar setting in Buster that I could try with? Thanks Lee
  4. Hi Igor, Thank you for your response. Apologies for the delay, I had to flash the OS onto my tinkerboard again. I would say it has made a slight improvement but it's still very slow when rotating 90 degrees left. I have tried 2 different monitors. Any other suggestions would be very much appreciated. Thanks Lee
  5. Hi first post here. I had been wrestling with TinkerOS but discovered Armbian and so far am super impressed with this one caveat. I too am experiencing the same issue, a web page's performance when running with a normal view is significantly quicker than when its rotated using xrandr I have tried the current buster build and used buster_legacy_4.4.213. Both appear to have the same issue, but I am very open to having got something wrong. The monitor(s) I have tested with all worked with a similar script when using TinkerOS. All help would be gratefully received. My bash script that runs on boot #!/bin/sh export DISPLAY=:0 # Rotate the screen 90 degrees left xrandr --output HDMI-1 --rotate left # Rotate the touchscreen settings by 90 degrees left xinput set-prop 'wch.cn USB2IIC_CTP_CONTROL' 'Coordinate Transformation Matrix' 0 -1 1 1 0 0 0 0 1 xset -dpms xset s noblank xset s 300 openbox-session & chromium --no-first-run --disable --disable-translate --disable-infobars --disable-suggestions-service --disable-save-password-bubble --start-maximized --kiosk --disable-session-crashed-bubble --incognito https://bbc.co.uk
  • Create New...