Gausus

  • Posts

    20
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Gausus's Achievements

  1. EDIT: Try forcing mode on HDMI Add new line inn armbianEnv.txt sudo nano /boot/armbianEnv.txt extraargs=video=HDMI-A-1:D drm.edid_firmware=edid/1920x1080.bin # OR you can test this setting extraargs=video=HDMI-A-1:D drm.edid_firmware=HDMI-A-1:edid/1920x1080.bin video=HDMI-A-1:1920x1080 # IF not working test lower res like 1024x768 # Y can set different refresh rate to : 1024x768@30 extraargs=video=HDMI-A-1:D drm.edid_firmware=HDMI-A-1:edid/1024x768.bin video=HDMI-A-1:1024x768@30 If working change res after login from Settings > Display ( Xfce) More info her LINK1 : LINK2
  2. I have used sudo apt-mark hold <linux-package-name> , on kernel . sudo apt-mark hold linux-image-current-rockchip64 sudo apt-mark hold linux-dtb-current-rockchip64 sudo apt-mark hold linux-u-boot-current-rk3318-box I then can run apt update and apt upgrade not updating kernel. To remove mark hold use : sudo apt-mark unhold <linux-package-name> Can y make a list of packages not to upgrade / overwrite ?
  3. There was a bug in the DTS file like y say. Have fixed it and uploaded new DTS , DTB was fine. Just download from old post DTS file if y need it. Yes there often are warnings when converting from DTS to DTB. I use editors inn Linux , like mousepad or nano +++ , think y can use any editor (Windows /Linux) and save inn txt format. As Jock sad , its impossible for the rk3318/28 tvbox to get 1,8 v on sdcard needed for sd uhs SDR104 mode , but some sdcard can work in this mode on 3,3v. I now run Samsung EVO sdcard in this mode.
  4. Thank you for your response. Dont know what y did , I was unable to create DTB. dtc -I dts -O dtb -f rk3318-box_1.5Ghz_SDCARD_v1a_ST_sdhr104.dts -o rk3318-box_1.5Ghz_SDCARD_v1a_ST_sdhr104.dtb Error: rk3318-box_1.5Ghz_SDCARD_v1a_ST_sdhr104.dts:2894.3-2895.1 syntax error FATAL ERROR: Unable to parse input tree I download my rk3318-box_1.3Ghz_SDCARD_v2_ST_sdhr104.dts file , looks like the same error. Will fix dts file. rk3318-box_1.3Ghz_SDCARD_v2_ST_sdhr104.dts fixed. Is it possible to delete post , can't find a way to do it.
  5. Thank y for the quick respond , your excellent work!! I dont understand to much about how DTB syntax works. Trying to learn , where are good sources for learning? Maybe if you have time you can set up a little guide. I also tried to undervolt CPU. Converted HEX to DES for easier reading. Found this setting to working well up to 1.5Ghz Tried to tweak some RAM and GPU settings , but dont think they work. Do you know a way to show RAM frequency from terminal ? dmesg ?. I do DD benchmark on /tmp and sysbench --test=memory run from sysbench tool. No changes in performance enable /disabling settings for RAM and GPU. I recommend hardinfo to show HWinfo. Are RAM frequency set by uboot ? If yes , how can I test different setting for RAM in uboot ? Links to DTB and DTS. opp-1200000000 { opp-hz = <0x00 0x47868c00>; opp-microvolt = <1200000>; clock-latency-ns = <0x9c40>; status = "okay"; }; opp-1296000000 { opp-hz = <0x00 0x4d3f6400>; opp-microvolt = <1225000>; clock-latency-ns = <0x9c40>; status = "okay"; }; opp-1392000000 { opp-hz = <0x00 0x52f83c00>; opp-microvolt = <1250000>; clock-latency-ns = <0x9c40>; status = "okay"; }; opp-1512000000 { opp-hz = <0x00 0x5a1f4a00>; opp-microvolt = <1350000>; // opp-microvolt = <0x149970>; clock-latency-ns = <0x9c40>; };
  6. DTB SDCARD mode up to 104 MB/s Have tried to squeeze some more performance out of my H96 max + RK3328. SDCARD speed runs at sd high-speed mode / max 24MB/s R∕W on rk3318-box.dtb Its possible to get higher speed from sd-card # Org DTB sudo cat /sys/kernel/debug/mmc0/ios clock: 50000000 Hz actual clock: 50000000 Hz vdd: 21 (3.3 ~ 3.4 V) bus mode: 2 (push-pull) chip select: 0 (dont care) power mode: 2 (on) bus width: 2 (4 bits) timing spec: 2 (sd high-speed) signal voltage: 0 (3.30 V) driver type: 0 (driver type B) Have modified the dtb to support up to hr104 (104 MB/s) rk3318 image will not boot , but Armbian_21.11.0-trunk_Station-m1_hirsute_edge_5.14.11_xfce_desktop.img are booting using this modified DTB DTS # Mod DTB Station m1 image sudo cat /sys/kernel/debug/mmc0/ios clock: 150000000 Hz actual clock: 150000000 Hz vdd: 21 (3.3 ~ 3.4 V) bus mode: 2 (push-pull) chip select: 0 (dont care) power mode: 2 (on) bus width: 2 (4 bits) timing spec: 6 (sd uhs SDR104) signal voltage: 1 (1.80 V) driver type: 0 (driver type B) Using gnome-disks performance tool , i get 70+ read 40+ write speed. about 2-3X performance boost on sdcard. If y like to test this DTB disable all overlays in /boot/extlinux/extlinux.conf Have tried to enable modules in rk3318 image to boot. APPEND root= xxx yyy .... ADD to end mmc_block sdhci tifm_sd Dont know if kernel need a patch to boot from sdacrd when sd-uhs-XX modes enabled. SOME links about sdcard mode i DTB https://android.googlesource.com/kernel/msm/+/android-wear-5.1.1_r0.6/Documentation/devicetree/bindings/mmc/mmc.txt https://patchwork.kernel.org/project/linux-arm-kernel/patch/87imkryz5t.fsf@vany.ca/ https://tinkerboarding.co.uk/forum/archive/index.php/thread-310.html Changed i rk3318-box.dtb mmc@ff500000 { compatible = "rockchip,rk3328-dw-mshc\0rockchip,rk3288-dw-mshc"; reg = <0x00 0xff500000 0x00 0x4000>; interrupts = <0x00 0x0c 0x04>; clocks = <0x02 0x13d 0x02 0x21 0x02 0x4a 0x02 0x4e>; clock-names = "biu\0ciu\0ciu-drive\0ciu-sample"; fifo-depth = <0x100>; max-frequency = <0x8f0d180>; resets = <0x02 0x6d>; reset-names = "reset"; status = "okay"; bus-width = <0x04>; cap-mmc-highspeed; cap-sd-highspeed; disable-wp; pinctrl-names = "default"; pinctrl-0 = <0x49 0x4a 0x4b 0x4c>; sd-uhs-sdr12; <-------------------------- sd-uhs-sdr25; <-------------------------- sd-uhs-sdr50; <-------------------------- sd-uhs-sdr104; <-------------------------- vmmc-supply = <0x4d>; vqmmc-supply = <0xd4>; <-------------------------- DISABLED phandle = d4 spdif-2 could not find l free phandle to use card-detect-delay = <0x320>; // Diff / Disabled // phandle = <0x9a>; // card-detect-delay = <0x320>; // cd-gpios = <0x48 0x05 0x01>; // no-sdio; // supports-sd; }; sdmmc-regulator { compatible = "regulator-fixed"; gpio = <0x6b 0x1e 0x01>; pinctrl-names = "default"; pinctrl-0 = <0x6c>; regulator-name = "vcc_sd"; regulator-always-on; regulator-boot-on; regulator-min-microvolt = <0x325aa0>; regulator-max-microvolt = <0x325aa0>; vin-supply = <0x1e>; phandle = <0x4d>; }; // ADD high speed sdcard 1,8v mode sdmmcio-regulator { compatible = "regulator-gpio"; gpios = <0x68 0x00 0x00>; states = <0x1b7740 0x01 0x325aa0 0x00>; regulator-name = "vcc_sdio"; regulator-type = "voltage"; regulator-min-microvolt = <0x1b7740>; regulator-max-microvolt = <0x325aa0>; regulator-always-on; // vin-supply = <0x2b>; vin-supply = <0x6e>; phandle = <0xd4>; }; // spdif-2 { // // spdifm2-tx { // rockchip,pins = <0x00 0x02 0x02 0x5f>; // phandle = <0xd4>; // }; // };
  7. Thanks for the quick reply. Did not work , used nmcli. Even tried to disable password on WiFi. Error: Connection activation failed: (11) 802.1X supplicant took too long to authenticate. 1. Copied and renamed brcmfmac4334-sdio.rockchip,rk3318-box.txt to brcmfmac4334-sdio.txt Rebooted: no wifi 2. Replaced the existing text in /lib/firmware/brcm/brcmfmac4334-sdio.rockchip,rk3318-box.txt and brcmfmac4334-sdio.txt with this file Rebooted: no wifi Think I have a different WiFi chip. Any idea what chip SP2743C is ? Curse have you opened your box and seen what name is on your wifi chip ?
  8. How did you make the WiFi work ? Did you write over the existing /lib/firmware/brcm/brcmfmac4334-sdio.rockchip,rk3318-box.txt ? Have tried the method without success. Have tested both nvram files past to brcmfmac4334-sdio.rockchip,rk3318-box.txt (reboot) WiFi in network-manager, enter password. After some time password prompt comes back asking for password. Opened the box, SP2743C on wifi chip. Google: wifi chip SP2743C , no result. Tested on mainline kernel 5.10.68 Run rk3318-config to configured , Wifi Broadcom BCM4334/Ampak6334 - Dev ID: 02d0:4334 armbianEnv.ini: overlays=rk3318-box-cpu-hs rk3318-box-led-conf1 rk3318-box-wlan-ap6334 Have also tested with: overlays=3318-box-wlan-ap6330 H96 Max+ RK3328 (4G/64G) dmesg from clean install , only run .rk3318-config and reboot.
  9. Tested on H96 Max + RK3328 4G / 64G. Great work jock! & JMCC
  10. Tested Ethernet speed 1000Mb reported , but speedtest.net only gets about 100Mb down and 200Mb up. No sound , and Android don't start. Restore X96 max + bootloader , Android works and sound (100 Mb /s)
  11. Download her , ignore don't support S905x3 (x96 max plus). Read instructions Burn img to sdcard , use BalenaEtcher Copy my downloaded DTB file to \dtb\amlogic Rename u-boot-s905x2-s922 to u-boot.ext Edit \extlinux\extlinux.conf # aml s9xxx FDT /dtb/amlogic/X.yourfile.Y.dtb Boot X96 max +
  12. Works on all Armbian image for RK + AML + AW armbian images , Tv boxes (aarch64 ARMv8)
  13. Ethernet and sound works using DTB meson-sm1-sei610.dtb. Start working in 20200901-dev kernel 5.9 Rc3. (focal).
  14. X96 Max Plus s905x3 4G DTB fix for network and sound. https://drive.google.com/file/d/1jWnRu-GdOL72__X-ea8oI2VRW_x1ENTM/view?usp=sharing Tested on Armbian 20.05.01 20200408.
  15. I tested on Armbian_20.05.3_Arm-64_bionic_current_5.7.0-rc2_desktop_20200425.img (Ubuntu 16.04). Before and after apt upgrade to kernel 5.7.16. Its only in bionic video plays fine. Video plays fine from MPV in full screen and almost fine inn chromium using h264ify video add-on. Have tested new bionic images from Balbes installing desktop from armbian-config, video lags on them to. There most be some change inn config , on older images video plays fine even when upgrading to latest kernel. Video tested MPV. Format : MPEG-4 Format profile : Base Media Codec ID : isom (isom/avc1) File size : 2.00 GiB Duration : 1 h 56 min Overall bit rate mode : Variable Overall bit rate : 2 472 kb/