Jump to content


  • Posts

  • Joined

  • Last visited

  1. Yep, that is what I did (my example above was incorrect). Here the adapted config from the compile script: # method KERNEL_ONLY="yes" # build kernel only SOURCE_COMPILE="yes" # force source compilation KERNEL_CONFIGURE="yes" # change default configuration KERNEL_CLEAN="yes" # MAKE clean before compilation USEALLCORES="yes" # Use all CPU cores BUILD_DESKTOP="yes" # desktop with hw acceleration for some boards # user DEST_LANG="en_US.UTF-8" # sl_SI.UTF-8, en_US.UTF-8 CONSOLE_CHAR="UTF-8" # console charset TZDATA="Europe/Berlin" # time zone ROOTPWD="1234" # forced to change @first login SDSIZE="1500" # SD image size in MB AFTERINSTALL="" # command before closing image MAINTAINER="Igor Pecovnik" # deb signature MAINTAINERMAIL="igor.pecovnik@****l.com" # deb signature GPG_PASS="" # set GPG password for non-interactive packing # advanced KERNELTAG="v3.18.13" # kernel TAG - valid only for mainline UBOOTTAG="v2015.04" # kernel TAG - valid for all sunxi FBTFT="yes" # https://github.com/notro/fbtft EXTERNAL="yes" # compile extra drivers FORCE="yes" # ignore manual changes to source If I did not mess around somewhere else, this does not work and the tag is ignored. I get a 4.0 kernel being checked out.
  2. Hi Thank you so much for this work! It helped me a lot for building my system with the Udoo. The original image was simply bad. I am using the next 4.0 kernel from patrykk which works fine. I got lost in your scripts when I tried modifying them to compile patrykk's 3.18.3 kernel. Where do I have to change what to compile/checkout a specific tag (e.g. v3.18.3) instead of using the newest master, 4.0 branch? The kernel tag in the compile.sh script does not work for the next option (as you mention in the comment). cheers!
  • Create New...