7profy

  • Content Count

    5
  • Joined

  • Last visited

About 7profy

  • Rank
    Newbie

Recent Profile Visitors

626 profile views
  1. SOLVED! Here is solution (for H3): 1. Convert script.bin to FEX: cd /boot bin2fex script.bin script.fex 2. Edit script.fex to enable UART3: sudo nano script.fex Find section [uart0] and set the next to disable uart0-2 and enable uart3 only with 2-pin mode on pin 8/10: [uart0] uart_used = 0 uart_port = 0 uart_type = 2 uart_tx = port:PA04<2><1><default><default> uart_rx = port:PA05<2><1><default><default> [uart1] uart_used = 0 uart_port = 1 uart_type = 4 uart_tx = port:PG0
  2. About month ago I install from armbian.com this os. root@orangepione ~ # uname -a Linux orangepione 3.4.112-sun8i #8 SMP PREEMPT Tue May 31 19:00:17 CEST 2016 armv7l GNU/Linux How to find out it using FEX or DTS? I have the next device list: root@orangepione ~ # ls /dev/ android_adb input ram1 tty18 tty45 uinput apm_bios ion ram2 tty19 tty46 urandom autofs kmsg ram3 tty2 tty47 usb_accessory block lircd ram4 tty20 tty48 usbdev1.1 btrfs-
  3. And how to "tweak"? And what is "FEX"? I'm trying to migrate from Rasperry to Orange. Almost all done. I'm not powerful linux user.
  4. I'm looking at pin 8 and pin 10. Device ttyS3 not available too.
  5. I'm using Orange Pi One with ARMBIAN Debian GNU/Linux 8 (jessie) 3.4.112-sun8i. To access to UART I'm using function serialOpen() of WiringPi library. Default device name for Raspberry is '/dev/ttyAMA0'. But I can't open this device (No such file or directory). How to enable ttyAMA0?