locki

  • Posts

    5
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

locki's Achievements

  1. It was white because i had connected HDMI monitor Now can see output on tft but i cant startx root@orangepione:~# startx X.Org X Server 1.20.9 X Protocol Version 11, Revision 0 Build Operating System: Linux 4.15.0-130-generic armv7l Ubuntu Current Operating System: Linux orangepione 5.10.12-sunxi #21.02.1 SMP Wed Feb 3 20:39:30 CET 2021 armv7l Kernel command line: root=UUID=14ec09df-9864-4191-b047-c6bfafc28b7e rootwait roo tfstype=ext4 console=ttyS0,115200 console=tty1 hdmi.audio=EDID:0 disp.screen0_ou tput_mode=1920x1080p60 consoleblank=0 loglevel=1 ubootpart=54392a35-01 ubootsour ce=mmc usb-storage.quirks=0x2537:0x1066:u,0x2537:0x1068:u sunxi_ve_mem_reserve =0 sunxi_g2d_mem_reserve=0 sunxi_fb_mem_reserve=16 cgroup_enable=memory swapacco unt=1 Build Date: 17 January 2021 09:13:31AM xorg-server 2:1.20.9-2ubuntu1.2~20.04.1 (For technical support please see http:/ /www.ubuntu.com/support) Current version of pixman: 0.38.4 Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 14 22:27:50 2021 (==) Using config directory: "/etc/X11/xorg.conf.d" (==) Using system config directory "/usr/share/X11/xorg.conf.d" MESA-LOADER: failed to open ili9486 (search paths /usr/lib/arm-linux-gnueabihf/d ri:\$${ORIGIN}/dri:/usr/lib/dri) failed to load driver: ili9486 (II) modeset(0): Initializing kms color map for depth 24, 8 bpc. (II) modeset(G0): Initializing kms color map for depth 16, 6 bpc. xinit: connection to X server lost waiting for X server to shut down ...(II) Server terminated successfully (0). Cl osing log file. . root@orangepione:~# How to fix this driver missing issue? i dint find it ... and also can i rotate screen 180 degrees somehow? I tryded: Option "SwapAxes" "1" and Option "InvertY" "true" Option "InvertX" "true" in /etc/X11/xorg.conf.d/99-fbturbo.conf
  2. Thank you I am littlebit close with this! / _ \| _ \(_) / _ \ _ __ ___ | | | | |_) | | | | | | '_ \ / _ \ | |_| | __/| | | |_| | | | | __/ \___/|_| |_| \___/|_| |_|\___| Welcome to Armbian 21.02.1 Focal with Linux 5.10.12-sunxi downloaded compiled via: sudo armbian-add-overlay tft35a-overlay.dts evtest touch screen works! I can see fb1 device root@orangepione:~# ls /dev/fb* /dev/fb0 /dev/fb1 but screen is still white root@orangepione:~# cat /boot/armbianEnv.txt verbosity=1 bootlogo=false console=both disp_mode=1920x1080p60 overlay_prefix=sun8i-h3 rootdev=UUID=14ec09df-9864-4191-b047-c6bfafc28b7e rootfstype=ext4 overlays=spi-add-cs1 user_overlays=tft35a-overlay usbstoragequirks=0x2537:0x1066:u,0x2537:0x1068:u /etc/X11/xorg.conf.d/99-fbturbo.conf Section "Device" Identifier "Allwinner A10/A13 FBDEV" Driver "fbturbo" Option "fbdev" "/dev/fb1" Option "SwapbuffersWait" "true" EndSection root@orangepione:~# dmesg | grep touch [ 7.180180] ads7846 spi0.1: touchscreen, irq 67 root@orangepione:~# dmesg | grep tft [ 7.220722] fbtft: module is from the staging directory, the quality is unknown, you have been warned. root@orangepione:~# dmesg | grep spi [ 7.116782] ads7846 spi0.1: supply vcc not found, using dummy regulator [ 7.179629] [drm] Initialized ili9486 1.0.0 20200118 for spi0.0 on minor 2 [ 7.180180] ads7846 spi0.1: touchscreen, irq 67 [ 7.180833] input: ADS7846 Touchscreen as /devices/platform/soc/1c68000.spi/spi_master/spi0/spi0.1/input/input1 [ 7.199053] ili9486 spi0.0: [drm] fb1: ili9486drmfb frame buffer device root@orangepione:~# startx X.Org X Server 1.20.9 X Protocol Version 11, Revision 0 Build Operating System: Linux 4.15.0-130-generic armv7l Ubuntu Current Operating System: Linux orangepione 5.10.12-sunxi #21.02.1 SMP Wed Feb 3 20:39:30 CET 2021 armv7l Kernel command line: root=UUID=14ec09df-9864-4191-b047-c6bfafc28b7e rootwait rootfstype=ext4 console=ttyS0,115200 console=tty1 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 consoleblank=0 loglevel=1 ubootpart=54392a35-01 ubootsource=mmc usb-storage.quirks=0x2537:0x1066:u,0x2537:0x1068:u sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_fb_mem_reserve=16 cgroup_enable=memory swapaccount=1 Build Date: 17 January 2021 09:13:31AM xorg-server 2:1.20.9-2ubuntu1.2~20.04.1 (For technical support please see http://www.ubuntu.com/support) Current version of pixman: 0.38.4 Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 13 21:28:22 2021 (==) Using config directory: "/etc/X11/xorg.conf.d" (==) Using system config directory "/usr/share/X11/xorg.conf.d" MESA-LOADER: failed to open ili9486 (search paths /usr/lib/arm-linux-gnueabihf/dri:\$${ORIGIN}/dri:/usr/lib/dri) failed to load driver: ili9486 (II) modeset(0): Initializing kms color map for depth 24, 8 bpc. (II) modeset(G0): Initializing kms color map for depth 16, 6 bpc. xinit: connection to X server lost waiting for X server to shut down (II) Server terminated successfully (0). Closing log file. .. I think I am close but some detail still missing
  3. after install drivers: all works but my touch screen is inverted i tryex invert swap axes etc ... I tryed all also some tips from @olehs but no luck... any other tips? root@orangepione:~# cat /etc/X11/xorg.conf.d/99-calibration.conf-35 Section "InputClass" Identifier "calibration" MatchProduct "ADS7846 Touchscreen" Option "Calibration" "200 3933 170 3869" Option "SwapAxes" "0" Option "TransformationMatrix" "1 0 0 0 -1 1 0 0 1" # tip from olehs but also not working EndSection
  4. ___ ____ _ ___ / _ \| _ \(_) / _ \ _ __ ___ | | | | |_) | | | | | | '_ \ / _ \ | |_| | __/| | | |_| | | | | __/ \___/|_| |_| \___/|_| |_|\___| Welcome to Armbian 21.02.1 Focal with Linux 5.10.12-sunxi System load: 29% Up time: 0 min Memory usage: 23% of 491M IP: 192.168.101.15 CPU temp: 63°C Usage of /: 11% of 30G [ General system configuration (beta): armbian-config ] root@orangepione:~/ds7846# ls ads7846.c Makefile root@orangepione:~/ds7846# cat Makefile obj-m := ads7846.o KDIR := /lib/modules/$(shell uname -r)/build PWD := $(shell pwd) all: $(MAKE) -C $(KDIR) M=$(PWD) modules clean: $(MAKE) -C $(KDIR) M=$(PWD) clean install: $(MAKE) -C $(KDIR) M=$(PWD) modules_install root@orangepione:~/ds7846# sudo make make -C /lib/modules/5.10.12-sunxi/build M=/root/ds7846 modules make[1]: *** /lib/modules/5.10.12-sunxi/build: No such file or directory. Stop. make: *** [Makefile:5: all] Error 2 root@orangepione:~/ds7846# I am ending on this error, how to fix it? When my arm distro dont have this module loaded? And what is correct wiring? I did this one: https://www.waveshare.com/3.5inch-rpi-lcd-a.htm screen is white os its look ok ...
  5. Hello, any progress with 3.5 inch RPi LCD V3.0 ? It is possible tu use it with ubuntu distribution or only on RPi?