Jump to content

marvindroid

Members
  • Posts

    4
  • Joined

  • Last visited

  1. Unfortunately the raspap is not working obo for me. Tried to debug, but couldn't by myself. Here is the guide I followed for raspAP https://www.instructables.com/Raspberry-Pi-As-Completely-Wireless-Router/ . My original implementation, I was able to create an AP via /usr/sbin/hostapd /etc/hostapd.conf . Now I am getting wlan0 is not configured, even though I see wlan0 and wlan1 via iwconfig command. Will revert to original implementation and see if I can fix the final step of getting connected to the device via the SSID being generated by the board.
  2. Thank you for the tip, Werner. Will try to use the rasp-ap-gui to see if it fixes the issue I am facing.
  3. I am trying to set up a WiFi access point on Hummingboard 2 which has Armbian Bionic. I am having trouble setting up WiFi AP on the HummingBoard 2. I was able to set this up in a Raspberry Pi using a combination of hostapd and dnsmasq, but having issues on Hummingboard 2 and Armbian. We are operating a sensor using the Board and would like to transfer files using the WiFi generated by the board. /etc/rc.local has the following: sleep 5 rfkill unblock wifi /usr/sbin/hostapd /etc/hostapd.conf systemctl restart dnsmasq iptables-restore < /etc/iptables.ipv4.nat NetworkManager.conf has the following: [main] dns=default rc-manager=file plugins=ifupdown,keyfile [ifupdown] managed=false [device] wifi.scan-rand-mac-address=no /etc/network/interfaces is set up as: source /etc/network/interfaces.d/* # Network is managed by Network manager auto lo iface lo inet loopback auto wlan0 allow hot-plug wlan0 auto br0 iface br0 inet manual bridge_ports eth0 wlan0 /etc/hostapd.conf is setup as: # # armbian hostapd configuration example # # nl80211 mode # interface=wlan0 driver=nl80211 hw_mode=g channel=7 bridge=br0 logger_syslog=0 logger_syslog_level=0 wmm_enabled=0 wpa=2 preamble=1 ssid=ARMBIAN_WiFi wpa_psk=66eb31d2b48d19ba216f2e50c6831ee11be98e2fa3a8075e30b866f4a5ccda27 wpa_passphrase=12345678 wpa_key_mgmt=WPA-PSK wpa_pairwise=TKIP rsn_pairwise=CCMP auth_algs=1 macaddr_acl=0 ### IEEE 802.11n #ieee80211n=1 #ht_capab= #country_code=US #ieee80211d=1 ### IEEE 802.11n ### IEEE 802.11a #hw_mode=a ### IEEE 802.11a ### IEEE 802.11ac #ieee80211ac=1 #vht_capab=[MAX-MPDU-11454][SHORT-GI-80][TX-STBC-2BY1][RX-STBC-1][MAX-A-MPDU-LEN-EXP3] #vht_oper_chwidth=1 #vht_oper_centr_freq_seg0_idx=42 ### IEEE 802.11ac # controlling enabled ctrl_interface=/var/run/hostapd ctrl_interface_group=0 /etc/dnsmasq.conf is setup as: port=5353 interface=wlan0 dhcp-range=192.168.1.50,192.168.1.60,12h /etc/dhcp/dhclient.conf has: # Configuration file for /sbin/dhclient. # # This is a sample configuration file for dhclient. See dhclient.conf's # man page for more information about the syntax of this file # and a more comprehensive list of the parameters understood by # dhclient. # # Normally, if the DHCP server provides reasonable information and does # not leave anything out (like the domain name, for example), then # few changes must be made to this file, if any. # option rfc3442-classless-static-routes code 121 = array of unsigned integer 8; send host-name = gethostname(); request subnet-mask, broadcast-address, time-offset, routers, domain-name, domain-name-servers, domain-search, host-name, dhcp6.name-servers, dhcp6.domain-search, dhcp6.fqdn, dhcp6.sntp-servers, netbios-name-servers, netbios-scope, interface-mtu, rfc3442-classless-static-routes, ntp-servers; alias { interface "eth0"; fixed-address 192.168.1.5; option subnet-mask 255.255.255.0; } alias { interface "wlan0"; fixed-address 192.168.1.10; option subnet-mask 255.255.255.0; } I do see the SSID of the WiFi being generated on other machines, but unable to connect to it. Here are the two guides I followed to set up AP on Raspberry PI: https://thepi.io/how-to-use-your-raspberry-pi-as-a-wireless-access-point/ https://web.archive.org/web/20170103221147/https://frillip.com/using-your-raspberry-pi-3-as-a-wifi-access-point-with-hostapd/ Any advice or suggestions to troubleshoot this situation is helpful. Thank you for your time.
  4. Thank you for the tips. However when I enter the above I get the error Unknown parameter <SSID>. I passed <SSID> as ARMBIAN_WiFi. Any ideas on why this is the case?
×
×
  • Create New...