Jump to content

pennm

Members
  • Posts

    5
  • Joined

  • Last visited

  1. So I've not looked further at this in over a year but figured I'd bump this to see if any other Armbian PBP users have solved this yet.
  2. Yeah I have been using console=display in armbianEnv.txt which translates to console=/dev/tty1 which I believe is what is required. I've also been trying to replicate a working setup based on the Manjaro + LUKS discussion on the Pine64 forums here: https://forum.pine64.org/showthread.php?tid=9052 I updated the initrd image to include the kernel modules seen in the Manjaro installer patch from that thread but still no dice. I need to look more closely to see if there's anything else from there I'm missing as would naively expect the same approach to be reproducible here.
  3. Hi all, I have a working Pinebook Pro Focal build with LUKS encryption enabled. The only issue I have is that when booting no progress or password prompt is displayed. As soon as I enter the password and hit enter I see the boot logo or console output depending on what is set in armbianEnv.txt. I will be continuing my research and learning about the boot process in general but wanted to check in here to see if people had any obvious pointers to share or whether maybe this is a known limitation that is going to be hard to resolve. Thanks, Matt
  4. I had been hitting this error in both cases. The install log suggests a conflict between the base package and the desktop package. I am able to create a server image without issues so for now that gives me what I needed! Selecting previously unselected package armbian-focal-desktop-gnome. (Reading database ... 89075 files and directories currently installed.) Preparing to unpack .../armbian-focal-desktop-gnome_21.05.0-trunk_all.deb ... Unpacking armbian-focal-desktop-gnome (21.05.0-trunk) ... dpkg: error processing archive /root/armbian-focal-desktop-gnome_21.05.0-trunk_all.deb (--unpack): trying to overwrite '/etc/udev/hwdb.d/10-usb-kbd.hwdb', which is also in package linux-focal-root-current-pinebook-pro 21.05.0-trunk dpkg-deb: error: paste subprocess was killed by signal (Broken pipe) Errors were encountered while processing: /root/armbian-focal-desktop-gnome_21.05.0-trunk_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1)
  5. Hello all, I want to build armbian for Pinebook Pro with LUKS enabled but I'm hitting this error. This is happening regardless of build environment (I've tried virtualbox, docker, vagrant) or board selection (most recently I tried building orangepipcplus). .... ] Installing [ armbian-focal-desktop-gnome_21.05.0-trunk_all.deb ] [ error ] ERROR in function install_deb_chroot [ image-helpers.sh:148 ] [ error ] Installation of /root/armbian-focal-desktop-gnome_21.05.0-trunk_all.deb failed [ pinebook-pro focal yes rockchip64 ] [ o.k. ] Process terminated [ o.k. ] Unmounting [ /root/build/.tmp/rootfs-712d9aa2-7aa7-4e20-ae2e-21136ed09662/ ] [ error ] ERROR in function unmount_on_exit [ image-helpers.sh:65 ] [ error ] debootstrap-ng was interrupted [ o.k. ] Process terminated Any suggestions on what is causing this failure? Thanks, Matt
×
×
  • Create New...