binarym

  • Posts

    3
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

binarym's Achievements

  1. Just to let you know, about the ISO i shared there: i'm running my R2S perfectly fine with my fiber connection and a gigabit lan since i used my image. It routes traffic over 3 VLANs, do dhcpd, bind, and iptables. You can just `apt hold` the kernel stuff and update the system normally... You just loose kernel updates.
  2. 1 week later, i confirm that my custom build makes the R2S perfectly stable.
  3. Hi all ! I faced the same issue with my Nano PI R2S : even with nightly builds, the r8152 randomly hanged and lan0 disappeared. I built a minimal armbian buster and revert the driver to previous 1.11 version. I also manually modified my /etc/udev/rules.d/70-rename-lan.rules with the following content: SUBSYSTEM=="net", ACTION=="add", DRIVERS=="rk_gmac-dwmac", KERNEL=="eth0", NAME="wan0" SUBSYSTEM=="net", ACTION=="add", DRIVERS=="r8152", NAME="lan0", RUN+="/usr/sbin/ethtool -K lan0 tx off rx off" It manages correctly my home fiber with ~600Mbps for DL and ~300Mbps for UL. Under heavy charge, i didn't experiment lan0 freeze for at least 1h (previously, it froze every 10 minutes). I guess 2.5Gbps support is lost but: For people with 1Gbps network, it's enought. I have serious doubt regarding the ability of R2S to route 2.5Gbps traffic ;-) For people interested and who do not have time/skill/machine for compilation you can download the image here (~950MB uncompressed) : https://drive.google.com/file/d/1RRvmObBDi58TRTnZN661PL0PYFRbAi0_/view?usp=sharing