Jump to content

Javier Vela

  • Posts

    5
  • Joined

  • Last visited

  1. U-Boot 2021.10-armbian (Nov 05 2021 - 13:19:06 -0600) Allwinner Technology CPU: Allwinner H3 (SUN8I 1680) Model: Banana Pi BPI-M2-Zero DRAM: 512 MiB MMC: mmc@1c0f000: 0, mmc@1c10000: 2 Loading Environment from FAT... Unable to use mmc 0:1... In: serial@1c28000 Out: serial@1c28000 Err: serial@1c28000 Net: No ethernet found. Autoboot in 1 seconds, press <Space> to stop switch to partitions #0, OK mmc0 is current device Scanning mmc 0:1... Found U-Boot script /boot/boot.scr 3964 bytes read in 4 ms (967.8 KiB/s) ## Executing script at 43100000 U-boot loaded from SD Boot script loaded from mmc 352 bytes read in 4 ms (85.9 KiB/s) 10388878 bytes read in 440 ms (22.5 MiB/s) 8303240 bytes read in 351 ms (22.6 MiB/s) Found mainline kernel configuration 34107 bytes read in 11 ms (3 MiB/s) 478 bytes read in 9 ms (51.8 KiB/s) Applying kernel provided DT overlay sun8i-h3-cpu-clock-1.2GHz-1.3v.dtbo 374 bytes read in 10 ms (36.1 KiB/s) Applying kernel provided DT overlay sun8i-h3-i2c0.dtbo 788 bytes read in 10 ms (76.2 KiB/s) Applying kernel provided DT overlay sun8i-h3-spi-spidev.dtbo 502 bytes read in 10 ms (48.8 KiB/s) Applying kernel provided DT overlay sun8i-h3-uart1.dtbo 502 bytes read in 10 ms (48.8 KiB/s) Applying kernel provided DT overlay sun8i-h3-uart2.dtbo 502 bytes read in 10 ms (48.8 KiB/s) Applying kernel provided DT overlay sun8i-h3-uart3.dtbo 504 bytes read in 10 ms (48.8 KiB/s) Applying kernel provided DT overlay sun8i-h3-usbhost0.dtbo 504 bytes read in 10 ms (48.8 KiB/s) Applying kernel provided DT overlay sun8i-h3-usbhost1.dtbo 504 bytes read in 10 ms (48.8 KiB/s) Applying kernel provided DT overlay sun8i-h3-usbhost2.dtbo 504 bytes read in 10 ms (48.8 KiB/s) Applying kernel provided DT overlay sun8i-h3-usbhost3.dtbo 4185 bytes read in 11 ms (371.1 KiB/s) Applying kernel provided DT fixup script (sun8i-h3-fixup.scr) ## Executing script at 45000000 Kernel image @ 0x42000000 [ 0x000000 - 0x7eb288 ] ## Loading init Ramdisk from Legacy Image at 43400000 ... Image Name: uInitrd Image Type: ARM Linux RAMDisk Image (gzip compressed) Data Size: 10388814 Bytes = 9.9 MiB Load Address: 00000000 Entry Point: 00000000 Verifying Checksum ... OK ## Flattened Device Tree blob at 43000000 Booting using the fdt blob at 0x43000000 Loading Ramdisk to 49617000, end 49fff54e ... OK Loading Device Tree to 495a6000, end 49616fff ... OK Starting kernel ...
  2. Hello, I am also having a problem with spidev. I am using Banana-pi-m2-zero with ARMBIAN based Ubuntu Focal. I can't enable spi-dev. I have write in armbiancomfig.txt the following: overlays=cpu-clock-1.3GHz-1.3v i2c0 spi-spidev param_spidev_spi_bus=0 param_spidev_spi_cs=0 Checking the kernel logs with "dmesg | grep spidev" no show relevant info. Reading other posts: Do I have to change sun8i-h3-spi-spidev.dtbo? I have seen similar problem with this processor:https://archlinuxarm.org/forum/viewtopic.php?f=60&t=15395
  3. sudo cat /proc/tty/drivers /dev/tty /dev/tty 5 0 system:/dev/tty /dev/console /dev/console 5 1 system:console dev/ptmx /dev/ptmx 5 2 system /dev/vc/0 /dev/vc/0 4 0 system:vtmaster usbserial /dev/ttyUSB 188 0-511 serial g_serial /dev/ttyGS 242 0-7 serial unknown /dev/ttySC 243 0-7 serial serial /dev/ttyS 4 64-71 serial pty_slave /dev/pts 136 0-1048575 pty:slave pty_master /dev/ptm 128 0-1048575 pty:master unknown /dev/tty 4 1-63 console
  4. I have attached sc16is740 to the I2C port of BPI. sc16is740 is a device that lets me work with i2c like a uart. The device is detected with the comand: sudo i2cdetect -y 0 nº48 00: – -- – -- – -- – -- – -- – -- – 10: – -- – -- – -- – -- – -- – -- – -- – -- 20: – -- – -- – -- – -- – -- – -- – -- – -- 30: – -- – -- – -- – -- – -- – -- – -- – -- 40: 40 – -- – -- – -- – 48 – -- – -- – -- – 50: – -- – -- – -- – -- – -- – -- – -- – -- 60: – -- – -- – -- – -- – -- – -- – -- – -- 70: 70 – -- – -- – -- – Then I have load the driver with: sudo modprobe sc16is7xx 0x48 Using: sudo modprobe sc16is7xx I see the module sc16is7xx loaded using: sudo lsmod However, the system does not created a new interface like ttySC0 and I do not know how to tell the driver which IRQ Pin should use. I have tested also: sudo modprobe i2c:sc16is740 int_pin=4 addr=0x48 Then, I have added the module to: /etc/modules-load.d/module_name.conf I am missing some steps. Could someone help to load this driver? PSD: I have try also to load this driver in an Radxa Zero. Same result Thanks
×
×
  • Create New...