Starfishmod

Members
  • Content Count

    2
  • Joined

  • Last visited

  1. I have an orange pi lite and I'm building my (dev 4.10) image using the Armbian tools. So far I figured out how to enable the DT overlays located in /boot/dtb/overlays by editing the armbianEnv.txt file and adding overlays=sun8i-h3-uart1 sun8i-h3-uart2 sun8i-h3-uart3 sun8i-h3-i2c0 sun8i-h3-spi0-spidev This now enables the various uart, i2c and spi ports I wish to use and that works. I'm trying to now set up a ADS7846 Touch controller using DTB I have copied the file from https://raw.githubusercontent.com/raspberrypi/linux/rpi-4.4.y/arch/arm/boot/dts/overlays/ads7846-overlay.dts and run dtc -I dts -O dtb ads7846-overlay.dts -o /boot/dtb/overlays/ads7846-overlay.dtbo and changed overlays in armbianEnv.txt to overlays=sun8i-h3-uart1 sun8i-h3-uart2 sun8i-h3-uart3 sun8i-h3-i2c0 sun8i-h3-spi0-spidev ads7846-overlay and rebooted. ads7846-overlay doesn't work and according to the information https://github.com/raspberrypi/firmware/blob/master/boot/overlays/README there is supposed to be extra params supplied as part of the dt load How do I add the settings? Thanks Andrew
  2. So I'm pretty new at using serial ports in linux so not even sure if this is the right place. I'm playing around with MIDI using the serial ports on the Orange PiLite - it uses the baud rate of 31250 to achieve this you use setserial to get the base_baud (which it reports as 1500000) and you divide by the speed you want to get the divisor i.e. 1500000/31250 = 48 this becomes >setserial /dev/ttyS1 divisor 48 speed_cust So now when you use 38400 as your baud speed it actually becomes 31250.... ...in theory after some fiddling I found the divsor is actually 50 as 48 gives you weird results which would suggest that the base_baud is actually 1562500 not 1500000 So where is this initial base_baud set? I assuming in the kernel? I see this: sources/u-boot/v2016.11/include/configs/rk3399_common.h:16:#define CONFIG_BAUDRATE 1500000 But i really don't know if this is correct Edit: oops I put spaces in setserial