Jump to content

michal

Members
  • Posts

    6
  • Joined

  • Last visited

  1. Hi, ambianmonitor -u uploaded my armhwinfo.log onto http://sprunge.us/TAUI I hope the verbosity is sufficient since on my laptop I am using Windows Putty terminal. I am going to edit my posts as you suggested. Thanks for your care.
  2. Hi, you were right, I needed to reboot the Orange Pi Zero after commenting out the interfaces file to start the nmtui and nmcli. Now, I am able to get the network lists and activate the proper Wifi connection. All mentioned problems, that I reported as bugs are gone. Thanks a lot for priceless advice - I have spent nearly 9 days playing with Wifi settings, before I wrote these lines into forum. The last thing: OPIz is connected via wifi to router, but SSH gives me Network error: Connection timed out. Ethernet works fine, though. Thanks in advance.
  3. Hi, I commented out all interfaces file, but I still have got nmtui:ERROR:nmt-newt-listbox.c:333:update_active_internal: assertion failed: (priv->active >= 0 && priv->active < priv->entries->len) Aborted as I try to activate the connection. My AP is visible. Problems resolved, see few posts below
  4. Hi, I am having the wifi connection trouble even though I did what TKaiser suggested. My settings - Armbian 5.25 Jessie 3.4.113-sun8i running on Orange Pi Zero. wpa_supplicant configured: network={ ssid="MY_WIFI" psk="secret_password" } interfaces configured: auto eth0 allow-hotplug eth0 iface eth0 inet dhcp auto wlan0 allow-hotplug wlan0 iface wlan0 inet manual wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf iface default inet dhcp wireless-mode Managed wireless-power off auto lo iface lo inet loopback my router: TP-LINK Archer C2. SSH via Ethernet is OK, but SSH via wifi is complete K.O. I am not even able to get the log in screen, although I do have the IP address for wifi as well as for Eth0. Mentioned nmcli is bugy -> nmcli d wifi list brings an empty list, although nmcli radio wifi -> is enabled. nmcli d wifi rescan ends up with Error: Scanning not allowed while unavailable or activating nmtui is MEGA bugy :-( does not connect to the AP at all... The OPIz and Router restart trick did not bring any effect at all. Thanks for any advice. Problems resolved, see few posts below
  5. Hi msev, all pins except pin 5 work. On pin 5 I am getting the following error: File "blink_led.py", line 20, in <module> led = port.PA5 AttributeError: 'module' object has no attribute 'PA5' Yes, with this lib I am able to set GPIO pins high and low. Even more, I can read GPIO pins values - HIGH and LOW.
  6. Hi Martin, I have built and installed the GPIO library on my Orange Pi Zero that you suggested. But unfortunately I noticed that STATUS_LED pin is wrongly mapped after the install. I tried to build and install the library once again after the modification of the mapping.h but after the initialization of led >>> led1 = port.STATUS_LED and print out >>> print led1 I am getting a wrong pin (15) instead of PA17. How shall I fix this problem? Thanks, Michal
×
×
  • Create New...