rom

  • Content Count

    25
  • Joined

  • Last visited

Everything posted by rom

  1. Hello, finally I've switched to Armbian hostapd despite the loss of WPS support (I was using the push-button function with stock Debian hostapd). I confirm that both brcmfmac and 8811au based wifi devices work fine now Thanks for your time and support, Romain
  2. I confirm that brcmfmac works with Armbian hostapd however there's no WPS support and I can't get it to work either in ac mode with my 8811au based wifi device. For the while I'm stuck to Armbian 5.60 with Debian hostapd, both wifi devices working (embedded and USB adapter) and WPS support.
  3. Until now, I've been using what seems the official hostapd.conf man page here https://w1.fi/cgit/hostap/plain/hostapd/hostapd.conf Yes, stock Debian hostapd (2:2.4-1+deb9u2) comes with WPS support, unlike Armbian hostapd it seems.
  4. Igor, just installed Armbian hostapd and tried it with my config file for the embedded AP6210 wifi chipset. It has been working fine until I use WPS related configuration items, among others. Below the result of the command hostapd with my config file as an argument : Line 32: unknown configuration item 'wps_state' Line 33: unknown configuration item 'ap_setup_locked' Line 34: unknown configuration item 'os_version' Line 36: unknown configuration item 'manufacturer' Line 37: unknown configuration item 'device_name' Line 39: unknown configuration item 'device_type' Lin
  5. Yes, it's already the way I use it but I thought you were meaning that there was just one config file in your post above...doesn't matter anyway
  6. Can this work with two APs/adapters at the same time, I've realised there's only one hostapd config involved ?
  7. OK, I'm not used to armbian-config but I'm gonna test this then. I'll keep you informed
  8. No good news Igor...to sum up things, the different options for the while are: - Armbian 5.60/kernel 4.14/Debian hostapd (Amrbian hostapd not tested) => both brcmfmac and 8812au working; - Armbian 5.73+/kernel 4.19/Debian hostapd => only 8812au working ; - Armbian 5.73+/kernel 4.19/Armbian hostapd => only brcmfmac working. Thank you very much for your concern though.
  9. It's an rtl8811au based wifi device handled by the 8812au module, my mistake.
  10. Igor, I don't get the point of the powered USB hub because my rtl8812au based wifi device already works as an AP directly plugged into one of my Cubietruck USB ports. It is an USB 2.0 device however (https://aliexpress.com/item/EDUP-Brand-Dual-Band-11ac-600Mbps-wifi-adapter-6dbi-wifi-Adapter-USB-Antenna-Black-usb-wireless/32798559832.html), not USB3, maybe that's the point ?
  11. Well, I'm not much surprised that it works with Armbian hostapd because it was already the case in one of my previous posts above. Problem is that if I use Armbian hostpad, my setup works with the embedded AP6210 but it doesn't work anymore with my other wifi device based on rtl8812au chipset and I don't know why:\ I want to get both b/g/n 2.4GHz and ac 5GHz APs working, this was the case with Debian hostapd before I upgrade to Armbian 5.70. I'll give a try to Armbian 5.74 (compiling it right now) + Debian hostapd first then will try Armbian hostapd if it still doesn't
  12. Hi Igor, looks promising, thanks ! Do you use Armbian's custom hostapd package or the one from official Debian repo (2:2.4-1+deb9u2) ?
  13. Hi Igor, I use hostapd from official Debian repo (2:2.4-1+deb9u2), not the Armbian one, and it still doesn't work with module brcmfmac and ARMBIAN 5.73. So I uninstalled the "official" hostapd and tried the Armbian one : now hostapd works with the sample configuration file you provide but it doesn't with the one (attached) I've successfully used until now :\ With my configuration file and official hostapd, I get the following result with command "hostapd /etc/hostapd/hostapd_2.4GHz -dd": root@cubietruck:~# hostapd /etc/hostapd/hostapd_24GHz.conf -dd random:
  14. Hello Igor, is this problem fixed in ARMBIAN 5.73 please ? Thanks, Romain
  15. Hello, thank you very much for your answers. Romain
  16. Hello, since I upraded from Armbian Strech 5.60 (kernel 4.14.84-sunxi) to Armbian Stretch 5.70 (kernel 4.19.13-sunxi), I can't get hostapd to work on my Cubietruck. When I modprobe the brcmfmac module, I get the following lines with dmesg: [134591.243266] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43362-sdio for chip BCM43362/1 [134591.523515] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43362-sdio for chip BCM43362/1 [134591.523658] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43362-sdio.clm_blob failed with error -2 [134591.5236
  17. Hello, on Cubietruck, until I upgrade my ARMBIAN server from Jessie to Stretch with kernel 4.13.16-sunxi, I could use the VGA output for display. After the upgrade, I don't have any display from VGA. In /boot/boot.cmd, I have the following kernel bootargs : "console=tty1 root=/dev/mmcblk0p1 rootwait rootfstype=ext4 sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_mali_mem_reserve sunxi_fb_mem_reserve=16 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=1" Any advice ? Thanks in advance,
  18. Hi Edwin, based on your advice and compatibility matrix, I've just bought the Panda Wireless PAU06. Thank you very much! Romain
  19. Thanks a lot for the answer Igor as well as for your great work on Armbian ! Can anyone recommend a wireless USB adapter (n draft or better if possible) working out of the box to use as an AP with hostapd ? Thanks again, Romain
  20. Hello, I'm running ARMBIAN 5.25 stable with kernel 4.9.12-sunxi on my Cubietruck and I mostly use it as an AP. I've installed the "hostapd" package from the official armbian repository and it works fine until I want to connect more than 5 wireless clients. The kernel module used is "brcmfmac" provided by the armbian-firmware package. Is it an hardware limit and how can I bypass it if possible ? The working default config provided with hostapd package is below: ssid=ARMBIAN interface=wlan0 hw_mode=g channel=5 driver=nl80211 ctrl_interface=/va
  21. Thanks for the advice Actually, on Cubietruck, the kernel module for the embedded AP6210 wifi chipset is "brcmfmac" but I'll probably need Rui RUBIERO's procedure if I decide to switch to an rtl819cu based chipset because brcmfmac dosen't support WPS :\ unless someone demonstrates me the contrary. When I use the command "hostapd_cli wps_pbc" on cli, hostapd_cli's output seems OK : Selected interface 'wlan0' OK but I get the following messages in syslog : brcmfmac: brcmf_vif_set_mgmt_ie: vndr ie set error : -30 brcmfmac: brcmf_config_ap_mgmt_ie: Set Beacon IE Failed and no
  22. Hello, on my cubietruck, I tried to upgrade a working hostpad install with the one provided by the armbian repository. After upgrade, hostapd fails to start. Is there any particular prerequisite to using the armbian version ? Thanks in advance for your time.
  23. Thanks, it was woth to be mentionned.
  24. Problem solved after setting the "console" parameter to "display" instead of "both" in /boot/armbianEnv.txt and recompiling /boot/boot.scr
  25. Hello, I'm running a freshly installed armbian with mainline kernel 4.9.5 on my cubietruck. Between u-boot messages and login prompt I don't get any output while booting. I've tried several values for the "console" parameter in the armbianEnv.txt and recompiled the /boot/boot.scr file without success. I've tested both VGA and HDMI (with an HDMI to VGA adapter) outputs without success too. What should I do to get things to work please ? Thanks for your time and your great work on armbian.