damien78

Members
  • Content Count

    33
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Raffles

Applications

Calendar

Everything posted by damien78

  1. Hi, I updated my cubietruck jessie to 5.23. update successful but no boot on kernel . I boot on sd card and mount nand . no uImage but an zImage. I use mkimage in order to generate uImage and it work. kernel packaging must be corrected.
  2. Ok I tested. bluethoot ok. but the function I want to use, loudspeaker emulator, does not work properly. the sound is constantly cut, choppy. it's not an armbian problem...
  3. Hi, I updated my system to version 5.20. This version is supposed to solve the problem of bluetooth.But this is not the case. Can you help me? thanks. ps : dmesg | grep ap6210 : 8.054958] [ap6210] select wifi ap6210 [ 8.058372] [ap6210] Initializing ap6210. [ 8.063627] [ap6210] platform device registered successfully. [ 8.067651] [ap6210] Using ap6210 configuration. [ 8.288340] [ap6210] WLAN placed in POWER ON [ 8.559560] [ap6210] Linux Kernel SDIO/MMC Driver [ 8.582485] [ap6210] Broadcom Dongle Host Driver: register interface [wlan0] MAC: 00:90:4c:11:22:33 [ 8.947049] [ap6210] WLAN placed in RESET [ 10.468573] ap6211: exports duplicate symbol bcmsdh_probe (owned by ap6210) [ 10.487291] ap6211: exports duplicate symbol bcmsdh_probe (owned by ap6210) [ 10.792652] [ap6210] Using ap6210 configuration. [ 32.955882] [ap6210] dhd_check_hang: Event HANG send up due to re=0 te=0 e=-36 s=0 [ 32.959999] [ap6210] In : chip crash eventing [ 32.975217] Modules linked in: disp_ump mali_drm drm mali ump bnep cpufreq_userspace btusb ap6210 sunxi_ir hidp rfcomm hci_uart bluetooth sg [last unloaded: scsi_wait_scan] [ 33.024617] [<c0706ea8>] (cfg80211_disconnected+0xc0/0xc4) from [<bf0da1ac>] (wl_cfg80211_hang+0x44/0xb4 [ap6210]) [ 33.034502] [<bf0da1ac>] (wl_cfg80211_hang+0x44/0xb4 [ap6210]) from [<c004cef0>] (process_one_work+0x138/0x3cc) [ 33.121388] [ap6210] reg_notifier for intiator:0 not supported
  4. I have build and rapidly test on my cubietrucks it's ok. I must debug sound format mismatch on spdif ( basically remove s32le and add iec958) I add iec958 format, but it has not had any effect. I think it lacks a specific configuration file in alsa but it's too complicated.
  5. Hi, I solved this issue. You must apply ( manually ) this part of patch in order to be able to pause during playback with sound over spdif. @@ -247,13 +296,20 @@ static int sunxi_pcm_trigger(struct snd_pcm_substream *substream, int cmd) case SNDRV_PCM_TRIGGER_START: case SNDRV_PCM_TRIGGER_RESUME: case SNDRV_PCM_TRIGGER_PAUSE_RELEASE: + /* enqueue dma buffers */ + sunxi_pcm_enqueue(substream); sunxi_dma_start(prtd->params); + ret =0; break; case SNDRV_PCM_TRIGGER_SUSPEND: case SNDRV_PCM_TRIGGER_STOP: case SNDRV_PCM_TRIGGER_PAUSE_PUSH: sunxi_dma_stop(prtd->params); + prtd->dma_loaded = 0; + ret = 0; break; default: @@ -262,7 +318,7 @@ static int sunxi_pcm_trigger(struct snd_pcm_substream *substream, int cmd) } spin_unlock(&prtd->lock); - return 0; + return ret; } I copied this from the HDMI driver that works fine. first line : push data in dma buffer second line : flush dma the others lines are non functional.they simply allow to return errors.
  6. Hi, I compiled with one of my patch and it works. Can you tell me how you manage to debug the kernel? you use the connection ttl series with kgdb? thanks
  7. Hi, I have tested this issue : https://github.com/linux-sunxi/linux-sunxi/issues/244 apparently it is not resolved. kernel panic log :
  8. Hi, There is no error during installation. my boot partition : bin boot.axf boot.cmd boot.ini boot.scr config-3.4.112-sun7i-gd47d367-dirty initrd.img-3.4.112-sun7i-gd47d367-dirty linux magic.bin script.bin script.bin.old script.old System.map-3.4.112-sun7i-gd47d367-dirty uEnv.txt uImage uImage-3.4.108 uImage-3.4.110 uImage-3.4.111-ir+ uImage-cma uImage-ir upgrade.log I installed the packages: linux-headers-sun7i_5.14_armhf.deb linux-image-sun7i_5.14_armhf.deb linux-image-sun7i-dbg_5.14_armhf.deb linux-u-boot-cubietruck_5.14_armhf.deb with "dpkg -i" cat boot.cmd setenv bootargs console=tty1 root=/dev/sda1 rootwait rootfstype=ext4 sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_mali_mem_reserve sunxi_fb_mem_reserve=16 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=1 #-------------------------------------------------------------------------------------------------------------------------------- # Boot loader script to boot with different boot methods for old and new kernel #-------------------------------------------------------------------------------------------------------------------------------- if ext4load mmc 0 0x00000000 /boot/.next || fatload mmc 0 0x00000000 .next then # sunxi mainline kernel #-------------------------------------------------------------------------------------------------------------------------------- ext4load mmc 0 0x49000000 /boot/dtb/${fdtfile} || fatload mmc 0 0x49000000 /dtb/${fdtfile} ext4load mmc 0 0x46000000 /boot/zImage || fatload mmc 0 0x46000000 zImage env set fdt_high ffffffff bootz 0x46000000 - 0x49000000 #-------------------------------------------------------------------------------------------------------------------------------- else # sunxi android kernel #-------------------------------------------------------------------------------------------------------------------------------- ext4load mmc 0 0x43000000 /boot/script.bin || fatload mmc 0 0x43000000 script.bin ext4load mmc 0 0x48000000 /boot/zImage || fatload mmc 0 0x48000000 zImage bootz 0x48000000 #-------------------------------------------------------------------------------------------------------------------------------- fi # Recompile with: # mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr I boot if I replace the uImage installed by the package with other uImage- *
  9. Hi, I have compile your kernel with my patch successfully. I have installed generated package but card not boot from nand kernel stop after 6s and no message. Can you help me? I must execute part of nand-sata-install? thank you
  10. Hi, You can change your screen resolution by the kernel command line.but it surprised me that the problem comes from this. have you tested another video player?
  11. Hi, sorry for my english! I use tiny media manager because it do the same some things of KODI (retrieving some information of media such as fanart, trailer , etc( not a jacket but a dvd cover) but it works out of the box with armbian. tiny media manager is able to launch video player such as mpv or mplayer but is not suitable for use with a remote. HD video playback and HD audio (DTS,ac3 pass-trougth) is quite difficult with the CPU Allwinner and those despite the incredible work of developers. the idea of my post is to constitute a team in order to create or find as suitable solution for workaround the very difficult work to port kodi on allwinner. there is no question of remake kodi but only the essential function: Display wholesale video present on the disk and launch an external player and not internally in kodi. control this with a remote
  12. Hi, The results seem good. But you can test with 1920x1080p24 because video is rarely in 60 fps and blueray are in 24 or 25 fps. You can test with mplayer which also support vdpau.
  13. Hi all, Kodi is a beautiful software, but it's very complicated. for my personal use I'd settle for a small program that shows only the jacket in single screen and which launches mpv or mplayer. and to recover jacket tiny media manager is very good things,same if it is in java
  14. Your user must be part of the group video normally is the case but it's worth checking. This command will list the groups to which the user belongs : groups orangepi you can post your kernel command line with: cat /proc/cmdline
  15. Hi, Your kernel work is really great! I will abandon the dan-and fork in order to contribute effectively. my change its simple and not dependent on the work's dan-and. My goal is to have a system of emmision effective receipt for any type of infrared remote control. For that I have to review the management of the PWM. I hoped successfully operate the PWM as the mainline.
  16. OK, how can I integrate the script in a standard compilation. I have not seen this script in : https://github.com/igorpecovnik/lib/blob/master/common.sh#L186. I intend to transfer the kernel modifications in your but he tested it easier for me to use my fork.. thanks
  17. Hi, when I try to update my core the apt-get install operation fails. This is because the post-installation script creates a symbolic link as the boot partition does not support because she is fat. Also the boot is only possible with a uImage not zImage I think. To compensate I am forced to make a copy instead of the link.
  18. Hello, apparently you are logged in as root. you must create a Standard user. You can try to connect via ssh: ssh root@ip. password: 1234 normally it should launch an account creation process. You must replace ip by ip of our machine or by name. On allwinner CPU only vdpau output is able to play video. Your user must be in video group.
  19. Hi, I want to use my cubietruck to play the video in HD and with spdif pass-trougth and I want use mopidy. with last armbian jessie desktop : with mplayer2 : pass-trougth is ok but video is too slow with mpv : I heard a very loud noise at the output of the amplifier is not DTS decoding and is transmitted as the pcm.--> it is a kernel problem: the driver sends a sound that is not recognized by the amplifier. the SPDIF sound format is limited to 24 bits video is OK. mopidy is OK with last armbian xenial: it work because mpv is very old with mplayer2 : pass-through and video is ok but kernel panic when I put the video paused--> kernel bug solved : see http://forum.armbian.com/index.php/topic/1396-kernel-panic-when-playing-video-with-spdif-audio-output/ with mpv : video is OK but same issue for sound. mopidy : no sound. with armbian trusty: all work but but kernel panic when I put the video paused-> kernel bug solved This issue is partially solved because work only with old version of mpv (before 0.6)
  20. Hi, Can you provide the log mpv and the results of "ls -la /dev"? and results of "uname -a"?
  21. I tested this : http://mopidy.readthedocs.io/en/latest/service/#configure-pulseaudio it does not work against by now I see the output sound of my other pc so pulse is configured properly.
  22. Hi, I use my cubietruck with xenial desktop and mopidy. I installed successfully mopidy with mopidy's repository I tested only with alsa then with pulse. results : no sound and error on service mopidy status. pulse work well with mpv. Can you help me?
  23. Hi all, I plan to use kodi and cubietruck. I have a fork with cma patch and powerfull IR remote receiver ( i.e not limited to nec ). On my cubietruck HW accleration work and 5.1 sound but if i pause video kernel bug and i must reboot my cubie. Have you had this problem? It's my repo with lmast commit form dan-and fork : git clone -b pwm+cma https://github.com/damien7851/linux-sunxi.git In travis.yml you can view used config.
  24. Hi, I'am backported mainline IR driver to legacy kernel and it works! see this post : https://github.com/igorpecovnik/lib/issues/135
  25. hi, I thought of a solution of this kind but it is qaund a shame not to use existing equipment and add a usb. So I wear the IR driver kerenl mainline to the legacy and it works. see this post: https://github.com/igorpecovnik/lib/issues/135