sufialhussaini

Members
  • Content Count

    6
  • Joined

  • Last visited

About sufialhussaini

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. sufialhussaini

    USB0 host mode not working

    Hi All, I'm using the latest Debian mainline kernel image -> Armbian_5.31_Micro_Debian_jessie_next_4.11.5. I can't get the USB OTG port to work as host only. I was using the legacy kernel before and below setup was working for me -> [usbc0] usb_used = 1 usb_port_type = 1 usb_detect_type = 0 usb_drv_vbus_gpio = port:PB09<1><0><default><0> usb_restrict_gpio = usb_host_init_state = 1 usb_restric_flag = 0 I read on another post that usb0 mode is host on armbian images by default. I also read about needing to load the g_serial module for Banana pi, but I don't think it's required here. Do I need to make any changes to the dts? Thank you for your help.
  2. sufialhussaini

    Mod nand-sata-install for SD with separate boot partition

    The latest `nand-sata-install.sh` scripts works great! Thanks again!
  3. sufialhussaini

    Mod nand-sata-install for SD with separate boot partition

    I was actually using an earlier version of the `nand-sata-install.sh`, but it failed to boot on NAND. I believe you mean the one here on github? I will give it a try and let you know. Thanks.
  4. Hello, I followed the steps Igor provided here to create separate partitions for boot & root. I'm now trying to flash my NAND using this SD card, but nand-sata-install doesn't work out-of-the-box with this setup. # df -h Filesystem Size Used Avail Use% Mounted on /dev/mmcblk0p1 20M 16M 4.1M 80% /boot /dev/mmcblk0p2 3.6G 2.3G 1.1G 68% / ... I tried making a lot of modifications to the nand-sata-install.sh script, but nothing seems to work. I would appreciate if someone could direct me as to what parts of the script need to be modified. Thank you.
  5. I get this message in dmesg: [ 7.584329] invalid gpio pin in fex configuration : -1 How can I check what line in the fex file is causing this problem? # cat /etc/armbian-release # PLEASE DO NOT EDIT THIS FILE BOARD=micro BOARD_NAME="Micro" VERSION=5.25 LINUXFAMILY=sun7i BRANCH=default ARCH=arm IMAGE_TYPE=stable Thanks.
  6. sufialhussaini

    Armbian in Read Only Mode

    Same problem with me @gailu. Were you able to solve this? I too couldn't find overlayroot_0.27ubuntu1.2_all.deb and I just can't get overlayroot_0.27ubuntu1.3_all.deb to work with modifications based on @lauhub's patch.