Dmitriy Zhuk

Members
  • Content Count

    25
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Raffles

Applications

Everything posted by Dmitriy Zhuk

  1. Thank you for answer. I have additional information. I've built the image. But I can't boot. There are errors during building: What it means? And why it happens?
  2. Hello. Now, build environment is only Ubuntu 18.04 (bionic). But some time ago, the build environment was Ubuntu 16.04 (xenial). How can I build armbian on Xenial? Maybe, I have to change branch to another, or checkout to certain commit? Help me please...
  3. I have found the solution: kill `pidof hostapd`
  4. These methods don't work: root@bananapim2plus:~# ps -ef | grep hostapd root 1061 1 0 23:55 ? 00:00:00 hostapd -B /etc/hostapd.conf root 1148 948 0 23:57 pts/0 00:00:00 grep hostapd root@bananapim2plus:~# systemctl stop hostapd root@bananapim2plus:~# ps -ef | grep hostapd root 1061 1 0 23:55 ? 00:00:00 hostapd -B /etc/hostapd.conf root 1154 948 0 23:57 pts/0 00:00:00 grep hostapd root@bananapim2plus:~# service hostapd stop root@bananapim2plus:~# ps -ef | grep hostapd root 1061 1 0 23:55 ? 00:00:00 hostapd -B /etc/hostapd.conf root 1172 948 0 23:58 pts/0 00:00:00 grep hostapd
  5. And I have the second question. When I run hostapd as daemon in background (hostapd -B /etc/hostapd.conf), how can I stop the hostapd? The one way (I think wrong way) I can ps -ef | grep hostapd and then hill the precess.
  6. I have resolved this problem due to this forum: https://www.raspberrypi.org/forums/viewtopic.php?t=17702 But I have the question. This method works: rmmod dhd modprobe dhd op_mode=2 But this method does't work: echo 2 > /sys/module/dhd/parameters/op_mode Why? How can I to change some script in sources in order to this module insert with op_mode=2 by default?
  7. Igor, thank you for this hint. I have the small success. I have done rmmod dhd modprobe dhd op_mode=2 After it, I can scan and see my SSID via mobile phone. But, when I trying to connect to it, my phone can't obtain IP address. Do I have error on my hostapd.conf? Or do I need other actions for successful connecting?
  8. I have cache/sources/linux-sun8i/sun8i/drivers/net/wireless/bcmdhd/dhd.ko But I don't have ap6212.ko and ap6211.ko How can I to insmod it?
  9. I have created file /etc/NetworkManager/conf.d/10-ignore-interfaces.conf with echo "[keyfile]" > /etc/NetworkManager/conf.d/10-ignore-interfaces.conf echo "unmanaged-devices=interface-name:wlx0013ef6c46e3" >> /etc/NetworkManager/conf.d/10-ignore-interfaces.conf service network-manager restart I run hostapd -dd /etc/hostapd.conf and also no AP
  10. Do you mean, I need add [keyfile] unmanaged-devices=mac:00:19:e0:57:86:af to file /etc/NetworkManager/NetworkManager.conf? By the way, without telling Network manager, I can to connect to WiFi modem via wpa_supplicant. Is it OK?
  11. My folder /etc/NetworkManager/conf.d is empty. I have attached my hostapd.conf I run hostapd -dd /etc/hostapd.conf There is my output: Maybe this additional information can help... hostapd.conf
  12. Thank you. But, for some reasons, I use older version of Armbian (5.33) for my BananaPi M2+. And, in menu Wired Wireless Bluetooth Hotspot only 3 items: IP Clear Advanced And it is no Hotspot item. How can I make AP via hostapd?
  13. Sorry, I mean how to run it. This video has small resolution, and I can't view it.
  14. Could you please explain me this way?
  15. Hello guys. I try to configure AP on WiFi. I have created /etc/hostapd/hostapd.conf: interface=wlan0 driver=nl80211 country_code=IN ssid=TEST hw_mode=g channel=6 wpa=2 wpa_passphrase=12345678 wpa_key_mgmt=WPA-PSK wpa_pairwise=TKIP rsn_pairwise=CCMP auth_algs=1 macaddr_acl=0 Then I have uncommented DAEMON_CONF="/etc/hostapd/hostapd.conf" in /etc/default/hostapd. After it, I run /etc/init.d/hostapd restart And I try to scan WiFi via mobile phone, and no TEST. What am I doing wrong?
  16. Hello guys. I try to build image for pine64. My OS is Ubuntu 16.04. My options: - Full OS image for flashing - Do not change the kernel configuration - pine64 - default - jessie -image with console interface. Then I see the following: 0 upgraded, 299 newly installed, 0 to remove and 0 not upgraded. Need to get 118 MB of archives. After this operation, 461 MB of additional disk space will be used. WARNING: The following packages cannot be authenticated! hostapd E: There are problems and -y was used without --force-yes [ error ] ERROR in function create_rootfs_cache [ debootstrap-ng.sh:208 ] [ error ] Installation of Armbian packages failed [ o.k. ] Process terminated [ error ] ERROR in function unmount_on_exit [ image-helpers.sh:59 ] [ error ] debootstrap-ng was interrupted [ o.k. ] Process terminated How can I resolve this problem?
  17. I have uncommented #allow-hotplug wlan0 and all works.
  18. Thank you for hint. I will try to do this.
  19. Yes, of course. Thank you for link to documentation. This method works. But I need method without any dialogues. So I try to use wpa_supplicant.
  20. Thank you for answer and help in advance. My board is Banana Pi M2 Plus. Name of image is ARMBIAN 5.33 user-built Debian GNU/Linux 8 (jessie) 3.4.113-sun8i There is log link: http://sprunge.us/fFSg About my problem. I try to connect board to my WiFi router. My steps are following: 1. root@bananapim2plus:~# wpa_passphrase Home MY_PASSWORD > /etc/wpa_supplicant.conf 2. I modified /etc/network/interfaces for enabling WiFi: source /etc/network/interfaces.d/* # Wired adapter #1 allow-hotplug eth0 #no-auto-down eth0 iface eth0 inet dhcp #address 192.168.0.100 #netmask 255.255.255.0 #gateway 192.168.0.1 #dns-nameservers 8.8.8.8 8.8.4.4 # hwaddress ether # if you want to set MAC manually # pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838 # Wireless adapter #1 # Armbian ships with network-manager installed by default. To save you time # and hassles consider using 'sudo nmtui' instead of configuring Wi-Fi settings # manually. The below lines are only meant as an example how configuration could # be done in an anachronistic way: # #allow-hotplug wlan0 auto wlan0 iface wlan0 inet dhcp #address 192.168.0.100 #netmask 255.255.255.0 #gateway 192.168.0.1 #dns-nameservers 8.8.8.8 8.8.4.4 wpa-conf /etc/wpa_supplicant.conf # Disable power saving on compatible chipsets (prevents SSH/connection dropouts over WiFi) #wireless-mode Managed #wireless-power off # Local loopback auto lo iface lo inet loopback 3. Rebooting the device. After it, my device is obtaining IP address, for example 169.254.11.71 But a result, there is no internet connection. I made ping 8.8.8.8 But answer is “Destination Host Unreachable” How can I connect my board to the internet?
  21. Hello, guys. I use debian server version for my board. But I can't use WiFi to connect my router. I have tried wpa_supplicat, but no result. I used many resources for information, such as https://www.blackmoreops.com/2014/09/18/connect-to-wifi-network-from-command-line-in-linux/ https://unix.stackexchange.com/questions/283722/how-to-connect-to-wifi-from-command-line Maybe, I do something wrong. Can you help me please?
  22. Hello, Hardic. I didn't test it. I only investigated it. Do you need help yet?
  23. I found the driver for similar processor: https://github.com/allwinner-zh/linux-3.4-sunxi/tree/master/drivers/char/sunxi-scr
  24. Yes, this is SCR, not SPI. May be somebody worked with it...
  25. Hello guys. I have issue regarding with smart card reader interface. According to it's datasheet http://linux-sunxi.org/images/4/4b/Allwinner_H3_Datasheet_V1.2.pdf page " Support FIFOs for receive and transmit buffers (up to 128 characters) with threshold " But in practice, the size of FIFO is only 16 bytes. Is anybody worked with SCR interface? May be I must to select size of FIFO in some REGISTER? Thanks for help.