Jump to content

jonshouse

Members
  • Posts

    3
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Sorry for the delay. I've upgraded via apt-get upgrade, apt-get update. Am now running this kernel. I have the following shell script, I called it /lcd1 I login via ethernet/ssh as root and run the script, LCD comes up ok. After running anything that does regular framebuffer updates it still locks the display after a few mins, linux continues to run. mame seems to kill it quickly, dmesg has the following Note "[ 361.030817] [<c061bc00>] (wait_for_completion+0x20/0x24) from [<c03e944c>] (sunxi_spi_work+0x748/0x88c)" Is that a stall waiting for something in the SPI driver to unlock ? Anyhew, bottom line is it still does not work in any useful manner.
  2. I tried downgrading the kernel, it is not any better. Does anyone have any ideas what to try before I chuck the board in a box and ignore it for a year ? root@orangepizero:~# uname -a Linux orangepizero 3.4.112-sun8i #8 SMP PREEMPT Tue May 31 19:00:17 CEST 2016 armv7l armv7l armv7l GNU/Linux Thanks, Jon
  3. I am trying to use fbtft on the Orange Pi Zero, seems broken. Looks like an issue with the SPI driver itself. My skills are not enough to debug this. I am doing something like this: modprobe fbtft_device custom name=fb_ili9340 gpios=dc:3,reset:0 speed=32000000 busnum=1 rotate=90 The LCD functions but stops updating after a couple of mins. Linux is still running but dmesg shows a crash. Login shows "ARMBIAN 5.31 stable Ubuntu 16.04.3 LTS 3.4.113-sun8i" root@orangepizero:~# uname -a Linux orangepizero 3.4.113-sun8i #18 SMP PREEMPT Thu Jun 15 02:16:06 CEST 2017 armv7l armv7l armv7l GNU/Linux It is not related to SPI speed, i;ve tried as slow as 4Mhz. Anyone any ideas, this seems plain old broken to me rather than any configuration issue ? Thanks, Jon
×
×
  • Create New...